summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-11-05 03:49:39 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-11-05 03:49:39 +0000
commit7d6391de87c48e970681f8c14488d70a5969d266 (patch)
tree022fc7c8ab35c14def4ad0895617e025895f75de /x11-libs/gtk+
parentfix #10239 (diff)
downloadgentoo-2-7d6391de87c48e970681f8c14488d70a5969d266.tar.gz
gentoo-2-7d6391de87c48e970681f8c14488d70a5969d266.tar.bz2
gentoo-2-7d6391de87c48e970681f8c14488d70a5969d266.zip
New version of gtk+. removed the directfb stuff and here we go again
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog9
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-2.0.71
-rw-r--r--x11-libs/gtk+/gtk+-2.0.7.ebuild68
3 files changed, 77 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 684096f319e4..34b335d92eb4 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,7 +1,14 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.28 2002/10/27 15:19:16 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.29 2002/11/05 03:49:39 spider Exp $
+*gtk+-2.0.7 (04 Nov 2002)
+
+ 04 Nov 2002; Spider <spider@gentoo.org> gtk+-2.0.4.ebuild
+ files/digest-gtk+-2.0.4: added the latest stable release, bugfixes and nothing
+ more. Ripped out the directfb (wow, it survived more than 10 days! )
+
+
*gtk+-2.1.1 (27 Oct 2002)
27 Oct 2002; foser <foser@gentoo.org> gtk+-2.1.1.ebuild :
diff --git a/x11-libs/gtk+/files/digest-gtk+-2.0.7 b/x11-libs/gtk+/files/digest-gtk+-2.0.7
new file mode 100644
index 000000000000..24041ff7750e
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-2.0.7
@@ -0,0 +1 @@
+MD5 c9f641a22400660555094506f298e9b8 gtk+-2.0.7.tar.bz2 6319904
diff --git a/x11-libs/gtk+/gtk+-2.0.7.ebuild b/x11-libs/gtk+/gtk+-2.0.7.ebuild
new file mode 100644
index 000000000000..a87660758391
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.0.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.0.7.ebuild,v 1.1 2002/11/05 03:49:39 spider Exp $
+
+IUSE="tiff doc jpeg"
+
+inherit libtool flag-o-matic
+
+SLOT="2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Gimp ToolKit + "
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.0/${P}.tar.bz2"
+HOMEPAGE="http://www.gtk.org/"
+LICENSE="LGPL-2.1"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.0.7
+ >=dev-libs/atk-1.0.3-r1
+ >=x11-libs/pango-1.0.4-r1
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ directfb? ( >=dev-libs/DirectFB-0.9.13 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_compile() {
+ # see bug 8762
+ replace-flags "-O3" "-O2"
+
+ elibtoolize
+
+ local myconf=""
+ use doc \
+ && myconf="${myconf} --enable-gtk-doc" \
+ || myconf="${myconf} --disable-gtk-doc"
+ use jpeg || myconf="${myconf} --without-libjpeg"
+ use tiff || myconf="${myconf} --without-libtiff"
+ if [ -n "$DEBUG" ]; then
+ myconf="${myconf} --enable-debug"
+ fi
+
+ econf --with-gdktarget=x11 ${myconf} || die
+
+# gtk+ isn't multithread friendly due to some obscure code generation bug
+ make || die
+}
+
+src_install() {
+ dodir /etc/gtk-2.0
+ make DESTDIR=${D} \
+ prefix=/usr \
+ sysconfdir=/etc \
+ infodir=/usr/share/info \
+ mandir=/usr/share/man \
+ install || die
+ dodoc AUTHORS COPYING ChangeLog* HACKING* INSTALL NEWS* README* TODO
+}
+
+
+pkg_postinst() {
+ gtk-query-immodules-2.0 > /etc/gtk-2.0/gtk.immodules
+}
+