summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonny Davies <woodchip@gentoo.org>2001-08-30 04:33:21 +0000
committerDonny Davies <woodchip@gentoo.org>2001-08-30 04:33:21 +0000
commit2b6f60ab6fdff3db44447a6ea54b9ae837b5d78f (patch)
tree3776c5452abf45265b93c5b882aa4d469f0df3ed /x11-libs/gtk+
parentlooser restrictions on the pcmcia-cs ebuild (diff)
downloadgentoo-2-2b6f60ab6fdff3db44447a6ea54b9ae837b5d78f.tar.gz
gentoo-2-2b6f60ab6fdff3db44447a6ea54b9ae837b5d78f.tar.bz2
gentoo-2-2b6f60ab6fdff3db44447a6ea54b9ae837b5d78f.zip
Was installing info files to /usr/X11R6/info. Fixed to /usr/share/info
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/files/digest-gtk+-1.2.10-r31
-rw-r--r--x11-libs/gtk+/gtk+-1.2.10-r3.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-libs/gtk+/files/digest-gtk+-1.2.10-r3 b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r3
new file mode 100644
index 000000000000..7c7d628a46aa
--- /dev/null
+++ b/x11-libs/gtk+/files/digest-gtk+-1.2.10-r3
@@ -0,0 +1 @@
+MD5 4d5cb2fc7fb7830e4af9747a36bfce20 gtk+-1.2.10.tar.gz
diff --git a/x11-libs/gtk+/gtk+-1.2.10-r3.ebuild b/x11-libs/gtk+/gtk+-1.2.10-r3.ebuild
new file mode 100644
index 000000000000..586827d48c8a
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-1.2.10-r3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Achim Gottinger <achim@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-1.2.10-r3.ebuild,v 1.1 2001/08/30 04:33:21 woodchip Exp $
+
+A=${P}.tar.gz
+S=${WORKDIR}/${P}
+DESCRIPTION="gtk"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v1.2/${A}
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}
+ http://ftp.gnome.org/pub/GNOME/stable/sources/gtk+/${A}"
+
+DEPEND="virtual/glibc virtual/x11
+ >=dev-libs/glib-1.2.10"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/gtk-1.2.10.patch || die
+}
+
+src_compile() {
+ local myconf
+
+ if [ "${DEBUG}" ]
+ then
+ myconf="--enable-debug=yes"
+ else
+ myconf="--enable-debug=no"
+ fi
+
+ ./configure --host=${CHOST} --prefix=/usr/X11R6 ${myconf} \
+ --infodir=/usr/share/info --mandir=/usr/X11R6/man --sysconfdir=/etc/X11 \
+ --with-xinput=xfree --with-x || die
+
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+
+ preplib /usr/X11R6
+
+ dodoc AUTHORS COPYING ChangeLog* HACKING
+ dodoc NEWS* README* TODO
+ docinto docs
+ cd docs
+ dodoc *.txt *.gif text/*
+ cd html
+ docinto html
+ dodoc *.html *.gif
+
+ #install nice, clean-looking default gtk+ style
+ insinto /etc/X11/gtk
+ doins ${FILESDIR}/gtkrc
+}