summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2008-09-25 10:05:31 +0000
committerMart Raudsepp <leio@gentoo.org>2008-09-25 10:05:31 +0000
commit0f321a9fbd394e481cef5a1a0fa3c294f62e1eb8 (patch)
treec1cbfaf602792bf8131a9241df2cffd94ce50320 /x11-libs/gtk+
parentkeyword ~x86-fbsd (diff)
downloadgentoo-2-0f321a9fbd394e481cef5a1a0fa3c294f62e1eb8.tar.gz
gentoo-2-0f321a9fbd394e481cef5a1a0fa3c294f62e1eb8.tar.bz2
gentoo-2-0f321a9fbd394e481cef5a1a0fa3c294f62e1eb8.zip
Major version bump. Uses GIO (and indirectly gvfs for remote file support) directly for filechooser, with improved auto-completion; printer dialog can show status information; includes gail accessibility library with other a11y improvements; better keyboard compose sequences; jpeg2000 support for gdk-pixbuf with USE=jpeg2k; uses Xrandr for more and better monitor information; new API that helps removing use of libgnome(ui) by applications; and much much more
(Portage version: 2.2_rc9/cvs/Linux 2.6.26-gentoo-r1 x86_64)
Diffstat (limited to 'x11-libs/gtk+')
-rw-r--r--x11-libs/gtk+/ChangeLog13
-rw-r--r--x11-libs/gtk+/gtk+-2.14.3.ebuild153
2 files changed, 165 insertions, 1 deletions
diff --git a/x11-libs/gtk+/ChangeLog b/x11-libs/gtk+/ChangeLog
index 43ffccf40dc5..39d521139daa 100644
--- a/x11-libs/gtk+/ChangeLog
+++ b/x11-libs/gtk+/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for x11-libs/gtk+
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.396 2008/09/22 03:07:22 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/ChangeLog,v 1.397 2008/09/25 10:05:31 leio Exp $
+
+*gtk+-2.14.3 (25 Sep 2008)
+
+ 25 Sep 2008; Mart Raudsepp <leio@gentoo.org> +gtk+-2.14.3.ebuild:
+ Major version bump. Uses GIO (and indirectly gvfs for remote file support)
+ directly for filechooser, with improved auto-completion; printer dialog
+ can show status information; includes gail accessibility library with
+ other a11y improvements; better keyboard compose sequences; jpeg2000
+ support for gdk-pixbuf with USE=jpeg2k; uses Xrandr for more and better
+ monitor information; new API that helps removing use of libgnome(ui) by
+ applications; and much much more
*gtk+-2.12.12 (22 Sep 2008)
diff --git a/x11-libs/gtk+/gtk+-2.14.3.ebuild b/x11-libs/gtk+/gtk+-2.14.3.ebuild
new file mode 100644
index 000000000000..11d200186a4a
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.14.3.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.14.3.ebuild,v 1.1 2008/09/25 10:05:31 leio Exp $
+
+WANT_AUTOMAKE="1.7"
+
+inherit gnome.org flag-o-matic eutils libtool virtualx
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="cups debug doc jpeg jpeg2k tiff vim-syntax xinerama"
+
+RDEPEND="x11-libs/libXrender
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXt
+ x11-libs/libXext
+ >=x11-libs/libXrandr-1.2
+ x11-libs/libXcursor
+ x11-libs/libXfixes
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ xinerama? ( x11-libs/libXinerama )
+ >=dev-libs/glib-2.17.6
+ >=x11-libs/pango-1.20
+ >=dev-libs/atk-1.13
+ >=x11-libs/cairo-1.6
+ media-libs/fontconfig
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ cups? ( net-print/cups )
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ jpeg2k? ( media-libs/jasper )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ !<gnome-base/gail-1000"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ x11-proto/xextproto
+ x11-proto/xproto
+ x11-proto/inputproto
+ x11-proto/damageproto
+ xinerama? ( x11-proto/xineramaproto )
+ >=dev-util/gtk-doc-am-1.8
+ doc? (
+ >=dev-util/gtk-doc-1.8
+ ~app-text/docbook-xml-dtd-4.1.2
+ )"
+PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
+
+pkg_setup() {
+ if ! built_with_use x11-libs/cairo X; then
+ eerror "Please re-emerge x11-libs/cairo with the X USE flag set"
+ die "cairo needs the X flag set"
+ fi
+}
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch "${FILESDIR}/${PN}-2.8.0-multilib.patch"
+
+ # Workaround adobe flash infinite loop. Patch from http://bugzilla.gnome.org/show_bug.cgi?id=463773#c11
+ epatch "${FILESDIR}/${PN}-2.12.0-flash-workaround.patch"
+
+ # -O3 and company cause random crashes in applications. Bug #133469
+ replace-flags -O3 -O2
+ strip-flags
+
+ use ppc64 && append-flags -mminimal-toc
+
+ elibtoolize
+}
+
+src_compile() {
+ # png always on to display icons (foser)
+ local myconf="$(use_enable doc gtk-doc) \
+ $(use_with jpeg libjpeg) \
+ $(use_with jpeg2k libjasper) \
+ $(use_with tiff libtiff) \
+ $(use_enable xinerama) \
+ $(use_enable cups cups auto) \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput"
+
+ # Passing --disable-debug is not recommended for production use
+ use debug && myconf="${myconf} --enable-debug=yes"
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_test() {
+ Xemake check || die "tests failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ # see bug #133241
+ echo 'gtk-fallback-icon-theme = "gnome"' > "${D}/${GTK2_CONFDIR}/gtkrc"
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" > "${D}/etc/env.d/50gtk2"
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+
+ # This has to be removed, because it's multilib specific; generated in
+ # postinst
+ rm "${D}/etc/gtk-2.0/gtk.immodules"
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ if [ -d "${ROOT}${GTK2_CONFDIR}" ]; then
+ gtk-query-immodules-2.0 > "${ROOT}${GTK2_CONFDIR}/gtk.immodules"
+ gdk-pixbuf-query-loaders > "${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders"
+ else
+ ewarn "The destination path ${ROOT}${GTK2_CONFDIR} doesn't exist;"
+ ewarn "to complete the installation of GTK+, please create the"
+ ewarn "directory and then manually run:"
+ ewarn " cd ${ROOT}${GTK2_CONFDIR}"
+ ewarn " gtk-query-immodules-2.0 > gtk.immodules"
+ ewarn " gdk-pixbuf-query-loaders > gdk-pixbuf.loaders"
+ fi
+
+ if [ -e /usr/lib/gtk-2.0/2.[^1]* ]; then
+ elog "You need to rebuild ebuilds that installed into" /usr/lib/gtk-2.0/2.[^1]*
+ elog "to do that you can use qfile from portage-utils:"
+ elog "emerge -va1 \$(qfile -qC /usr/lib/gtk-2.0/2.[^1]*)"
+ fi
+
+ elog "Please install app-text/evince for print preview functionality"
+}