summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeonardo Boshell <leonardop@gentoo.org>2005-11-15 16:58:27 +0000
committerLeonardo Boshell <leonardop@gentoo.org>2005-11-15 16:58:27 +0000
commitc96e8801004472e769c2a60e489b1cd1685edfc9 (patch)
treeda6c73699b714e10974ed93be67575d398568784 /x11-libs/gtk+/gtk+-2.6.10-r1.ebuild
parentUpdated to latest upstream version. ffmpeg useflag is disabled until a newer ... (diff)
downloadgentoo-2-c96e8801004472e769c2a60e489b1cd1685edfc9.tar.gz
gentoo-2-c96e8801004472e769c2a60e489b1cd1685edfc9.tar.bz2
gentoo-2-c96e8801004472e769c2a60e489b1cd1685edfc9.zip
New revisions including a patch to fix a vulnerability inside gdk-pixbuf (bug #112608).
(Portage version: 2.0.53_rc7)
Diffstat (limited to 'x11-libs/gtk+/gtk+-2.6.10-r1.ebuild')
-rw-r--r--x11-libs/gtk+/gtk+-2.6.10-r1.ebuild108
1 files changed, 108 insertions, 0 deletions
diff --git a/x11-libs/gtk+/gtk+-2.6.10-r1.ebuild b/x11-libs/gtk+/gtk+-2.6.10-r1.ebuild
new file mode 100644
index 000000000000..4f065f097874
--- /dev/null
+++ b/x11-libs/gtk+/gtk+-2.6.10-r1.ebuild
@@ -0,0 +1,108 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtk+/gtk+-2.6.10-r1.ebuild,v 1.1 2005/11/15 16:58:27 leonardop Exp $
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="Gimp ToolKit +"
+HOMEPAGE="http://www.gtk.org/"
+SRC_URI="ftp://ftp.gtk.org/pub/gtk/v2.6/${P}.tar.bz2
+ mirror://gentoo/gtk+-2.6-smoothscroll-r5.patch.bz2
+ amd64? ( http://dev.gentoo.org/~kingtaco/gtk+-2.6.1-lib64.patch.bz2 )"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 ~arm hppa ~ia64 ~mips ppc ppc64 sparc x86"
+IUSE="doc tiff jpeg"
+
+RDEPEND="virtual/x11
+ >=dev-libs/glib-2.6
+ >=dev-libs/atk-1.0.1
+ >=x11-libs/pango-1.8
+ x11-misc/shared-mime-info
+ >=media-libs/libpng-1.2.1
+ jpeg? ( >=media-libs/jpeg-6b-r2 )
+ tiff? ( >=media-libs/tiff-3.5.7 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ sys-devel/autoconf
+ >=sys-devel/automake-1.7.9
+ doc? ( >=dev-util/gtk-doc-1 )"
+
+
+set_gtk2_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ use x86 && [ "$(get_libdir)" == "lib32" ] && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix problems in gdk-pixbuf's code regarding XPM files. Bug #112608.
+ epatch "${FILESDIR}"/${PN}-2-xpm_loader.patch
+ # beautifying patch for disabled icons
+ epatch "${FILESDIR}"/${PN}-2.2.1-disable_icons_smooth_alpha.patch
+ # add smoothscroll support for usability reasons
+ # http://bugzilla.gnome.org/show_bug.cgi?id=103811
+ epatch "${DISTDIR}"/${PN}-2.6-smoothscroll-r5.patch.bz2
+
+ # use an arch-specific config directory so that 32bit and 64bit versions
+ # dont clash on multilib systems
+ has_multilib_profile && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
+ # and this line is just here to make building emul-linux-x86-gtklibs a bit
+ # easier, so even this should be amd64 specific.
+ use x86 && [ "$(get_libdir)" == "lib32" ] && epatch ${DISTDIR}/gtk+-2.6.1-lib64.patch.bz2
+
+ # patch for ppc64 (#64359,#109089)
+ use ppc64 && ! has_version '>=dev-libs/glib-2.8' && epatch ${FILESDIR}/${PN}-2.4.9-ppc64.patch
+ use ppc64 && append-flags -mminimal-toc
+
+ autoconf || die "autoconf failed"
+ automake || die "automake failed"
+
+ epunt_cxx
+}
+
+src_compile() {
+
+ # bug 8762
+ replace-flags "-O3" "-O2"
+
+ econf \
+ `use_enable doc gtk-doc` \
+ `use_with jpeg libjpeg` \
+ `use_with tiff libtiff` \
+ --with-libpng \
+ --with-gdktarget=x11 \
+ --with-xinput \
+ || die
+
+ # gtk+ isn't multithread friendly due to some obscure code generation bug
+ emake -j1 || die "Compilation failed"
+
+}
+
+src_install() {
+ set_gtk2_confdir
+ dodir ${GTK2_CONFDIR}
+ keepdir ${GTK2_CONFDIR}
+
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ # Enable xft in environment as suggested by <utx@gentoo.org>
+ dodir /etc/env.d
+ echo "GDK_USE_XFT=1" >${D}/etc/env.d/50gtk2
+
+ dodoc AUTHORS ChangeLog* HACKING NEWS* README*
+}
+
+pkg_postinst() {
+ set_gtk2_confdir
+
+ gtk-query-immodules-2.0 > ${ROOT}${GTK2_CONFDIR}/gtk.immodules
+ gdk-pixbuf-query-loaders > ${ROOT}${GTK2_CONFDIR}/gdk-pixbuf.loaders
+}