summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-01 18:20:16 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-01 18:20:16 +0000
commit84634d37e78ebaad1de6f55b453a06dc911e1924 (patch)
tree76c4eff9d8447b78b2b30a975f6921069d2a05f4 /x11-libs/goocanvas
parentremove old (diff)
downloadgentoo-2-84634d37e78ebaad1de6f55b453a06dc911e1924.tar.gz
gentoo-2-84634d37e78ebaad1de6f55b453a06dc911e1924.tar.bz2
gentoo-2-84634d37e78ebaad1de6f55b453a06dc911e1924.zip
Version bump wrt #219954, thanks to Dieter Verfaillie for reporting.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/ChangeLog8
-rw-r--r--x11-libs/goocanvas/goocanvas-0.10.ebuild36
-rw-r--r--x11-libs/goocanvas/goocanvas-0.8.ebuild23
-rw-r--r--x11-libs/goocanvas/goocanvas-0.9.ebuild33
4 files changed, 43 insertions, 57 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index 047f616082fe..ecbeff5ed0b1 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/goocanvas
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.8 2008/01/31 21:11:51 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.9 2008/05/01 18:20:16 drac Exp $
+
+*goocanvas-0.10 (01 May 2008)
+
+ 01 May 2008; Samuli Suominen <drac@gentoo.org> -goocanvas-0.8.ebuild,
+ -goocanvas-0.9.ebuild, +goocanvas-0.10.ebuild:
+ Version bump wrt #219954, thanks to Dieter Verfaillie for reporting.
31 Jan 2008; Michael Hanselmann <hansmi@gentoo.org> metadata.xml:
Remove myself as maintainer.
diff --git a/x11-libs/goocanvas/goocanvas-0.10.ebuild b/x11-libs/goocanvas/goocanvas-0.10.ebuild
new file mode 100644
index 000000000000..d8beef16666c
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-0.10.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-0.10.ebuild,v 1.1 2008/05/01 18:20:16 drac Exp $
+
+inherit libtool
+
+DESCRIPTION="GooCanvas is a canvas widget for GTK+ using the cairo 2D library for drawing."
+HOMEPAGE="http://sourceforge.net/projects/goocanvas"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # Needed for FreeBSD - Please do not remove
+ elibtoolize
+}
+
+src_compile() {
+ econf --disable-dependency-tracking --disable-gtk-doc
+ emake || die "emake failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/x11-libs/goocanvas/goocanvas-0.8.ebuild b/x11-libs/goocanvas/goocanvas-0.8.ebuild
deleted file mode 100644
index 9d645f74a5e3..000000000000
--- a/x11-libs/goocanvas/goocanvas-0.8.ebuild
+++ /dev/null
@@ -1,23 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-0.8.ebuild,v 1.2 2007/04/27 23:24:49 hansmi Exp $
-
-IUSE=""
-
-DESCRIPTION="GooCanvas is a canvas widget for GTK+ using the cairo 2D library for drawing."
-HOMEPAGE="http://goocanvas.sourceforge.net/"
-SRC_URI="mirror://sourceforge/goocanvas/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~ppc ~x86"
-
-DEPEND="
- >=x11-libs/gtk+-2.10.0
- x11-libs/cairo
- dev-util/pkgconfig
-"
-
-src_install() {
- einstall || die
-}
diff --git a/x11-libs/goocanvas/goocanvas-0.9.ebuild b/x11-libs/goocanvas/goocanvas-0.9.ebuild
deleted file mode 100644
index e18fe69275c8..000000000000
--- a/x11-libs/goocanvas/goocanvas-0.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-0.9.ebuild,v 1.3 2007/11/09 19:47:32 lavajoe Exp $
-
-inherit libtool
-
-IUSE=""
-
-DESCRIPTION="GooCanvas is a canvas widget for GTK+ using the cairo 2D library for drawing."
-HOMEPAGE="http://sourceforge.net/projects/goocanvas/"
-SRC_URI="mirror://sourceforge/goocanvas/${P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
-
-DEPEND="
- >=x11-libs/gtk+-2.10.0
- x11-libs/cairo
- dev-util/pkgconfig
-"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Needed for FreeBSD - Please do not remove
- elibtoolize
-}
-
-src_install() {
- einstall || die
-}