summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2009-01-18 21:14:44 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2009-01-18 21:14:44 +0000
commit7996c412c9282d6e6503ee4b2fa9514f47c845b0 (patch)
treebee26275e4899280f72bad9bdbf524292bb7094e /x11-libs/goocanvas
parentBump ganglia-3.1.1-r1. Patch added to prevent a buffer overflow. Gentoo #25... (diff)
downloadgentoo-2-7996c412c9282d6e6503ee4b2fa9514f47c845b0.tar.gz
gentoo-2-7996c412c9282d6e6503ee4b2fa9514f47c845b0.tar.bz2
gentoo-2-7996c412c9282d6e6503ee4b2fa9514f47c845b0.zip
Bump to 0.13.
(Portage version: 2.2_rc20/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'x11-libs/goocanvas')
-rw-r--r--x11-libs/goocanvas/ChangeLog10
-rw-r--r--x11-libs/goocanvas/goocanvas-0.13.ebuild40
2 files changed, 48 insertions, 2 deletions
diff --git a/x11-libs/goocanvas/ChangeLog b/x11-libs/goocanvas/ChangeLog
index fe3efa86d74f..a9ca25a8e18f 100644
--- a/x11-libs/goocanvas/ChangeLog
+++ b/x11-libs/goocanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/goocanvas
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.10 2008/12/14 22:57:07 eva Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/ChangeLog,v 1.11 2009/01/18 21:14:44 eva Exp $
+
+*goocanvas-0.13 (18 Jan 2009)
+
+ 18 Jan 2009; Gilles Dartiguelongue <eva@gentoo.org>
+ +goocanvas-0.13.ebuild:
+ Bump to 0.13.
14 Dec 2008; Gilles Dartiguelongue <eva@gentoo.org> goocanvas-0.10.ebuild:
Build fix for gtk+-2.14.
diff --git a/x11-libs/goocanvas/goocanvas-0.13.ebuild b/x11-libs/goocanvas/goocanvas-0.13.ebuild
new file mode 100644
index 000000000000..804b49945439
--- /dev/null
+++ b/x11-libs/goocanvas/goocanvas-0.13.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goocanvas/goocanvas-0.13.ebuild,v 1.1 2009/01/18 21:14:44 eva Exp $
+
+inherit gnome2 libtool
+
+DESCRIPTION="GooCanvas is a canvas widget for GTK+ using the cairo 2D library for drawing."
+HOMEPAGE="http://live.gnome.org/GooCanvas"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+RDEPEND=">=x11-libs/gtk+-2.10
+ >=dev-libs/glib-2.10
+ >=x11-libs/cairo-1.4"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( >=dev-util/gtk-doc-1.8 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --disable-rebuilds"
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fails to build with recent GTK+
+ sed -e "s/-D.*_DISABLE_DEPRECATED//g" \
+ -i src/Makefile.am src/Makefile.in demo/Makefile.am demo/Makefile.in \
+ || die "sed failed"
+
+ # Needed for FreeBSD - Please do not remove
+ elibtoolize
+}
+