summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-09-03 21:56:12 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-09-03 21:56:12 +0000
commit2f3616c801082e6b66fc6ee634f8fd53f3be5386 (patch)
tree205d8853cb0f25de6e1c6d382e3541eacac500c8 /x11-libs/goffice/goffice-0.6.5.ebuild
parentAtoms must not have a "." before a trailing "*". (diff)
downloadgentoo-2-2f3616c801082e6b66fc6ee634f8fd53f3be5386.tar.gz
gentoo-2-2f3616c801082e6b66fc6ee634f8fd53f3be5386.tar.bz2
gentoo-2-2f3616c801082e6b66fc6ee634f8fd53f3be5386.zip
bump to 0.6.5.
(Portage version: 2.2_rc8/cvs/Linux 2.6.24-gentoo-r8-mactel x86_64)
Diffstat (limited to 'x11-libs/goffice/goffice-0.6.5.ebuild')
-rw-r--r--x11-libs/goffice/goffice-0.6.5.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/x11-libs/goffice/goffice-0.6.5.ebuild b/x11-libs/goffice/goffice-0.6.5.ebuild
new file mode 100644
index 000000000000..c90648525ffe
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.6.5.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.6.5.ebuild,v 1.1 2008/09/03 21:56:12 eva Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.6"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome"
+
+# Raising glib dep to 2.14 to drop pcre dependency
+# cairo support broken and -gtk broken
+
+RDEPEND=">=dev-libs/glib-2.14
+ >=gnome-extra/libgsf-1.13.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.6
+ >=media-libs/libart_lgpl-2.3.11
+ >=x11-libs/cairo-1.2
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with gnome)"
+
+ local diemessage=""
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "Please rebuild gnome-extra/libgsf with gnome support enabled"
+ eerror "echo \"gnome-extra/libgsf gnome\" >> /etc/portage/package.use"
+ eerror "or add \"gnome\" to your USE string in /etc/make.conf"
+ diemessage="No Gnome support found in libgsf."
+ fi
+
+ if ! built_with_use x11-libs/cairo svg ; then
+ eerror "Please rebuild x11-libs/cairo with svg support enabled"
+ eerror "echo \"x11-libs/cairo svg\" >> /etc/portage/package.use"
+ eerror "emerge -1 x11-libs/cairo"
+ diemessage="${diemessage} No SVG support found in cairo."
+ fi
+
+ [ -n "${diemessage}" ] && die ${diemessage}
+}
+
+src_compile() {
+ filter-flags -ffast-math
+ gnome2_src_compile
+}