summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2007-12-10 23:11:22 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2007-12-10 23:11:22 +0000
commitb5e54cc24f7b5a83b3e162f2af5e05d4ded76d18 (patch)
treeaa86fe77353ac70fdccaa53bf4e0e6e66c74cf4a /x11-libs/goffice/goffice-0.4.3.ebuild
parentpull in x11-libs/libXrandr for USE=X #201186 by Jon Daniel (diff)
downloadgentoo-2-b5e54cc24f7b5a83b3e162f2af5e05d4ded76d18.tar.gz
gentoo-2-b5e54cc24f7b5a83b3e162f2af5e05d4ded76d18.tar.bz2
gentoo-2-b5e54cc24f7b5a83b3e162f2af5e05d4ded76d18.zip
add 0.4.3 to fix bug #198385, remove old unstable release and move all in slots
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'x11-libs/goffice/goffice-0.4.3.ebuild')
-rw-r--r--x11-libs/goffice/goffice-0.4.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/x11-libs/goffice/goffice-0.4.3.ebuild b/x11-libs/goffice/goffice-0.4.3.ebuild
new file mode 100644
index 000000000000..53c856711a1f
--- /dev/null
+++ b/x11-libs/goffice/goffice-0.4.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/goffice/goffice-0.4.3.ebuild,v 1.1 2007/12/10 23:11:21 eva Exp $
+
+inherit eutils gnome2 flag-o-matic
+
+DESCRIPTION="A library of document-centric objects and utilities"
+HOMEPAGE="http://freshmeat.net/projects/goffice/"
+
+LICENSE="GPL-2"
+SLOT="0.4"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc gnome"
+#cairo support broken and -gtk broken
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=gnome-extra/libgsf-1.13.3
+ >=dev-libs/libxml2-2.4.12
+ >=x11-libs/pango-1.8.1
+ >=x11-libs/gtk+-2.6
+ >=gnome-base/libglade-2.3.6
+ >=gnome-base/libgnomeprint-2.8.2
+ >=media-libs/libart_lgpl-2.3.11
+ >=x11-libs/cairo-1.2
+ gnome? (
+ >=gnome-base/gconf-2
+ >=gnome-base/libgnomeui-2 )
+ dev-libs/libpcre"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.18
+ >=dev-util/intltool-0.28
+ doc? ( >=dev-util/gtk-doc-1.4 )"
+
+DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} $(use_with gnome)"
+
+ if use gnome && ! built_with_use gnome-extra/libgsf gnome; then
+ eerror "Please rebuild gnome-extra/libgsf with gnome support enabled"
+ eerror "USE=\"gnome\" emerge gnome-extra/libgsf"
+ eerror "or add \"gnome\" to your USE string in /etc/make.conf"
+ die "No Gnome support found in libgsf"
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ # fix tests
+ echo "goffice/component/go-component-factory.c" >> po/POTFILES.in
+ echo "goffice/graph/gog-graph-prefs.glade" >> po/POTFILES.in
+ echo "goffice/graph/gog-renderer-cairo.c" >> po/POTFILES.in
+ echo "goffice/graph/gog-series-prefs.glade" >> po/POTFILES.in
+ echo "goffice/graph/gog-smoothed-curve.c" >> po/POTFILES.in
+ echo "goffice/graph/gog-trend-line.c" >> po/POTFILES.in
+ echo "goffice/gtk/go-color-selector.c" >> po/POTFILES.in
+ echo "goffice/gtk/go-image-save-dialog-extra.glade" >> po/POTFILES.in
+ echo "goffice/gtk/go-palette.c" >> po/POTFILES.in
+ echo "plugins/plot_boxes/gog-histogram.c" >> po/POTFILES.in
+ echo "plugins/reg_linear/gog-power-reg.c" >> po/POTFILES.in
+}
+
+src_compile() {
+ filter-flags -ffast-math
+ gnome2_src_compile
+}
+