summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-11-27 05:33:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-11-27 05:33:45 +0000
commit479252b62c02c4051c87728cb017ba926d5f941c (patch)
tree477a2c31099c91a4455e36b9492f2cf421ebc68a /x11-libs/gl2ps
parentBuild in the source tree. (diff)
downloadgentoo-2-479252b62c02c4051c87728cb017ba926d5f941c.tar.gz
gentoo-2-479252b62c02c4051c87728cb017ba926d5f941c.tar.bz2
gentoo-2-479252b62c02c4051c87728cb017ba926d5f941c.zip
Version bump
(Portage version: 2.1.10.37/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/gl2ps')
-rw-r--r--x11-libs/gl2ps/ChangeLog8
-rw-r--r--x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch61
-rw-r--r--x11-libs/gl2ps/gl2ps-1.3.6.ebuild44
3 files changed, 112 insertions, 1 deletions
diff --git a/x11-libs/gl2ps/ChangeLog b/x11-libs/gl2ps/ChangeLog
index eff9f7bf0f36..23a667a60f91 100644
--- a/x11-libs/gl2ps/ChangeLog
+++ b/x11-libs/gl2ps/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/gl2ps
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.14 2011/05/17 09:53:51 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/ChangeLog,v 1.15 2011/11/27 05:33:45 bicatali Exp $
+
+*gl2ps-1.3.6 (27 Nov 2011)
+
+ 27 Nov 2011; Sébastien Fabbro <bicatali@gentoo.org> +gl2ps-1.3.6.ebuild,
+ +files/gl2ps-1.3.6-CMakeLists.patch:
+ Version bump
17 May 2011; Justin Lecher <jlec@gentoo.org> gl2ps-1.3.5.ebuild,
gl2ps-1.3.5-r2.ebuild, files/gl2ps-1.3.5-CMakeLists.patch:
diff --git a/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
new file mode 100644
index 000000000000..53e0fba7e493
--- /dev/null
+++ b/x11-libs/gl2ps/files/gl2ps-1.3.6-CMakeLists.patch
@@ -0,0 +1,61 @@
+--- CMakeLists.txt.orig 2011-08-14 18:15:31.000000000 +0100
++++ CMakeLists.txt 2011-11-27 05:25:50.000000000 +0000
+@@ -46,6 +46,7 @@
+
+ option(ENABLE_ZLIB "Enable compression using ZLIB" ON)
+ option(ENABLE_PNG "Enable PNG support" ON)
++option(ENABLE_DOC "Enable documentation" OFF)
+
+ set(GL2PS_MAJOR_VERSION 1)
+ set(GL2PS_MINOR_VERSION 3)
+@@ -103,8 +104,6 @@
+ include_directories(${EXTERNAL_INCLUDES})
+
+ if(OPENGL_FOUND)
+- add_library(lib STATIC gl2ps.c gl2ps.h)
+- set_target_properties(lib PROPERTIES OUTPUT_NAME gl2ps)
+
+ add_library(shared SHARED gl2ps.c gl2ps.h)
+ target_link_libraries(shared ${EXTERNAL_LIBRARIES})
+@@ -116,29 +115,22 @@
+ set_target_properties(shared PROPERTIES COMPILE_FLAGS "-DGL2PSDLL -DGL2PSDLL_EXPORTS")
+ endif(MSVC)
+
+- install(TARGETS lib shared DESTINATION lib)
++ install(TARGETS shared DESTINATION lib${LIB_SUFFIX})
+ endif(OPENGL_FOUND)
+
+ if(WIN32)
+ set(GL2PS_DOC .)
+ else(WIN32)
+- set(GL2PS_DOC share/doc/gl2ps)
++ set(GL2PS_DOC share/doc/gl2ps-${GL2PS_VERSION})
+ endif(WIN32)
+
+ install(FILES gl2ps.h DESTINATION include)
+ install(FILES ${CMAKE_SOURCE_DIR}/README.txt DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.LGPL DESTINATION ${GL2PS_DOC})
+-install(FILES ${CMAKE_SOURCE_DIR}/COPYING.GL2PS DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTest.c DESTINATION ${GL2PS_DOC})
++install(FILES ${CMAKE_SOURCE_DIR}/TODO.txt DESTINATION ${GL2PS_DOC})
+ install(FILES ${CMAKE_SOURCE_DIR}/gl2psTestSimple.c DESTINATION ${GL2PS_DOC})
+
+-if(GLUT_FOUND)
+- add_executable(gl2psTest WIN32 gl2psTest.c)
+- target_link_libraries(gl2psTest lib ${EXTERNAL_LIBRARIES})
+- add_executable(gl2psTestSimple WIN32 gl2psTestSimple.c)
+- target_link_libraries(gl2psTestSimple lib ${EXTERNAL_LIBRARIES})
+-endif(GLUT_FOUND)
+-
++if(ENABLE_DOC)
+ find_package(LATEX)
+ if(PDFLATEX_COMPILER)
+ add_custom_command(OUTPUT gl2ps.pdf DEPENDS gl2ps.tex
+@@ -157,6 +149,7 @@
+ add_custom_target(html DEPENDS gl2ps.html)
+ endif(TTH)
+ endif(PDFLATEX_COMPILER)
++endif(ENABLE_DOC)
+
+ set(CPACK_PACKAGE_VENDOR "Christophe Geuzaine")
+ set(CPACK_PACKAGE_VERSION_MAJOR ${GL2PS_MAJOR_VERSION})
diff --git a/x11-libs/gl2ps/gl2ps-1.3.6.ebuild b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
new file mode 100644
index 000000000000..5cd7e92ebae2
--- /dev/null
+++ b/x11-libs/gl2ps/gl2ps-1.3.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/gl2ps/gl2ps-1.3.6.ebuild,v 1.1 2011/11/27 05:33:45 bicatali Exp $
+
+EAPI=4
+inherit cmake-utils multilib
+
+DESCRIPTION="OpenGL to PostScript printing library"
+HOMEPAGE="http://www.geuz.org/gl2ps/"
+SRC_URI="http://geuz.org/${PN}/src/${P}.tgz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc png zlib"
+
+DEPEND="
+ media-libs/freeglut
+ png? ( media-libs/libpng )
+ doc? ( dev-tex/tth dev-texlive/texlive-latex )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${P}-source
+
+PATCHES=( "${FILESDIR}"/${P}-CMakeLists.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_enable png PNG)
+ $(cmake-utils_use_enable zlib ZLIB)
+ $(cmake-utils_use_enable doc DOC)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ install_name_tool \
+ -id "${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib \
+ "${D%/}${EPREFIX}"/usr/$(get_libdir)/libgl2ps.dylib || die
+ fi
+}