summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatti Bickel <mabi@gentoo.org>2008-08-10 14:14:26 +0000
committerMatti Bickel <mabi@gentoo.org>2008-08-10 14:14:26 +0000
commit4878a2da832aa8299cd9aed434096747a0c79df0 (patch)
tree58a34e855f0ee7dbb3c4f83088664c1aa2d8996b /x11-libs/fxscintilla
parentVersion bump, fixing security issues from #225465 and #234224 (diff)
downloadgentoo-2-4878a2da832aa8299cd9aed434096747a0c79df0.tar.gz
gentoo-2-4878a2da832aa8299cd9aed434096747a0c79df0.tar.bz2
gentoo-2-4878a2da832aa8299cd9aed434096747a0c79df0.zip
removed ebuild re bug #226635
(Portage version: 2.2_rc6/cvs/Linux 2.6.23-gentoo-r3-20080120 ppc)
Diffstat (limited to 'x11-libs/fxscintilla')
-rw-r--r--x11-libs/fxscintilla/ChangeLog6
-rw-r--r--x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild4
-rw-r--r--x11-libs/fxscintilla/fxscintilla-1.71.ebuild108
3 files changed, 7 insertions, 111 deletions
diff --git a/x11-libs/fxscintilla/ChangeLog b/x11-libs/fxscintilla/ChangeLog
index 36f2939a1320..34a7f47f58bc 100644
--- a/x11-libs/fxscintilla/ChangeLog
+++ b/x11-libs/fxscintilla/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-libs/fxscintilla
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.39 2008/02/17 21:37:12 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/ChangeLog,v 1.40 2008/08/10 14:14:26 mabi Exp $
+
+ 10 Aug 2008; Matti Bickel <mabi@gentoo.org> -fxscintilla-1.71.ebuild,
+ fxscintilla-1.71-r1.ebuild:
+ removed ebuild re bug #226635
17 Feb 2008; Matti Bickel <mabi@gentoo.org> fxscintilla-1.71-r1.ebuild:
add missing inherit autotools (bug #204606)
diff --git a/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild b/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild
index d6cbff17bd06..1ea3e0fe14b9 100644
--- a/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild
+++ b/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild,v 1.8 2008/02/17 21:37:12 mabi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.71-r1.ebuild,v 1.9 2008/08/10 14:14:26 mabi Exp $
inherit autotools eutils multilib
@@ -25,7 +25,7 @@ src_unpack() {
einfo "Running autoreconf..."
touch NEWS AUTHORS
- autoreconf --install --force || die "autoreconf error"
+ eautoreconf || die "autoreconf error"
}
src_compile () {
diff --git a/x11-libs/fxscintilla/fxscintilla-1.71.ebuild b/x11-libs/fxscintilla/fxscintilla-1.71.ebuild
deleted file mode 100644
index 9a652fc0d4b5..000000000000
--- a/x11-libs/fxscintilla/fxscintilla-1.71.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fxscintilla/fxscintilla-1.71.ebuild,v 1.14 2007/04/19 12:28:05 fmccor Exp $
-
-inherit eutils multilib
-
-DESCRIPTION="A free source code editing component for the FOX-Toolkit"
-HOMEPAGE="http://www.nongnu.org/fxscintilla/"
-SRC_URI="http://savannah.nongnu.org/download/fxscintilla/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 hppa ~ppc ~ppc64 ~sparc x86"
-IUSE="doc"
-
-DEPEND="=x11-libs/fox-1.2*
- =x11-libs/fox-1.4*
- =x11-libs/fox-1.6*"
-
-src_unpack() {
- unpack ${A}
- cd ${S}
-
- epatch ${FILESDIR}/1.71-shared-libs.patch || die
- epatch ${FILESDIR}/1.71-fox-SLOT.patch || die
-
- einfo "Running autoreconf..."
- touch NEWS AUTHORS
- autoreconf --install --force || die "autoreconf error"
-}
-
-src_compile () {
- # Borrowed from wxGTK ebuild
-
- einfo "Building ${PN} for FOX-1.2..."
- mkdir ${S}/build_1_2
- cd ${S}/build_1_2
- ../configure \
- --prefix=/usr \
- --includedir=/usr/include \
- --libdir=/usr/$(get_libdir) \
- ${EXTRA_ECONF} \
- --enable-nolexer \
- --with-fox-1-2 \
- --with-foxinclude=/usr/include \
- --with-foxlib=/usr/lib \
- || die "configure error"
- emake || die "make error"
-
- einfo "Building ${PN} for FOX-1.4..."
- mkdir ${S}/build_1_4
- cd ${S}/build_1_4
- ../configure \
- --prefix=/usr \
- --includedir=/usr/include \
- --libdir=/usr/$(get_libdir) \
- ${EXTRA_ECONF} \
- --enable-nolexer \
- --with-fox-1-4 \
- --with-foxinclude=/usr/include \
- --with-foxlib=/usr/lib \
- || die "configure error"
- emake || die "make error"
-
- einfo "Building ${PN} for FOX-1.6..."
- mkdir ${S}/build_1_6
- cd ${S}/build_1_6
- ../configure \
- --prefix=/usr \
- --includedir=/usr/include \
- --libdir=/usr/$(get_libdir) \
- ${EXTRA_ECONF} \
- --enable-nolexer \
- --with-fox-1-6 \
- --with-foxinclude=/usr/include \
- || die "configure error"
- emake || die "make error"
-}
-
-src_install () {
- cd ${S}/build_1_2
- emake DESTDIR="${D}" install || die "make install error"
-
- cd ${S}/build_1_4
- emake DESTDIR="${D}" install || die "make install error"
-
- cd ${S}/build_1_6
- emake DESTDIR="${D}" install || die "make install error"
-
- cd ${S}
- dodoc README
- if use doc ; then
- dodoc scintilla/doc/Lexer.txt
- dohtml scintilla/doc/*
- fi
-}
-
-pkg_postinst() {
- elog "New as of 1.71:"
- elog "FXScintilla is now built separately against FOX-1.2,-1.4 and -1.6."
- elog "Support for FOX-1.0 has been dropped upstream."
- elog "The Librarys are named for the FOX-release they correspond to, for"
- elog "example: For FOX-1.2, the library is called libfxscintilla-1.2."
- elog "Anything linked against previous releases of FOX and fxscintilla"
- elog "may need to be rebuilt."
- elog
- elog "The nolexer libraries are now included in this release as well."
-}