summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-12-18 09:13:37 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-12-18 09:13:37 +0000
commitc7a494578b0ba743c8750b9da4f93220c5f337ff (patch)
tree134fe9aebd3951b97a2cc5919680999730ad9503 /x11-libs/fox
parentstable x86, bug #158342 (diff)
downloadgentoo-2-c7a494578b0ba743c8750b9da4f93220c5f337ff.tar.gz
gentoo-2-c7a494578b0ba743c8750b9da4f93220c5f337ff.tar.bz2
gentoo-2-c7a494578b0ba743c8750b9da4f93220c5f337ff.zip
resurrect fox-1.0.53.ebuild which is also still in use
(Portage version: 2.1.1-r2)
Diffstat (limited to 'x11-libs/fox')
-rw-r--r--x11-libs/fox/ChangeLog7
-rw-r--r--x11-libs/fox/files/digest-fox-1.0.533
-rw-r--r--x11-libs/fox/fox-1.0.53.ebuild40
3 files changed, 49 insertions, 1 deletions
diff --git a/x11-libs/fox/ChangeLog b/x11-libs/fox/ChangeLog
index ef11d61a9b47..bae01258107b 100644
--- a/x11-libs/fox/ChangeLog
+++ b/x11-libs/fox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fox
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.72 2006/12/18 02:53:08 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/ChangeLog,v 1.73 2006/12/18 09:13:37 mr_bones_ Exp $
+
+*fox-1.0.53 (18 Dec 2006)
+
+ 18 Dec 2006; Michael Sterrett <mr_bones_@gentoo.org> +fox-1.0.53.ebuild:
+ resurrect fox-1.0.53.ebuild which is also still in use
*fox-1.5.4 (18 Dec 2006)
diff --git a/x11-libs/fox/files/digest-fox-1.0.53 b/x11-libs/fox/files/digest-fox-1.0.53
new file mode 100644
index 000000000000..a18628f067e0
--- /dev/null
+++ b/x11-libs/fox/files/digest-fox-1.0.53
@@ -0,0 +1,3 @@
+MD5 0b0c352154a24629985d9eccbd2e6bc6 fox-1.0.53.tar.gz 2120403
+RMD160 639c53b8d744cb1bd6674d022bd6a8fdf3cd593d fox-1.0.53.tar.gz 2120403
+SHA256 74fda862214869a20f0f3f83726c41d04e9159820a0a92042d9396425bb4ccd6 fox-1.0.53.tar.gz 2120403
diff --git a/x11-libs/fox/fox-1.0.53.ebuild b/x11-libs/fox/fox-1.0.53.ebuild
new file mode 100644
index 000000000000..ac8ff032256d
--- /dev/null
+++ b/x11-libs/fox/fox-1.0.53.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.0.53.ebuild,v 1.6 2006/12/18 09:13:37 mr_bones_ Exp $
+
+inherit toolchain-funcs flag-o-matic fox
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~alpha ~hppa ~ia64 ~ppc ~ppc64 ~sparc"
+IUSE="cups jpeg opengl png tiff zlib"
+
+RDEPEND="x11-libs/libXrandr
+ x11-libs/libXcursor
+ cups? ( net-print/cups )
+ jpeg? ( >=media-libs/jpeg-6b )
+ opengl? ( virtual/opengl virtual/glu )
+ png? ( >=media-libs/libpng-1.2.5 )
+ tiff? ( >=media-libs/tiff-3.5.7 )
+ zlib? ( >=sys-libs/zlib-1.1.4 )"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+FOXCONF="$(use_enable cups) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable tiff) \
+ $(use_enable zlib)"
+
+# fox-1.0 incorrectly detects mesa on xorg-x11-6.8.2
+use opengl \
+ && FOXCONF="${FOXCONF} --with-opengl=opengl" \
+ || FOXCONF="${FOXCONF} --without-opengl"
+
+src_compile() {
+ if [[ $(gcc-major-version) -ge 4 ]]; then
+ append-flags -ffriend-injection
+ fi
+ fox_src_compile
+}