summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-08-05 19:00:34 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-08-05 19:00:34 +0000
commit87774d26a6887cc65f427b3006d74b09340738a9 (patch)
tree4db65f005a1b859544833016d905e7ec7c7519a2 /x11-libs/fox/fox-1.6.40.ebuild
parent[bump] dev-perl/FCGI-ProcManager-0.220.0 (diff)
downloadgentoo-2-87774d26a6887cc65f427b3006d74b09340738a9.tar.gz
gentoo-2-87774d26a6887cc65f427b3006d74b09340738a9.tar.bz2
gentoo-2-87774d26a6887cc65f427b3006d74b09340738a9.zip
Fix building with libpng15.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/fox/fox-1.6.40.ebuild')
-rw-r--r--x11-libs/fox/fox-1.6.40.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/x11-libs/fox/fox-1.6.40.ebuild b/x11-libs/fox/fox-1.6.40.ebuild
index a991d7c600d1..9a88e2a2fde5 100644
--- a/x11-libs/fox/fox-1.6.40.ebuild
+++ b/x11-libs/fox/fox-1.6.40.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.6.40.ebuild,v 1.8 2011/02/26 22:34:32 signals Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fox/fox-1.6.40.ebuild,v 1.9 2011/08/05 19:00:34 ssuominen Exp $
EAPI="2"
-inherit fox
+inherit eutils fox
LICENSE="LGPL-2.1"
SLOT="1.6"
@@ -33,3 +33,8 @@ FOXCONF="$(use_enable bzip2 bz2lib) \
$(use_enable tiff) \
$(use_with truetype xft) \
$(use_enable zlib)"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
+ fox_src_prepare
+}