summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-05-30 17:03:05 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-05-30 17:03:05 +0000
commitdad80024ee8fd821ffadab69292d389d7727da79 (patch)
tree8f6b7956b41eb77c246771fbcf269c87d6b313f5 /x11-libs/fltk
parentx86 stable wrt bug #320439 (diff)
downloadgentoo-2-dad80024ee8fd821ffadab69292d389d7727da79.tar.gz
gentoo-2-dad80024ee8fd821ffadab69292d389d7727da79.tar.bz2
gentoo-2-dad80024ee8fd821ffadab69292d389d7727da79.zip
Apply datadir fix from bug #31553 to latest ebuild as well
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/fltk')
-rw-r--r--x11-libs/fltk/ChangeLog7
-rw-r--r--x11-libs/fltk/fltk-1.1.10-r1.ebuild137
2 files changed, 143 insertions, 1 deletions
diff --git a/x11-libs/fltk/ChangeLog b/x11-libs/fltk/ChangeLog
index 76ca5e6de8fd..0055a24e7112 100644
--- a/x11-libs/fltk/ChangeLog
+++ b/x11-libs/fltk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/fltk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.157 2010/05/30 10:44:20 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/ChangeLog,v 1.158 2010/05/30 17:03:05 hwoarang Exp $
+
+*fltk-1.1.10-r1 (30 May 2010)
+
+ 30 May 2010; Markos Chandras <hwoarang@gentoo.org> +fltk-1.1.10-r1.ebuild:
+ Apply datadir fix from bug #31553 to latest ebuild as well
*fltk-1.1.9-r2 (30 May 2010)
diff --git a/x11-libs/fltk/fltk-1.1.10-r1.ebuild b/x11-libs/fltk/fltk-1.1.10-r1.ebuild
new file mode 100644
index 000000000000..eca324c7810d
--- /dev/null
+++ b/x11-libs/fltk/fltk-1.1.10-r1.ebuild
@@ -0,0 +1,137 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/fltk/fltk-1.1.10-r1.ebuild,v 1.1 2010/05/30 17:03:05 hwoarang Exp $
+
+EAPI=2
+inherit eutils autotools versionator fdo-mime
+
+DESCRIPTION="C++ user interface toolkit for X and OpenGL."
+HOMEPAGE="http://www.fltk.org"
+SRC_URI="mirror://easysw/${PN}/${PV}/${P}-source.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+LICENSE="FLTK LGPL-2"
+
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE="debug doc examples games opengl threads xft xinerama"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXt
+ media-libs/jpeg
+ media-libs/libpng
+ sys-libs/zlib
+ opengl? ( virtual/opengl virtual/glu )
+ xinerama? ( x11-libs/libXinerama )
+ xft? ( x11-libs/libXft )
+ >=sys-libs/glibc-2.10" # glibc-2.10 patch breaks with 2.9, bug 276695
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ doc? ( app-text/htmldoc )
+ xinerama? ( x11-proto/xineramaproto )"
+
+INCDIR=/usr/include/fltk-${SLOT}
+LIBDIR=/usr/$(get_libdir)/fltk-${SLOT}
+
+src_prepare() {
+ epatch "${FILESDIR}"/fltk-1.1.9-share.patch
+ #epatch "${FILESDIR}"/${P}-fromdebian.patch
+ epatch "${FILESDIR}"/${PN}-1.1.9-desktop.patch
+ epatch "${FILESDIR}"/${PN}-1.1.9-as-needed.patch
+ # prevent to run twice configure (needs eautoconf), to compile tests,
+ # remove forced -Os compile
+ epatch "${FILESDIR}"/${PN}-1.1.9-conf-tests.patch
+ # fix stricter c++ handling in glibc-2.10/gcc-4.4 (bug 270487)
+ epatch "${FILESDIR}"/${PN}-1.1.9-glibc2.10-scandir.patch
+ # remove forced flags from fltk-config
+ sed -i \
+ -e '/C\(XX\)\?FLAGS=/s:@C\(XX\)\?FLAGS@::' \
+ -e '/^LDFLAGS=/d' \
+ "${S}/fltk-config.in" || die
+ # some fixes introduced because slotting
+ sed -i \
+ -e '/RANLIB/s:$(libdir)/\(.*LIBNAME)\):$(libdir)/`basename \1`:g' \
+ src/Makefile || die
+ # docs in proper docdir
+ sed -i \
+ -e "/^docdir/s:fltk:${PF}/html:" \
+ makeinclude.in || die
+ sed -e "s/7/$(get_version_component_range 3)/" \
+ "${FILESDIR}"/FLTKConfig.cmake > CMake/FLTKConfig.cmake
+ eautoconf
+}
+
+src_configure() {
+ econf \
+ --includedir=${INCDIR}\
+ --libdir=${LIBDIR} \
+ --docdir=/usr/share/doc/${PF}/html \
+ --enable-largefile \
+ --enable-shared \
+ --enable-xdbe \
+ --disable-localjpeg \
+ --disable-localpng \
+ --disable-localzlib \
+ $(use_enable debug) \
+ $(use_enable opengl gl) \
+ $(use_enable threads) \
+ $(use_enable xft) \
+ $(use_enable xinerama)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}"/documentation
+ emake alldocs || die "emake doc failed"
+ fi
+ if use games; then
+ cd "${S}"/test
+ emake blocks checkers sudoku || die "emake games failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ emake -C fluid \
+ DESTDIR="${D}" install-linux || die "emake install fluid failed"
+ if use doc; then
+ emake -C documentation \
+ DESTDIR="${D}" install || die "emake install doc failed"
+ fi
+ local apps="fluid"
+ if use games; then
+ emake -C test \
+ DESTDIR="${D}" install-linux || die "emake install games failed"
+ emake -C documentation \
+ DESTDIR="${D}" install-linux || die "emake install doc games failed"
+ apps="${apps} sudoku blocks checkers"
+ fi
+ for app in ${apps}; do
+ dosym /usr/share/icons/hicolor/32x32/apps/${app}.png \
+ /usr/share/pixmaps/${app}.png
+ done
+ dodoc CHANGES README CREDITS ANNOUNCEMENT
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins test/*.{h,cxx,fl} test/demo.menu
+ fi
+
+ insinto /usr/share/cmake/Modules
+ doins CMake/FLTK*.cmake
+
+ echo "LDPATH=${LIBDIR}" > 99fltk-${SLOT}
+ echo "FLTK_DOCDIR=/usr/share/doc/${PF}/html" >> 99fltk-${SLOT}
+ doenvd 99fltk-${SLOT}
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}