summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-01-13 08:30:24 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-01-13 08:30:24 +0000
commit42e82ff474cf53c91a6b6f42825d291d6faab6db (patch)
treeadc4a7e74a3c5ea0d16bbc0e70b9c55c57d3642e /x11-libs/flowcanvas
parentVersion bump (diff)
downloadgentoo-2-42e82ff474cf53c91a6b6f42825d291d6faab6db.tar.gz
gentoo-2-42e82ff474cf53c91a6b6f42825d291d6faab6db.tar.bz2
gentoo-2-42e82ff474cf53c91a6b6f42825d291d6faab6db.zip
version bump
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/flowcanvas')
-rw-r--r--x11-libs/flowcanvas/ChangeLog10
-rw-r--r--x11-libs/flowcanvas/files/ldconfig2.patch10
-rw-r--r--x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild48
3 files changed, 66 insertions, 2 deletions
diff --git a/x11-libs/flowcanvas/ChangeLog b/x11-libs/flowcanvas/ChangeLog
index 2b32e44c8047..336f030aefbc 100644
--- a/x11-libs/flowcanvas/ChangeLog
+++ b/x11-libs/flowcanvas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/flowcanvas
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.9 2010/10/09 13:28:16 aballier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/ChangeLog,v 1.10 2011/01/13 08:30:24 aballier Exp $
+
+*flowcanvas-0.7.1 (13 Jan 2011)
+
+ 13 Jan 2011; Alexis Ballier <aballier@gentoo.org> +files/ldconfig2.patch,
+ +flowcanvas-0.7.1.ebuild:
+ version bump
*flowcanvas-0.6.4 (09 Oct 2010)
diff --git a/x11-libs/flowcanvas/files/ldconfig2.patch b/x11-libs/flowcanvas/files/ldconfig2.patch
new file mode 100644
index 000000000000..d86e65eaf179
--- /dev/null
+++ b/x11-libs/flowcanvas/files/ldconfig2.patch
@@ -0,0 +1,10 @@
+Index: flowcanvas-0.7.1/wscript
+===================================================================
+--- flowcanvas-0.7.1.orig/wscript
++++ flowcanvas-0.7.1/wscript
+@@ -85,5 +85,3 @@ def build(bld):
+
+ # Documentation
+ autowaf.build_dox(bld, 'FLOWCANVAS', FLOWCANVAS_VERSION, top, out)
+-
+- bld.add_post_fun(autowaf.run_ldconfig)
diff --git a/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild b/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild
new file mode 100644
index 000000000000..9823b245bcec
--- /dev/null
+++ b/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/flowcanvas/flowcanvas-0.7.1.ebuild,v 1.1 2011/01/13 08:30:24 aballier Exp $
+
+EAPI=2
+
+inherit toolchain-funcs multilib eutils
+
+DESCRIPTION="Gtkmm/Gnomecanvasmm widget for boxes and lines environments"
+HOMEPAGE="http://wiki.drobilla.net/FlowCanvas"
+SRC_URI="http://download.drobilla.net/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc"
+
+RDEPEND="dev-libs/boost
+ >=dev-cpp/gtkmm-2.4
+ >=dev-cpp/libgnomecanvasmm-2.6
+ media-gfx/graphviz"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ epatch "${FILESDIR}/ldconfig2.patch"
+}
+
+src_configure() {
+ tc-export CC CXX CPP AR RANLIB
+ ./waf configure \
+ --prefix=/usr \
+ --libdir=/usr/$(get_libdir) \
+ --htmldir=/usr/share/doc/${PF}/html \
+ $(use debug && echo "--debug") \
+ $(use doc && echo "--docs") \
+ || die
+}
+
+src_compile() {
+ ./waf || die
+}
+
+src_install() {
+ ./waf install --destdir="${D}" || die
+ dodoc AUTHORS README ChangeLog || die
+}