summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-14 02:48:10 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-14 02:48:10 +0000
commita5bba4eee32520e6577a9b0895924bc7cf82623a (patch)
treeaef92548b0f21b057c8683fafd2fcaeba741b72b /x11-libs/evas
parentinitial ebuild (diff)
downloadgentoo-2-a5bba4eee32520e6577a9b0895924bc7cf82623a.tar.gz
gentoo-2-a5bba4eee32520e6577a9b0895924bc7cf82623a.tar.bz2
gentoo-2-a5bba4eee32520e6577a9b0895924bc7cf82623a.zip
ver bump
Diffstat (limited to 'x11-libs/evas')
-rw-r--r--x11-libs/evas/ChangeLog7
-rw-r--r--x11-libs/evas/evas-1.0.0.20031013_pre12.ebuild68
-rw-r--r--x11-libs/evas/files/digest-evas-1.0.0.20031013_pre121
3 files changed, 75 insertions, 1 deletions
diff --git a/x11-libs/evas/ChangeLog b/x11-libs/evas/ChangeLog
index f86f72ec097a..f739bd145f04 100644
--- a/x11-libs/evas/ChangeLog
+++ b/x11-libs/evas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-libs/evas
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.8 2003/03/20 13:02:25 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.9 2003/10/14 02:48:10 vapier Exp $
+
+*evas-1.0.0.20031013_pre12 (13 Oct 2003)
+
+ 13 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Version bump.
*evas-1.0.0.20030220_pre5-r1 (20 Mar 2003)
diff --git a/x11-libs/evas/evas-1.0.0.20031013_pre12.ebuild b/x11-libs/evas/evas-1.0.0.20031013_pre12.ebuild
new file mode 100644
index 000000000000..9a7777ee6d8e
--- /dev/null
+++ b/x11-libs/evas/evas-1.0.0.20031013_pre12.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20031013_pre12.ebuild,v 1.1 2003/10/14 02:48:10 vapier Exp $
+
+inherit enlightenment flag-o-matic
+
+DESCRIPTION="hardware-accelerated canvas API"
+HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
+
+IUSE="X mmx opengl jpeg png directfb fbcon"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.1.0
+ >=dev-libs/eet-0.9.0.20031013
+ >=dev-db/edb-1.0.4.20031013
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )
+ dev-util/pkgconfig"
+
+src_compile() {
+ # other *very* fun options:
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-mmx enable mmx code
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+ export MY_ECONF="
+ `use_enable mmx cpu-mmx` \
+ `use_enable sse cpu-sse` \
+ `use_enable X software-x11` \
+ `use_enable opengl gl-x11` \
+ `use_enable directfb` \
+ `use_enable fbcon fb` \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-444 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-16-rgb-rot-270 \
+ --enable-convert-16-rgb-rot-90 \
+ --enable-convert-24-rgb-888 \
+ --enable-convert-24-bgr-888 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ --enable-convert-32-rgb-rot-270 \
+ --enable-convert-32-rgb-rot-90 \
+ `use_enable png image-loader-png` \
+ `use_enable jpeg image-loader-jpeg`
+ "
+ enlightenment_src_compile
+}
diff --git a/x11-libs/evas/files/digest-evas-1.0.0.20031013_pre12 b/x11-libs/evas/files/digest-evas-1.0.0.20031013_pre12
new file mode 100644
index 000000000000..4aa809a298d0
--- /dev/null
+++ b/x11-libs/evas/files/digest-evas-1.0.0.20031013_pre12
@@ -0,0 +1 @@
+MD5 af719de680232e78d5791c10019c66e9 evas-1.0.0.20031013_pre12.tar.bz2 4213064