summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2003-03-20 13:02:25 +0000
committerSeemant Kulleen <seemant@gentoo.org>2003-03-20 13:02:25 +0000
commit388b3d90c373f0383fbfc0428fa1862b73d03a52 (patch)
tree2e2d7df9183483c77e1e203ffc0d2604572b8574 /x11-libs/evas
parentpic crap removed (diff)
downloadgentoo-2-388b3d90c373f0383fbfc0428fa1862b73d03a52.tar.gz
gentoo-2-388b3d90c373f0383fbfc0428fa1862b73d03a52.tar.bz2
gentoo-2-388b3d90c373f0383fbfc0428fa1862b73d03a52.zip
removal of pic crap
Diffstat (limited to 'x11-libs/evas')
-rw-r--r--x11-libs/evas/ChangeLog8
-rw-r--r--x11-libs/evas/evas-1.0.0.20030220_pre5-r1.ebuild83
-rw-r--r--x11-libs/evas/files/digest-evas-1.0.0.20030220_pre5-r11
3 files changed, 91 insertions, 1 deletions
diff --git a/x11-libs/evas/ChangeLog b/x11-libs/evas/ChangeLog
index e61427f20895..f86f72ec097a 100644
--- a/x11-libs/evas/ChangeLog
+++ b/x11-libs/evas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/evas
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.7 2003/03/11 17:23:19 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/ChangeLog,v 1.8 2003/03/20 13:02:25 seemant Exp $
+
+*evas-1.0.0.20030220_pre5-r1 (20 Mar 2003)
+
+ 20 Mar 2003; Seemant Kulleen <seemant@gentoo.org>
+ evas-1.0.0.20030220_pre5-r1.ebuild:
+ version bump for removal of pic nonsense
*evas-1.0.0.20030220_pre5 (20 Feb 2003)
diff --git a/x11-libs/evas/evas-1.0.0.20030220_pre5-r1.ebuild b/x11-libs/evas/evas-1.0.0.20030220_pre5-r1.ebuild
new file mode 100644
index 000000000000..0c0c92456b58
--- /dev/null
+++ b/x11-libs/evas/evas-1.0.0.20030220_pre5-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/evas/evas-1.0.0.20030220_pre5-r1.ebuild,v 1.1 2003/03/20 13:02:25 seemant Exp $
+
+inherit flag-o-matic
+
+IUSE="X mmx opengl jpeg png directfb fbcon"
+
+S=${WORKDIR}/${PN}
+DESCRIPTION="hardware-accelerated canvas API"
+HOMEPAGE="http://www.enlightenment.org/pages/evas.html"
+SRC_URI="mirror://gentoo/${P}.tar.bz2
+ http://wh0rd.tk/gentoo/distfiles/${P}.tar.bz2"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~alpha"
+
+DEPEND="virtual/x11
+ >=media-libs/imlib2-1.0.6.2003*
+ >=dev-libs/eet-0.0.1.2003*
+ >=dev-db/edb-1.0.3.2003*
+ png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ directfb? ( >=dev-libs/DirectFB-0.9.16 )"
+
+src_compile() {
+ env NOCONFIGURE=yes ./autogen.sh || die "could not autogen"
+
+ # other *very* fun options:
+ # (just do `env EXTRA_CONF="--enable-cpu-sse" emerge evas`)
+ # --enable-cpu-p2-only enable assumption of pentium2/amd cpu
+ # --enable-cpu-p3-only enable assumption of pentium3 and up cpu
+ # --enable-cpu-sse enable sse code
+ # --enable-scale-sample enable sampling scaler code
+ # --enable-scale-smooth enable sampling scaler code
+ # --enable-scale-trilinear enable tri-linear scaler code
+
+ local myconf=""
+ # mmx causes segfaults atm :/
+# use mmx && myconf="${myconf} --enable-cpu-mmx"
+ use X && myconf="${myconf} --enable-software-x11"
+ use opengl && myconf="${myconf} --enable-gl-x11"
+ use directfb && myconf="${myconf} --enable-directfb"
+ use fbcon && myconf="${myconf} --enable-fb"
+
+ use alpha && append-flags -fPIC
+
+ econf \
+ --enable-image-loader-eet \
+ --enable-image-loader-edb \
+ --enable-fmemopen \
+ --enable-cpu-c \
+ --enable-scale-smooth \
+ --enable-scale-sample \
+ --enable-convert-8-rgb-332 \
+ --enable-convert-8-rgb-666 \
+ --enable-convert-8-rgb-232 \
+ --enable-convert-8-rgb-222 \
+ --enable-convert-8-rgb-221 \
+ --enable-convert-8-rgb-121 \
+ --enable-convert-8-rgb-111 \
+ --enable-convert-16-rgb-565 \
+ --enable-convert-16-rgb-555 \
+ --enable-convert-16-rgb-rot-0 \
+ --enable-convert-32-rgb-8888 \
+ --enable-convert-32-rgbx-8888 \
+ --enable-convert-32-bgr-8888 \
+ --enable-convert-32-bgrx-8888 \
+ --enable-convert-32-rgb-rot-0 \
+ `use_enable png image-loader-png` \
+ `use_enable jpeg image-loader-jpeg` \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ find ${D} -name CVS -type d -exec rm -rf '{}' \;
+ dodoc AUTHORS ChangeLog Doxyfile NEWS README TODO
+ dohtml -r doc
+}
diff --git a/x11-libs/evas/files/digest-evas-1.0.0.20030220_pre5-r1 b/x11-libs/evas/files/digest-evas-1.0.0.20030220_pre5-r1
new file mode 100644
index 000000000000..0f1846eda954
--- /dev/null
+++ b/x11-libs/evas/files/digest-evas-1.0.0.20030220_pre5-r1
@@ -0,0 +1 @@
+MD5 ea2a8f9c638055f178daed029b54b5df evas-1.0.0.20030220_pre5.tar.bz2 1323057