summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-20 11:21:30 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-20 11:21:30 +0000
commita7e91cc3cdd24d5878ab72935f96bef8e2e5b540 (patch)
tree805968d968425c49598081fc5e1effb5ff3ea8be /x11-libs/cairo
parentMinor fixes to metadata.xml (thanks to leio for pointing these out). (diff)
downloadgentoo-2-a7e91cc3cdd24d5878ab72935f96bef8e2e5b540.tar.gz
gentoo-2-a7e91cc3cdd24d5878ab72935f96bef8e2e5b540.tar.bz2
gentoo-2-a7e91cc3cdd24d5878ab72935f96bef8e2e5b540.zip
Migrate live ebuild to git-2 eclass and update to eapi4.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog5
-rw-r--r--x11-libs/cairo/cairo-9999.ebuild41
2 files changed, 21 insertions, 25 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index 2907469a54f2..b7fb9cfa72ec 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.279 2011/04/18 14:41:00 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.280 2011/04/20 11:21:30 scarabeus Exp $
+
+ 20 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> cairo-9999.ebuild:
+ Migrate live ebuild to git-2 eclass and update to eapi4.
18 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org> +cairo-1.8.10.ebuild:
Restore cairo 1.8. Still required.
diff --git a/x11-libs/cairo/cairo-9999.ebuild b/x11-libs/cairo/cairo-9999.ebuild
index 6ee89fb419ce..74f14fb68731 100644
--- a/x11-libs/cairo/cairo-9999.ebuild
+++ b/x11-libs/cairo/cairo-9999.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.10 2011/04/10 10:25:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-9999.ebuild,v 1.11 2011/04/20 11:21:30 scarabeus Exp $
-EAPI=3
+EAPI=4
EGIT_REPO_URI="git://anongit.freedesktop.org/git/cairo"
-[[ ${PV} == *9999 ]] && GIT_ECLASS="git"
+[[ ${PV} == *9999 ]] && GIT_ECLASS="git-2"
inherit eutils flag-o-matic autotools ${GIT_ECLASS}
@@ -60,6 +60,13 @@ DEPEND="${RDEPEND}
)
)"
+# drm module requires X
+# for gallium we need to enable drm
+REQUIRED_USE="
+ drm? ( X )
+ gallium? ( drm )
+"
+
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
@@ -85,29 +92,13 @@ src_configure() {
#gets rid of fbmmx.c inlining warnings
append-flags -finline-limit=1200
- if use X; then
+ use X && myopts+=" --enable-tee=yes"
+ if use drm; then
myopts+="
- --enable-tee=yes
- $(use_enable drm)
+ $(use_enable xcb xcb-drm)
"
-
- if use drm; then
- myopts+="
- $(use_enable gallium)
- $(use_enable xcb xcb-drm)
- "
- else
- use gallium && ewarn "Gallium use requires drm use enabled. So disabling for now."
- myopts+="
- --disable-gallium
- --disable-xcb-drm
- "
- fi
else
- use drm && ewarn "drm use requires X use enabled. So disabling for now."
myopts+="
- --disable-drm
- --disable-gallium
--disable-xcb-drm
"
fi
@@ -131,6 +122,8 @@ src_configure() {
$(use_enable svg) \
$(use_enable xcb) \
$(use_enable xcb xcb-shm) \
+ $(use_enable drm) \
+ $(use_enable gallium) \
--enable-ft \
--enable-pdf \
--enable-png \
@@ -141,7 +134,7 @@ src_configure() {
src_install() {
# parallel make install fails
- emake -j1 DESTDIR="${D}" install || die
+ emake -j1 DESTDIR="${D}" install
find "${ED}" -name '*.la' -exec rm -f {} +
- dodoc AUTHORS ChangeLog NEWS README || die
+ dodoc AUTHORS ChangeLog NEWS README
}