summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2011-01-13 19:07:12 +0000
committerDror Levin <spatz@gentoo.org>2011-01-13 19:07:12 +0000
commit7206f77e6c831f642b2a3548356eeeb6ede7f097 (patch)
tree09ae3b7d36f2a9c9bc806288a606259a820391b9 /x11-libs/cairo
parentNew package, ebuild written by me (diff)
downloadgentoo-2-7206f77e6c831f642b2a3548356eeeb6ede7f097.tar.gz
gentoo-2-7206f77e6c831f642b2a3548356eeeb6ede7f097.tar.bz2
gentoo-2-7206f77e6c831f642b2a3548356eeeb6ede7f097.zip
Restore buggy_gradients.patch accidently removed by scarabeus.
(Portage version: 2.2.0_alpha15/cvs/Linux x86_64)
Diffstat (limited to 'x11-libs/cairo')
-rw-r--r--x11-libs/cairo/ChangeLog9
-rw-r--r--x11-libs/cairo/cairo-1.10.2-r1.ebuild (renamed from x11-libs/cairo/cairo-1.10.2.ebuild)3
-rw-r--r--x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch17
3 files changed, 27 insertions, 2 deletions
diff --git a/x11-libs/cairo/ChangeLog b/x11-libs/cairo/ChangeLog
index b0edef273cea..733f7708fd15 100644
--- a/x11-libs/cairo/ChangeLog
+++ b/x11-libs/cairo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-libs/cairo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.266 2011/01/11 18:58:37 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/ChangeLog,v 1.267 2011/01/13 19:07:12 spatz Exp $
+
+*cairo-1.10.2-r1 (13 Jan 2011)
+
+ 13 Jan 2011; Dror Levin <spatz@gentoo.org>
+ +files/cairo-1.10.0-buggy_gradients.patch, -cairo-1.10.2.ebuild,
+ +cairo-1.10.2-r1.ebuild:
+ Restore buggy_gradients.patch accidently removed by scarabeus.
*cairo-1.10.2 (11 Jan 2011)
diff --git a/x11-libs/cairo/cairo-1.10.2.ebuild b/x11-libs/cairo/cairo-1.10.2-r1.ebuild
index 59aae6499207..117ddab00a1d 100644
--- a/x11-libs/cairo/cairo-1.10.2.ebuild
+++ b/x11-libs/cairo/cairo-1.10.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.10.2.ebuild,v 1.1 2011/01/11 18:58:37 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/cairo/cairo-1.10.2-r1.ebuild,v 1.1 2011/01/13 19:07:12 spatz Exp $
EAPI=3
@@ -62,6 +62,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-1.8.8-interix.patch
+ epatch "${FILESDIR}"/${PN}-1.10.0-buggy_gradients.patch
# Slightly messed build system YAY
if [[ ${PV} == *9999* ]]; then
diff --git a/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch b/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch
new file mode 100644
index 000000000000..a58c2f8f4138
--- /dev/null
+++ b/x11-libs/cairo/files/cairo-1.10.0-buggy_gradients.patch
@@ -0,0 +1,17 @@
+http://repos.archlinux.org/wsvn/packages/cairo/trunk/cairo-1.10.0-buggy_gradients.patch
+http://bugs.gentoo.org/336696
+
+--- src/cairo-xlib-display.c
++++ src/cairo-xlib-display.c
+@@ -353,11 +353,7 @@
+ /* Prior to Render 0.10, there is no protocol support for gradients and
+ * we call function stubs instead, which would silently consume the drawing.
+ */
+-#if RENDER_MAJOR == 0 && RENDER_MINOR < 10
+ display->buggy_gradients = TRUE;
+-#else
+- display->buggy_gradients = FALSE;
+-#endif
+ display->buggy_pad_reflect = FALSE;
+ display->buggy_repeat = FALSE;
+