summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-06-04 18:53:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-06-04 18:53:02 +0000
commit534a595c4043e5a17efa463382a1513d0cc6f266 (patch)
tree798c2d37ccae49b1a03690441f7d07047a0d3c59 /x11-libs/c++-gtk-utils
parentold (diff)
downloadgentoo-2-534a595c4043e5a17efa463382a1513d0cc6f266.tar.gz
gentoo-2-534a595c4043e5a17efa463382a1513d0cc6f266.tar.bz2
gentoo-2-534a595c4043e5a17efa463382a1513d0cc6f266.zip
New series of c++-gtk-utils in a own SLOT; might as well use the free 0.
(Portage version: 2.2.0_alpha177/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-libs/c++-gtk-utils')
-rw-r--r--x11-libs/c++-gtk-utils/ChangeLog8
-rw-r--r--x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.0.ebuild41
2 files changed, 48 insertions, 1 deletions
diff --git a/x11-libs/c++-gtk-utils/ChangeLog b/x11-libs/c++-gtk-utils/ChangeLog
index a063d4aa4a02..4da0395c888a 100644
--- a/x11-libs/c++-gtk-utils/ChangeLog
+++ b/x11-libs/c++-gtk-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-libs/c++-gtk-utils
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/c++-gtk-utils/ChangeLog,v 1.17 2013/06/04 18:24:22 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/c++-gtk-utils/ChangeLog,v 1.18 2013/06/04 18:53:01 ssuominen Exp $
+
+*c++-gtk-utils-2.2.0 (04 Jun 2013)
+
+ 04 Jun 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +c++-gtk-utils-2.2.0.ebuild:
+ New series of c++-gtk-utils in a own SLOT; might as well use the free 0.
04 Jun 2013; Samuli Suominen <ssuominen@gentoo.org>
-c++-gtk-utils-2.0.16.ebuild:
diff --git a/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.0.ebuild b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.0.ebuild
new file mode 100644
index 000000000000..a89df85429c6
--- /dev/null
+++ b/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-libs/c++-gtk-utils/c++-gtk-utils-2.2.0.ebuild,v 1.1 2013/06/04 18:53:02 ssuominen Exp $
+
+EAPI=5
+inherit eutils
+
+DESCRIPTION="A library containing a number of classes and functions for programming GTK+ programs using C++"
+HOMEPAGE="http://cxx-gtk-utils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN/++/xx}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="+gtk nls static-libs"
+SLOT="0"
+
+RDEPEND="
+ >=dev-libs/glib-2.26
+ gtk? ( x11-libs/gtk+:3 )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+DOCS=( ChangeLog )
+
+src_configure() {
+ econf \
+ $(use_enable nls) \
+ $(use_with gtk) \
+ $(use_enable static-libs static) \
+ --docdir=/usr/share/doc/${PF} \
+ --htmldir=/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ prune_libtool_files
+}