summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-10-16 22:44:29 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-10-16 22:44:29 +0000
commitb4cdf1f81995e11322ca45fd3ca9285efee5bb47 (patch)
treef3f1fa4217e9f119f37e8064f5a42b42f85e2cc4 /x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild
parentxtrlock is a minimalist screen locker for X (diff)
downloadgentoo-2-b4cdf1f81995e11322ca45fd3ca9285efee5bb47.tar.gz
gentoo-2-b4cdf1f81995e11322ca45fd3ca9285efee5bb47.tar.bz2
gentoo-2-b4cdf1f81995e11322ca45fd3ca9285efee5bb47.zip
finally (?) fixed this Xaw3d problem
Diffstat (limited to 'x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild')
-rw-r--r--x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild b/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild
new file mode 100644
index 000000000000..41075a330d31
--- /dev/null
+++ b/x11-libs/Xaw3d/Xaw3d-1.5-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Authors Dan Armak <danarmak@gentoo.org>, Martin Schlemmer <azarah@gentoo.org>
+
+# Ok, hopefully this will resolv the problem with the version of libXaw3d that
+# gets created.
+#
+# The problem its seems, is that when X gets compiled, it determines (with the
+# help of some very dark magic) what version libXaw.so it it should build (6.1 or
+# 7.0). Now, when compiling Xaw3d, it checks which version of Xaw was built, and
+# then builds the same version of Xaw3d.
+#
+# Since this ebuild use the Makefile's "install" function, it "should" not be a
+# problem anymore.
+#
+# Azarah.
+
+
+S=${WORKDIR}/xc/lib/Xaw3d
+DESCRIPTION="the Xaw3d is a drop-in 3D replacement of the Xaw widget set
+ which comes with X. It is used e.g. by gv the ghostcript frontend."
+# All full ftp.x.org mirrors can be added here.
+SRC_URI="ftp://ftp.x.org/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz
+ http://ibiblio.org/pub/X11/contrib/widgets/Xaw3d/R6.3/${P}.tar.gz"
+# None so far as I know.
+#HOMEPAGE="http://"
+
+# There _might_ be something else, but I doubt it.
+DEPEND="virtual/x11"
+
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+ cd ${S}
+
+ # For some reason it isn't automatically patched.
+ # That's why I manually override the source_unpack function.
+ patch -p0 <${FILESDIR}/Xaw3d-xfree86.diff || die
+ patch -p0 <${FILESDIR}/Xaw3d-out-of-tree.diff || die
+}
+
+src_compile() {
+
+ # convoluted process for out-of-tree building
+ mkdir ./X11
+ cd ./X11 ; ln -sf ../../Xaw3d . ; cd ..
+
+ xmkmf || die
+ make includes || die
+ make depend || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc README.XAW3D
+}
+