summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-06-27 16:45:41 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-06-27 16:45:41 +0000
commitfcfa29480a1d31e5b5e52a51e88e23ba4e962a8c (patch)
tree218786346dc73af992e1607182cd81106e97d8bc /x11-drivers
parentSlotmove new ati-drivers-9.6 (diff)
downloadgentoo-2-fcfa29480a1d31e5b5e52a51e88e23ba4e962a8c.tar.gz
gentoo-2-fcfa29480a1d31e5b5e52a51e88e23ba4e962a8c.tar.bz2
gentoo-2-fcfa29480a1d31e5b5e52a51e88e23ba4e962a8c.zip
Add elog informations about supported video cards and also recomend other driver. Also move slot to 1 so user can still use x11-drivers/ati-drivers:0 in world set and for easier masking for blocking automatic update.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/ati-drivers/ChangeLog9
-rw-r--r--x11-drivers/ati-drivers/ati-drivers-9.6.ebuild31
2 files changed, 32 insertions, 8 deletions
diff --git a/x11-drivers/ati-drivers/ChangeLog b/x11-drivers/ati-drivers/ChangeLog
index f2335fd512b7..ea1815944579 100644
--- a/x11-drivers/ati-drivers/ChangeLog
+++ b/x11-drivers/ati-drivers/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/ati-drivers
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.159 2009/06/26 12:53:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ChangeLog,v 1.160 2009/06/27 16:45:41 scarabeus Exp $
+
+ 27 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ ati-drivers-9.6.ebuild:
+ Add elog informations about supported video cards and also recomend other
+ driver. Also move slot to 1 so user can still use
+ x11-drivers/ati-drivers:0 in world set and for easier masking for blocking
+ automatic update.
26 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org>
ati-drivers-9.6.ebuild:
diff --git a/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild b/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild
index aa4b18848de2..6cfa1ed577e1 100644
--- a/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild
+++ b/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild
@@ -1,39 +1,46 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild,v 1.2 2009/06/26 12:53:26 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/ati-drivers/ati-drivers-9.6.ebuild,v 1.3 2009/06/27 16:45:41 scarabeus Exp $
+
+EAPI="1"
IUSE="acpi debug"
inherit eutils multilib linux-mod toolchain-funcs versionator
-DESCRIPTION="Ati precompiled drivers for recent chipsets"
+DESCRIPTION="Ati precompiled drivers for r600 (HD Series) and newer chipsets"
HOMEPAGE="http://www.ati.com"
ATI_URL="https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/"
SRC_URI="${ATI_URL}/ati-driver-installer-${PV/./-}-x86.x86_64.run"
LICENSE="AMD GPL-2 QPL-1.0 as-is"
KEYWORDS="~amd64 ~x86"
+SLOT="1"
+
# The portage dep is for COLON_SEPARATED support in env-update.
# The eselect dep (>=1.0.9) is for COLON_SEPARATED in eselect env update.
-RDEPEND=">=x11-base/xorg-server-1.5
+RDEPEND="
+ !x11-drivers/ati-drivers:0
!x11-apps/ati-drivers-extra
>=app-admin/eselect-1.0.9
- app-admin/eselect-opengl
+ >=app-admin/eselect-opengl-1.0.7
+ >=sys-apps/portage-2.1.1-r1
sys-libs/libstdc++-v3
+ >=x11-base/xorg-server-1.5
+ x11-libs/libXrandr
amd64? ( app-emulation/emul-linux-x86-xlibs )
acpi? (
x11-apps/xauth
sys-power/acpid
)
- x11-libs/libXrandr
- >=sys-apps/portage-2.1.1-r1"
+"
DEPEND="${RDEPEND}
x11-proto/xf86miscproto
x11-proto/xf86vidmodeproto
x11-proto/inputproto
- !<x11-drivers/ati-drivers-8.552-r1"
+"
EMULTILIB_PKG="true"
@@ -123,6 +130,16 @@ pkg_setup() {
PKG_LIBDIR=lib
ARCH_DIR="${S}/arch/x86"
fi
+
+ elog
+ elog "Please note that this driver supports only graphic cards based on"
+ elog "r600 chipset and newer."
+ elog "This represent the ATI Radeon HD series at this moment."
+ elog
+ elog "If your card is older then usage of ${CATEGORY}/xf86-video-ati"
+ elog "as replacement is highly recommended. Rather than staying with"
+ elog "Old versions of this driver."
+ einfo
}
src_unpack() {