summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-10-19 14:28:58 +0000
committerJeroen Roovers <jer@gentoo.org>2014-10-19 14:28:58 +0000
commite6a0c810cfb0f52b1b1281ae40729ed56405c93b (patch)
treeff812dcdd1917dea1ec88a2775c98aadd63a04b8 /x11-drivers
parentversion bump (diff)
downloadgentoo-2-e6a0c810cfb0f52b1b1281ae40729ed56405c93b.tar.gz
gentoo-2-e6a0c810cfb0f52b1b1281ae40729ed56405c93b.tar.bz2
gentoo-2-e6a0c810cfb0f52b1b1281ae40729ed56405c93b.zip
Add new constify patch (bug #482784).
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/ChangeLog8
-rw-r--r--x11-drivers/nvidia-drivers/files/nvidia-drivers-337.12-pax-constify.patch25
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild3
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild3
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild3
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild3
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild3
7 files changed, 42 insertions, 6 deletions
diff --git a/x11-drivers/nvidia-drivers/ChangeLog b/x11-drivers/nvidia-drivers/ChangeLog
index 499629853a64..416efacb5297 100644
--- a/x11-drivers/nvidia-drivers/ChangeLog
+++ b/x11-drivers/nvidia-drivers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/nvidia-drivers
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/ChangeLog,v 1.584 2014/10/15 21:32:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/ChangeLog,v 1.585 2014/10/19 14:28:58 jer Exp $
+
+ 19 Oct 2014; Jeroen Roovers <jer@gentoo.org> nvidia-drivers-331.104.ebuild,
+ nvidia-drivers-334.21-r3.ebuild, nvidia-drivers-337.25.ebuild,
+ nvidia-drivers-340.46.ebuild, nvidia-drivers-343.22-r2.ebuild,
+ +files/nvidia-drivers-337.12-pax-constify.patch:
+ Add new constify patch (bug #482784).
15 Oct 2014; Jeroen Roovers <jer@gentoo.org> nvidia-drivers-340.46.ebuild:
Stable for AMD64 x86 too.
diff --git a/x11-drivers/nvidia-drivers/files/nvidia-drivers-337.12-pax-constify.patch b/x11-drivers/nvidia-drivers/files/nvidia-drivers-337.12-pax-constify.patch
new file mode 100644
index 000000000000..0ec9edf99cc8
--- /dev/null
+++ b/x11-drivers/nvidia-drivers/files/nvidia-drivers-337.12-pax-constify.patch
@@ -0,0 +1,25 @@
+--- a/kernel/uvm/nvidia_uvm_common.c
++++ b/kernel/uvm/nvidia_uvm_common.c
+@@ -95,7 +95,6 @@ static RM_STATUS uvmnext_gpu_event_stop_
+ #endif // NVIDIA_UVM_NEXT_ENABLED
+
+ static dev_t g_uvmBaseDev;
+-struct UvmOpsUvmEvents g_exportedUvmOps;
+
+ // TODO: This would be easier if RM allowed for multiple registrations, since we
+ // could register UVM-Lite and UVM-Next separately (bug 1372835).
+@@ -147,9 +146,11 @@ static RM_STATUS uvmSetupGpuProvider(voi
+ RM_STATUS status = RM_OK;
+
+ #ifdef NVIDIA_UVM_RM_ENABLED
+- g_exportedUvmOps.startDevice = uvm_gpu_event_start_device;
+- g_exportedUvmOps.stopDevice = uvm_gpu_event_stop_device;
+- g_exportedUvmOps.isrTopHalf = uvmnext_isr_top_half;
++ static struct UvmOpsUvmEvents g_exportedUvmOps = {
++ .startDevice = uvm_gpu_event_start_device,
++ .stopDevice = uvm_gpu_event_stop_device,
++ .isrTopHalf = uvmnext_isr_top_half,
++ };
+
+ // call RM to exchange the function pointers.
+ status = nvUvmInterfaceRegisterUvmCallbacks(&g_exportedUvmOps);
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild
index c21d82b60e0d..aedb2ad402b9 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild,v 1.1 2014/10/09 09:50:09 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-331.104.ebuild,v 1.2 2014/10/19 14:28:58 jer Exp $
EAPI=5
@@ -181,6 +181,7 @@ src_prepare() {
ewarn "use a standard kernel should you have issues. Should you"
ewarn "need support with these patches, contact the PaX team."
epatch "${FILESDIR}"/${PN}-331.13-pax-usercopy.patch
+ epatch "${FILESDIR}"/${PN}-337.12-pax-constify.patch
fi
# Allow user patches so they can support RC kernels and whatever else
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild
index f3a5b275744f..3d53d36dc9bb 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild,v 1.9 2014/07/30 19:22:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-334.21-r3.ebuild,v 1.10 2014/10/19 14:28:58 jer Exp $
EAPI=5
@@ -172,6 +172,7 @@ src_prepare() {
ewarn "use a standard kernel should you have issues. Should you"
ewarn "need support with these patches, contact the PaX team."
epatch "${FILESDIR}"/${PN}-331.13-pax-usercopy.patch
+ epatch "${FILESDIR}"/${PN}-337.12-pax-constify.patch
fi
# Allow user patches so they can support RC kernels and whatever else
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild
index a5db1913e98e..a464e355d8f1 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild,v 1.5 2014/07/30 19:22:29 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-337.25.ebuild,v 1.6 2014/10/19 14:28:58 jer Exp $
EAPI=5
@@ -172,6 +172,7 @@ src_prepare() {
ewarn "use a standard kernel should you have issues. Should you"
ewarn "need support with these patches, contact the PaX team."
epatch "${FILESDIR}"/${PN}-331.13-pax-usercopy.patch
+ epatch "${FILESDIR}"/${PN}-337.12-pax-constify.patch
fi
# Allow user patches so they can support RC kernels and whatever else
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild
index 4ac4f3991d92..2ea212002cf0 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild,v 1.3 2014/10/15 21:32:33 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-340.46.ebuild,v 1.4 2014/10/19 14:28:58 jer Exp $
EAPI=5
@@ -172,6 +172,7 @@ src_prepare() {
ewarn "use a standard kernel should you have issues. Should you"
ewarn "need support with these patches, contact the PaX team."
epatch "${FILESDIR}"/${PN}-331.13-pax-usercopy.patch
+ epatch "${FILESDIR}"/${PN}-337.12-pax-constify.patch
fi
# Allow user patches so they can support RC kernels and whatever else
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild
index f7c8a1565ad1..a6a62f2b593a 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild,v 1.3 2014/10/09 08:45:30 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-343.22-r2.ebuild,v 1.4 2014/10/19 14:28:58 jer Exp $
EAPI=5
@@ -172,6 +172,7 @@ src_prepare() {
ewarn "use a standard kernel should you have issues. Should you"
ewarn "need support with these patches, contact the PaX team."
epatch "${FILESDIR}"/${PN}-331.13-pax-usercopy.patch
+ epatch "${FILESDIR}"/${PN}-337.12-pax-constify.patch
fi
# Allow user patches so they can support RC kernels and whatever else