summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-09-06 06:50:54 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-09-06 06:50:54 +0000
commitac2f9b0780deadcc5727c6373fd648c456898a24 (patch)
tree30f1e5980735b8cc165fbba0782b87ed5139a607 /x11-drivers
parentUse elisp-compile instead of elisp-comp, bug 235576. Fix compile failure with... (diff)
downloadgentoo-2-ac2f9b0780deadcc5727c6373fd648c456898a24.tar.gz
gentoo-2-ac2f9b0780deadcc5727c6373fd648c456898a24.tar.bz2
gentoo-2-ac2f9b0780deadcc5727c6373fd648c456898a24.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.4.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index 2982f11b573f..84a81e82fcc2 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.82 2008/07/24 14:51:39 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.83 2008/09/06 06:50:54 dberkholz Exp $
+
+*xf86-input-evdev-2.0.4 (06 Sep 2008)
+
+ 06 Sep 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-input-evdev-2.0.4.ebuild:
+ Version bump.
*xf86-input-evdev-2.0.2 (24 Jul 2008)
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.4.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.4.ebuild
new file mode 100644
index 000000000000..8e78f134fe30
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-2.0.4.ebuild,v 1.1 2008/09/06 06:50:54 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="Generic Linux input driver"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86"
+IUSE="hal"
+RDEPEND=">=x11-base/xorg-server-1.4.0.90
+ hal? ( >=sys-apps/hal-0.5.10 )"
+DEPEND="${RDEPEND}
+ || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
+ >=x11-proto/inputproto-1.4
+ x11-proto/randrproto
+ x11-proto/xproto"
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+ pkg_info
+}
+
+pkg_info() {
+ if use hal; then
+ elog "If your XKB (keyboard settings) stopped working,"
+ elog "you may uninstall this driver or move your XKB configuration."
+ elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
+ elog "(these will be installed with sys-apps/hal soon),"
+ elog "and drop it into /etc/hal/fdi/policy/"
+ fi
+}