summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-03-14 05:13:49 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2009-03-14 05:13:49 +0000
commit9cca9b9c03820554753b10bd0a70b0cbad8cc148 (patch)
tree0d1d6ea116cc5c5c203c3bca53a290d025c4d6e5 /x11-drivers
parentkeyword ~amd64 (diff)
downloadgentoo-2-9cca9b9c03820554753b10bd0a70b0cbad8cc148.tar.gz
gentoo-2-9cca9b9c03820554753b10bd0a70b0cbad8cc148.tar.bz2
gentoo-2-9cca9b9c03820554753b10bd0a70b0cbad8cc148.zip
Bump. Adds EXA/Xv for R6xx/R7xx chips (with a sufficiently new DRM that should hit 2.6.30). Also has other bugfixes. Might work for DisplayPort if you actually have a computer with one.
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog10
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.12.0.ebuild43
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index d3cbcbc1f994..04fb42fd3d22 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.75 2009/03/13 15:25:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.76 2009/03/14 05:13:49 dberkholz Exp $
+
+*xf86-video-ati-6.12.0 (14 Mar 2009)
+
+ 14 Mar 2009; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.12.0.ebuild:
+ Bump. Adds EXA/Xv for R6xx/R7xx chips (with a sufficiently new DRM that
+ should hit 2.6.30). Also has other bugfixes. Might work for DisplayPort if
+ you actually have a computer with one.
13 Mar 2009; Raúl Porcel <armin76@gentoo.org>
xf86-video-ati-6.6.3.ebuild, xf86-video-ati-6.7.197.ebuild,
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.0.ebuild
new file mode 100644
index 000000000000..1b5c0a520627
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.0.ebuild,v 1.1 2009/03/14 05:13:49 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ >=x11-misc/util-macros-1.1.3
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+PATCHES=""
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}