summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2012-03-26 18:11:12 +0000
committerDoug Goldstein <cardoe@gentoo.org>2012-03-26 18:11:12 +0000
commit9a716394bb08f92b4aa556110989d782a3f164d5 (patch)
tree5e46a1e212a31cf5c4e17ccc9a7a821c4ca11b97 /x11-drivers
parentBump, unstable release, used by gnome-shell-3.4 (diff)
downloadgentoo-2-9a716394bb08f92b4aa556110989d782a3f164d5.tar.gz
gentoo-2-9a716394bb08f92b4aa556110989d782a3f164d5.tar.bz2
gentoo-2-9a716394bb08f92b4aa556110989d782a3f164d5.zip
ebuild updates that were meant to be committed part of the original commit.
(Portage version: 2.1.10.51/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/ChangeLog5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild46
2 files changed, 25 insertions, 26 deletions
diff --git a/x11-drivers/nvidia-drivers/ChangeLog b/x11-drivers/nvidia-drivers/ChangeLog
index ee317a9fea55..073ea53f91c6 100644
--- a/x11-drivers/nvidia-drivers/ChangeLog
+++ b/x11-drivers/nvidia-drivers/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-drivers/nvidia-drivers
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/ChangeLog,v 1.326 2012/03/23 16:17:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/ChangeLog,v 1.327 2012/03/26 18:11:12 cardoe Exp $
+
+ 26 Mar 2012; Doug Goldstein <cardoe@gentoo.org> nvidia-drivers-295.33.ebuild:
+ ebuild updates that were meant to be committed part of the original commit.
*nvidia-drivers-295.33 (23 Mar 2012)
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild
index 7f0b12fdd7d5..305c17ca2ee1 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild,v 1.1 2012/03/23 16:17:12 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/nvidia-drivers/nvidia-drivers-295.33.ebuild,v 1.2 2012/03/26 18:11:12 cardoe Exp $
EAPI="2"
@@ -213,6 +213,11 @@ pkg_setup() {
MODULE_NAMES="nvidia(video:${S}/kernel)"
BUILD_PARAMS="IGNORE_CC_MISMATCH=yes V=1 SYSSRC=${KV_DIR} \
SYSOUT=${KV_OUT_DIR} CC=$(tc-getBUILD_CC)"
+ # linux-mod_src_compile calls set_arch_to_kernel, which
+ # sets the ARCH to x86 but NVIDIA's wrapping Makefile
+ # expects x86_64 or i386 and then converts it to x86
+ # later on in the build process
+ BUILD_FIXES="ARCH=$(uname -m | sed -e 's/i.86/i386/')"
mtrr_check
lockdep_check
fi
@@ -283,13 +288,6 @@ src_prepare() {
-e 's:-Wsign-compare::g' \
"${NV_SRC}"/Makefile.kbuild
- epatch "${FILESDIR}"/256.35-unified-arch.patch
-
- # Fix building with Linux 3.3.x wrt #408841
- sed -i \
- -e '/CFLAGS="$CFLAGS/s:-I$SOURCES/arch/x86/include:& -I$OUTPUT/arch/x86/include/generated:' \
- kernel/conftest.sh || die
-
# If you set this then it's your own fault when stuff breaks :)
use custom-cflags && sed -i "s:-O:${CFLAGS}:" "${NV_SRC}"/Makefile.*
@@ -419,14 +417,14 @@ src_install() {
# Helper Apps
exeinto /opt/bin/
- dobin ${NV_EXEC}/nvidia-xconfig || die
- dobin ${NV_EXEC}/nvidia-debugdump || die
+ doexe ${NV_EXEC}/nvidia-xconfig || die
+ doexe ${NV_EXEC}/nvidia-debugdump || die
if use gtk; then
- dobin ${NV_EXEC}/nvidia-settings || die
+ doexe ${NV_EXEC}/nvidia-settings || die
fi
- dobin ${NV_EXEC}/nvidia-bug-report.sh || die
+ doexe ${NV_EXEC}/nvidia-bug-report.sh || die
if use kernel_linux; then
- dobin ${NV_EXEC}/nvidia-smi || die
+ doexe ${NV_EXEC}/nvidia-smi || die
fi
# Desktop entries for nvidia-settings
@@ -509,9 +507,7 @@ src_install-libs() {
}
pkg_preinst() {
- if use kernel_linux; then
- linux-mod_pkg_postinst
- fi
+ use kernel_linux && linux-mod_pkg_preinst
# Clean the dynamic libGL stuff's home to ensure
# we dont have stale libs floating around
@@ -525,13 +521,11 @@ pkg_preinst() {
}
pkg_postinst() {
- if use kernel_linux; then
- linux-mod_pkg_postinst
- fi
+ use kernel_linux && linux-mod_pkg_postinst
# Switch to the nvidia implementation
- eselect opengl set --use-old nvidia
- eselect opencl set --use-old nvidia
+ "${ROOT}"/usr/bin/eselect opengl set --use-old nvidia
+ "${ROOT}"/usr/bin/eselect opencl set --use-old nvidia
echo
elog "You must be in the video group to use the NVIDIA device"
@@ -565,9 +559,11 @@ pkg_postinst() {
fi
}
+pkg_prerm() {
+ "${ROOT}"/usr/bin/eselect opengl set --use-old xorg-x11
+}
+
pkg_postrm() {
- if use kernel_linux; then
- linux-mod_pkg_postrm
- fi
- eselect opengl set --use-old xorg-x11
+ use kernel_linux && linux-mod_pkg_postrm
+ "${ROOT}"/usr/bin/eselect opengl set --use-old xorg-x11
}