summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-16 21:31:05 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-16 21:31:05 +0000
commit87970297962897fe49f792594d75a3b25cd2a4db (patch)
treeb98c2dabd2b89016b25d4162c75e3480436057a9 /x11-drivers
parentVersion bump. Port to gnome3 stack. (diff)
downloadgentoo-2-87970297962897fe49f792594d75a3b25cd2a4db.tar.gz
gentoo-2-87970297962897fe49f792594d75a3b25cd2a4db.tar.bz2
gentoo-2-87970297962897fe49f792594d75a3b25cd2a4db.zip
Non-maintainer commit. Version bump, bug #385723. Drop dependency which is already handled by xorg-2.eclass. Move kernel check to pkg_pretend().
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0.ebuild36
2 files changed, 44 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index ee2c56103a13..f8bb6bf27b53 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.62 2011/07/20 23:34:56 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.63 2011/11/16 21:31:05 chithanh Exp $
+
+*xf86-input-synaptics-1.5.0 (16 Nov 2011)
+
+ 16 Nov 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +xf86-input-synaptics-1.5.0.ebuild:
+ Non-maintainer commit. Version bump, bug #385723. Drop dependency which is
+ already handled by xorg-2.eclass. Move kernel check to pkg_pretend().
20 Jul 2011; Mark Loeser <halcy0n@gentoo.org>
xf86-input-synaptics-1.4.0.ebuild:
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0.ebuild
new file mode 100644
index 000000000000..3d535d081600
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0.ebuild,v 1.1 2011/11/16 21:31:05 chithanh Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-base/xorg-server-1.8
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}