summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-05 19:06:53 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-05 19:06:53 +0000
commit369736f403c7301a2a5ce014879aa7f07970e11c (patch)
tree02e4e7aa376d47e06e12ff54b9c39bd59b209e4a /x11-drivers
parentTests are fundamentally broken, see bug 258857 for details (diff)
downloadgentoo-2-369736f403c7301a2a5ce014879aa7f07970e11c.tar.gz
gentoo-2-369736f403c7301a2a5ce014879aa7f07970e11c.tar.bz2
gentoo-2-369736f403c7301a2a5ce014879aa7f07970e11c.zip
Use Python 2 (bug #351576).
(Portage version: 2.2.0_alpha26_p6/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-virtualbox/ChangeLog7
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild8
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild8
-rw-r--r--x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild8
4 files changed, 24 insertions, 7 deletions
diff --git a/x11-drivers/xf86-video-virtualbox/ChangeLog b/x11-drivers/xf86-video-virtualbox/ChangeLog
index cbd28d419b03..3586c7ee34d3 100644
--- a/x11-drivers/xf86-video-virtualbox/ChangeLog
+++ b/x11-drivers/xf86-video-virtualbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-drivers/xf86-video-virtualbox
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.60 2011/02/20 18:31:04 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/ChangeLog,v 1.61 2011/03/05 19:06:53 arfrever Exp $
+
+ 05 Mar 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ xf86-video-virtualbox-3.2.12.ebuild, xf86-video-virtualbox-4.0.2.ebuild,
+ xf86-video-virtualbox-4.0.4.ebuild:
+ Use Python 2 (bug #351576).
20 Feb 2011; Lars Wendler <polynomial-c@gentoo.org>
-files/xf86-video-virtualbox-3.0.0-mesa-check.patch,
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild
index bacf87ec871a..4178ef1fb193 100644
--- a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild,v 1.4 2011/02/03 07:54:36 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-3.2.12.ebuild,v 1.5 2011/03/05 19:06:53 arfrever Exp $
EAPI=2
-inherit eutils linux-mod multilib versionator
+inherit eutils linux-mod multilib python versionator
MY_P=VirtualBox-${PV}-OSE
DESCRIPTION="VirtualBox video driver"
@@ -19,6 +19,7 @@ IUSE="dri"
RDEPEND="x11-base/xorg-server[-minimal]"
DEPEND="${RDEPEND}
>=dev-util/kbuild-0.1.5-r1
+ =dev-lang/python-2*
>=dev-lang/yasm-0.6.2
sys-devel/dev86
sys-power/iasl
@@ -48,6 +49,9 @@ QA_TEXTRELS_x86="usr/lib/VBoxOGL.so"
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
+
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild
index 36a5eec380a3..e77cf3b0e377 100644
--- a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild,v 1.1 2011/01/18 19:35:20 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.2.ebuild,v 1.2 2011/03/05 19:06:53 arfrever Exp $
EAPI=2
-inherit eutils linux-mod multilib versionator
+inherit eutils linux-mod multilib python versionator
MY_P=VirtualBox-${PV}
DESCRIPTION="VirtualBox video driver"
@@ -19,6 +19,7 @@ IUSE="dri"
RDEPEND="x11-base/xorg-server[-minimal]"
DEPEND="${RDEPEND}
>=dev-util/kbuild-0.1.5-r1
+ =dev-lang/python-2*
>=dev-lang/yasm-0.6.2
sys-devel/dev86
sys-power/iasl
@@ -48,6 +49,9 @@ QA_TEXTRELS_x86="usr/lib/VBoxOGL.so"
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
+
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {
diff --git a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild
index 3cddbdaf4b47..b89b8885e997 100644
--- a/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild
+++ b/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild,v 1.1 2011/02/19 08:37:30 polynomial-c Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-virtualbox/xf86-video-virtualbox-4.0.4.ebuild,v 1.2 2011/03/05 19:06:53 arfrever Exp $
EAPI=2
-inherit eutils linux-mod multilib versionator
+inherit eutils linux-mod multilib python versionator
MY_P=VirtualBox-${PV}
DESCRIPTION="VirtualBox video driver"
@@ -19,6 +19,7 @@ IUSE="dri"
RDEPEND="x11-base/xorg-server[-minimal]"
DEPEND="${RDEPEND}
>=dev-util/kbuild-0.1.5-r1
+ =dev-lang/python-2*
>=dev-lang/yasm-0.6.2
sys-devel/dev86
sys-power/iasl
@@ -48,6 +49,9 @@ QA_TEXTRELS_x86="usr/lib/VBoxOGL.so"
pkg_setup() {
linux-mod_pkg_setup
BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
+
+ python_set_active_version 2
+ python_pkg_setup
}
src_prepare() {