summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2009-03-19 21:36:04 +0000
committerNed Ludd <solar@gentoo.org>2009-03-19 21:36:04 +0000
commit1c19b06cb86e2909b7ef02069d11e75b55ab7c6f (patch)
treed959db133e66cd113c83c90ab0900bd169cb9982 /x11-drivers
parentadd ~x86, bug #228621 (diff)
downloadgentoo-2-1c19b06cb86e2909b7ef02069d11e75b55ab7c6f.tar.gz
gentoo-2-1c19b06cb86e2909b7ef02069d11e75b55ab7c6f.tar.bz2
gentoo-2-1c19b06cb86e2909b7ef02069d11e75b55ab7c6f.zip
- sync up this package with debians xf86-input-tslib_0.0.5-6 patchset. bug 262993 (thank slonopotamus for pointing this out)
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-tslib/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.5-r1.ebuild64
2 files changed, 71 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-tslib/ChangeLog b/x11-drivers/xf86-input-tslib/ChangeLog
index d10575408fed..89b454773736 100644
--- a/x11-drivers/xf86-input-tslib/ChangeLog
+++ b/x11-drivers/xf86-input-tslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-tslib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.2 2009/02/24 18:02:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.3 2009/03/19 21:36:04 solar Exp $
+
+*xf86-input-tslib-0.0.5-r1 (19 Mar 2009)
+
+ 19 Mar 2009; <solar@gentoo.org> +xf86-input-tslib-0.0.5-r1.ebuild:
+ - sync up this package with debians xf86-input-tslib_0.0.5-6 patchset. bug
+ 262993 (thank slonopotamus for pointing this out)
24 Feb 2009; Raúl Porcel <armin76@gentoo.org>
xf86-input-tslib-0.0.5.ebuild:
diff --git a/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.5-r1.ebuild b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.5-r1.ebuild
new file mode 100644
index 000000000000..382ec9fff010
--- /dev/null
+++ b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.5-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.5-r1.ebuild,v 1.1 2009/03/19 21:36:04 solar Exp $
+
+# Based on xf86-input-synaptics ebuild
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+PATCHLEVEL=6
+PATCHFILE="${PN}_${PV}-${PATCHLEVEL}.diff"
+
+DESCRIPTION="xorg input driver for use of tslib based touchscreen devices"
+HOMEPAGE="http://www.pengutronix.de/software/${PN}/index_en.html"
+SRC_URI="http://www.pengutronix.de/software/${PN}/download/${P}.tar.bz2
+ ftp://cdn.debian.net/debian/pool/main/x/${PN}/${PATCHFILE}.gz"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+LICENSE="GPL-2"
+IUSE=""
+RDEPEND="x11-libs/tslib"
+DEPEND="${RDEPEND}
+ x11-base/xorg-server
+ x11-proto/inputproto"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "tslib x11 input driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ cd "${WORKDIR}"
+ epatch "${WORKDIR}/${PATCHFILE}"
+ EPATCH_OPTS="-p0" EPATCH_SOURCE="${S}/debian/patches" EPATCH_SUFFIX="diff" EPATCH_FORCE="yes" epatch
+}
+
+src_install() {
+ DOCS="COPYING ChangeLog"
+ x-modular_src_install
+ insinto /usr/share/hal/fdi/policy/20thirdparty/
+ doins "${S}/debian/10-x11-input-tslib.fdi"
+}