summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-11-13 04:53:46 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-11-13 04:53:46 +0000
commit185a0159fc409d76d113753b6cd8e119678720aa (patch)
tree538be5007b40a932ee6f25393ac47e89312cc343 /x11-drivers
parentremove unused sys-power/hibernate-script:logrotate use flag (diff)
downloadgentoo-2-185a0159fc409d76d113753b6cd8e119678720aa.tar.gz
gentoo-2-185a0159fc409d76d113753b6cd8e119678720aa.tar.bz2
gentoo-2-185a0159fc409d76d113753b6cd8e119678720aa.zip
Bump to latest RC. Fixes: cursor-related hangs; LVDS fixes; support for new DDC type, 6; BIOS/dock/LVDS hardware state fixes.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog9
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.1966
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.7.196.ebuild35
3 files changed, 49 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index a57c3fb2916e..7fb834816932 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.54 2007/10/06 00:54:17 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.55 2007/11/13 04:53:45 dberkholz Exp $
+
+*xf86-video-ati-6.7.196 (13 Nov 2007)
+
+ 13 Nov 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.7.196.ebuild:
+ Bump to latest RC. Fixes: cursor-related hangs; LVDS fixes; support for new
+ DDC type, 6; BIOS/dock/LVDS hardware state fixes.
*xf86-video-ati-6.7.195 (06 Oct 2007)
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.196 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.196
new file mode 100644
index 000000000000..97f34ffcf0c4
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.7.196
@@ -0,0 +1,6 @@
+MD5 56566e8c3fb4bb99791d1788d0a9a1a8 x11-driver-patches-4.tar.bz2 346
+RMD160 fcbd405de080d07612d46f455b927035fd8123a8 x11-driver-patches-4.tar.bz2 346
+SHA256 07069bbd072f2def50e83801a8f2a41a4c96495104f15cd6f56f7df7f89769bf x11-driver-patches-4.tar.bz2 346
+MD5 06db625391c75c8be86c4dd5a5d713e6 xf86-video-ati-6.7.196.tar.bz2 787475
+RMD160 fae77f0f9e4acaed755617ce53214e73f53c10cf xf86-video-ati-6.7.196.tar.bz2 787475
+SHA256 8923a08232255ceacf770ef767d86bbfb195dffa9559baa1b1de90f9c947a6d9 xf86-video-ati-6.7.196.tar.bz2 787475
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.196.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.196.ebuild
new file mode 100644
index 000000000000..86e4cf00d835
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.196.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.7.196.ebuild,v 1.1 2007/11/13 04:53:45 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+XDPVER=4
+
+inherit x-modular
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}