summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:57:17 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-04-29 16:57:17 +0000
commit0c670d7275d9f150893ad562bce9f6657bbbf4b0 (patch)
tree32250e41c2bb965ae8847bd28ad6f7976be4d494 /x11-drivers
parentVersion bump. Adds names for various members of the Quadro FX series. (diff)
downloadgentoo-2-0c670d7275d9f150893ad562bce9f6657bbbf4b0.tar.gz
gentoo-2-0c670d7275d9f150893ad562bce9f6657bbbf4b0.tar.bz2
gentoo-2-0c670d7275d9f150893ad562bce9f6657bbbf4b0.zip
Version bump. Includes the memory map fixes that are in the 6.6 series.
(Portage version: 2.1_pre10)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.8.06
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.5.8.0.ebuild31
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 00f0a1a3293f..11991992b3a6 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.24 2006/04/16 14:05:42 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.25 2006/04/29 16:57:17 joshuabaergen Exp $
+
+*xf86-video-ati-6.5.8.0 (29 Apr 2006)
+
+ 29 Apr 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ +xf86-video-ati-6.5.8.0.ebuild:
+ Version bump. Includes the memory map fixes that are in the 6.6 series.
16 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
xf86-video-ati-6.5.7.3.ebuild:
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.8.0 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.8.0
new file mode 100644
index 000000000000..e78bfb5fbff5
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.5.8.0
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 6d99444b698b762d689b30a1e4f36c55 xf86-video-ati-6.5.8.0.tar.bz2 683625
+RMD160 f774fc0a4e49481278ab220d454cf7bd8fad85cb xf86-video-ati-6.5.8.0.tar.bz2 683625
+SHA256 564efc8f8e9b46bb0f8ae49d91d2a51a572f0294e571cc9d91dc6ed253ba119d xf86-video-ati-6.5.8.0.tar.bz2 683625
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.8.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.8.0.ebuild
new file mode 100644
index 000000000000..195d911bb264
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.8.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.5.8.0.ebuild,v 1.1 2006/04/29 16:57:17 joshuabaergen Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND="x11-base/xorg-server"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}