summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2008-09-08 10:17:49 +0000
committerTony Vroon <chainsaw@gentoo.org>2008-09-08 10:17:49 +0000
commit05431ce7d1a7105a9babf39826bd22d5052934f5 (patch)
tree8903a6d77eb26a1ca0ac7478d9a57fbb335f94ff /x11-drivers
parentforgot to mention Benoit's credits in the changelog... (diff)
downloadgentoo-2-05431ce7d1a7105a9babf39826bd22d5052934f5.tar.gz
gentoo-2-05431ce7d1a7105a9babf39826bd22d5052934f5.tar.bz2
gentoo-2-05431ce7d1a7105a9babf39826bd22d5052934f5.zip
Version bump, closes bug #237034 by Kamil Kamiński <kamil@mrblur.net>. X.Org version patch was applied upstream.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5-00131-g5f17cfc-dirty x86_64)
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1.ebuild67
2 files changed, 74 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 73d4a5374487..9cb508842389 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.6 2008/08/24 14:12:52 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.7 2008/09/08 10:17:49 chainsaw Exp $
+
+*xf86-input-synaptics-0.15.1 (08 Sep 2008)
+
+ 08 Sep 2008; <chainsaw@gentoo.org> +xf86-input-synaptics-0.15.1.ebuild:
+ Version bump, closes bug #237034 by Kamil Kamiński <kamil@mrblur.net>.
+ X.Org version patch was applied upstream.
24 Aug 2008; Markus Rothe <corsair@gentoo.org>
xf86-input-synaptics-0.15.0-r1.ebuild:
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1.ebuild
new file mode 100644
index 000000000000..2971af628851
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-0.15.1.ebuild,v 1.1 2008/09/08 10:17:49 chainsaw Exp $
+
+inherit toolchain-funcs eutils linux-info x-modular
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+LICENSE="MIT"
+IUSE="hal"
+RDEPEND="x11-libs/libXext
+ hal? ( sys-apps/hal )"
+DEPEND="${RDEPEND}
+ !x11-drivers/synaptics
+ x11-base/xorg-server
+ x11-proto/inputproto
+ >=sys-apps/sed-4"
+
+evdev-input_check() {
+ # Check kernel config for required event interface support (either
+ # built-in or as a module. Bug #134309.
+
+ ebegin "Checking kernel config for event device support"
+ linux_chkconfig_present INPUT_EVDEV
+ eend $?
+
+ if [[ $? -ne 0 ]] ; then
+ ewarn "Synaptics driver requires event interface support."
+ ewarn "Please enable the event interface in your kernel config."
+ ewarn "The option can be found at:"
+ ewarn
+ ewarn " Device Drivers"
+ ewarn " Input device support"
+ ewarn " -*- Generic input layer"
+ ewarn " <*> Event interface"
+ ewarn
+ ewarn "Then rebuild the kernel or install the module."
+ epause 5
+ fi
+}
+
+pkg_setup() {
+ linux-info_pkg_setup
+ evdev-input_check
+}
+
+src_unpack() {
+ x-modular_unpack_source
+ # Fix to handle multiple screens through Xinerama properly. Bug #206614.
+ epatch "${FILESDIR}"/synaptics-fix-xinerama.patch
+}
+
+src_install() {
+ DOCS="INSTALL NEWS TODO README"
+ x-modular_src_install
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd "${FILESDIR}"/rc.init syndaemon
+ newconfd "${FILESDIR}"/rc.conf syndaemon
+
+ if use hal ; then
+ # Have HAL assign this driver to supported touchpads.
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ doins "${FILESDIR}"/11-x11-synaptics.fdi
+ fi
+}