summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-06-27 05:20:55 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-06-27 05:20:55 +0000
commit967be489d5c733be03baad4e8101830c2f147298 (patch)
tree50ad38cca093dc80684b6aa231c8d6b0d443ca44 /x11-drivers/xf86-video-ati
parentNew package: ATI Mach64 video driver, split off from xf86-video-ati between 6... (diff)
downloadgentoo-2-967be489d5c733be03baad4e8101830c2f147298.tar.gz
gentoo-2-967be489d5c733be03baad4e8101830c2f147298.tar.bz2
gentoo-2-967be489d5c733be03baad4e8101830c2f147298.zip
Bump. Major features include: Improved EXA render support for r1xx/r2xx cards; EXA render support for r3xx/r4xx/r5xx cards; Textured video support for Xv (r1xx-r5xx). Also, the mach64 and r128 drivers now exist as their own packages, xf86-video-mach64 and xf86-video-r128. If you have VIDEO_CARDS set up, they should get pulled in automatically by xorg-server-1.4.2 and newer. (I'm committing those changes right after this.)
(Portage version: 2.1.5.6)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog14
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild48
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 5f7d3e972b7d..09a71ca8c562 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.62 2008/04/10 08:04:39 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.63 2008/06/27 05:20:55 dberkholz Exp $
+
+*xf86-video-ati-6.9.0 (27 Jun 2008)
+
+ 27 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.9.0.ebuild:
+ Bump. Major features include: Improved EXA render support for r1xx/r2xx
+ cards; EXA render support for r3xx/r4xx/r5xx cards; Textured video support
+ for Xv (r1xx-r5xx). Also, the mach64 and r128 drivers now exist as their
+ own packages, xf86-video-mach64 and xf86-video-r128. If you have
+ VIDEO_CARDS set up, they should get pulled in automatically by
+ xorg-server-1.4.2 and newer. (I'm committing those changes right after
+ this.)
*xf86-video-ati-6.8.0-r1 (10 Apr 2008)
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild
new file mode 100644
index 000000000000..73bb20fb0b25
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.9.0.ebuild,v 1.1 2008/06/27 05:20:55 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+PATCHES=""
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}