summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-10-04 01:56:43 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-10-04 01:56:43 +0000
commit6e69876cbaa4d31faa734c424293767921a7c8d5 (patch)
tree14d4648e4fff6af65232a32a554bad7c9ab516d1 /x11-drivers/xf86-video-ati
parentSetting DEPEND and RDEPEND explicitly. Fixed autotools eclass usage. (diff)
downloadgentoo-2-6e69876cbaa4d31faa734c424293767921a7c8d5.tar.gz
gentoo-2-6e69876cbaa4d31faa734c424293767921a7c8d5.tar.bz2
gentoo-2-6e69876cbaa4d31faa734c424293767921a7c8d5.zip
Bump, fixes rn50/M6/M7 and some other misc stuff.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'x11-drivers/xf86-video-ati')
-rw-r--r--x11-drivers/xf86-video-ati/ChangeLog8
-rw-r--r--x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.36
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild31
3 files changed, 44 insertions, 1 deletions
diff --git a/x11-drivers/xf86-video-ati/ChangeLog b/x11-drivers/xf86-video-ati/ChangeLog
index 8955f0cf7bfc..6d9646e8264d 100644
--- a/x11-drivers/xf86-video-ati/ChangeLog
+++ b/x11-drivers/xf86-video-ati/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-video-ati
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.35 2006/09/05 23:45:31 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/ChangeLog,v 1.36 2006/10/04 01:56:43 dberkholz Exp $
+
+*xf86-video-ati-6.6.3 (04 Oct 2006)
+
+ 04 Oct 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ +xf86-video-ati-6.6.3.ebuild:
+ Bump, fixes rn50/M6/M7 and some other misc stuff.
05 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>; +files/ati.xinf,
+files/r128.xinf, +files/radeon.xinf:
diff --git a/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.3 b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.3
new file mode 100644
index 000000000000..4c939fcf7761
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/files/digest-xf86-video-ati-6.6.3
@@ -0,0 +1,6 @@
+MD5 1b8cfd2923836ee93eda69abe50dda04 x11-driver-patches-1.tar.bz2 389
+RMD160 0c57d4b235d83f3d7c46691c13857fd121ddec2d x11-driver-patches-1.tar.bz2 389
+SHA256 64787d5b57d2845c0fa9297a9d924093ba191fc3551798239d9983f0bcca9b3e x11-driver-patches-1.tar.bz2 389
+MD5 f6d559f9d20f61567d381916b376590f xf86-video-ati-6.6.3.tar.bz2 723083
+RMD160 a1c24c13ea88fa38f34e3f0540b53082ab2ae129 xf86-video-ati-6.6.3.tar.bz2 723083
+SHA256 d08a429e1fb1620ae81839181a4dc6cd579d52fc440d44d7bba36d19be355780 xf86-video-ati-6.6.3.tar.bz2 723083
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild
new file mode 100644
index 000000000000..8cd36cede9ea
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.6.3.ebuild,v 1.1 2006/10/04 01:56:43 dberkholz Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular
+
+DESCRIPTION="X.Org driver for ati cards"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+RDEPEND=">=x11-base/xorg-server-1.0.99"
+DEPEND="${RDEPEND}
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+pkg_setup() {
+ if use dri && ! built_with_use x11-base/xorg-server dri; then
+ die "Build x11-base/xorg-server with USE=dri."
+ fi
+}