summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-03-31 15:03:50 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-03-31 15:03:50 +0000
commitef393b177c6fbdc5b902b1a2af4d2ae47b017502 (patch)
tree310f77c470d22dfaf2bcc6b29c215a7fd66a92cb /x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
parentRemoved old version. (diff)
downloadgentoo-2-ef393b177c6fbdc5b902b1a2af4d2ae47b017502.tar.gz
gentoo-2-ef393b177c6fbdc5b902b1a2af4d2ae47b017502.tar.bz2
gentoo-2-ef393b177c6fbdc5b902b1a2af4d2ae47b017502.zip
Revision bump. Apply upstream patches for various bugs. Remove old.
(Portage version: 2.2_rc28/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild')
-rw-r--r--x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
new file mode 100644
index 000000000000..083154301057
--- /dev/null
+++ b/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-video-ati/xf86-video-ati-6.12.1-r1.ebuild,v 1.1 2009/03/31 15:03:50 scarabeus Exp $
+
+# Must be before x-modular eclass is inherited
+#SNAPSHOT="yes"
+
+inherit x-modular eutils
+
+DESCRIPTION="ATI video driver"
+
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="dri"
+
+SRC_PATCHES="http://dev.gentooexperimental.org/~scarabeus/${PV}-patches-01.tar.bz2"
+SRC_URI="${SRC_URI}
+ ${SRC_PATCHES}"
+
+RDEPEND=">=x11-base/xorg-server-1.2"
+DEPEND="${RDEPEND}
+ >=x11-misc/util-macros-1.1.3
+ x11-proto/fontsproto
+ x11-proto/randrproto
+ x11-proto/videoproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xf86miscproto
+ x11-proto/xproto
+ dri? ( x11-proto/glproto
+ x11-proto/xf86driproto
+ >=x11-libs/libdrm-2 )"
+
+CONFIGURE_OPTIONS="$(use_enable dri)"
+
+PATCHES=""
+
+src_unpack() {
+ x-modular_src_unpack
+ if [[ -n "${SRC_PATCHES}" ]]; then
+ EPATCH_FORCE="yes" \
+ EPATCH_SOURCE="${WORKDIR}/patches" \
+ EPATCH_SUFFIX="patch" \
+ epatch
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ ewarn "If you have a mach64 or r128 video card, read this"
+ ewarn "The mach64 and r128 drivers moved to their own packages,"
+ ewarn "xf86-video-mach64 and xf86-video-r128. If these weren't installed"
+ ewarn "automatically by xorg-server and you have one of these cards,"
+ ewarn "check your VIDEO_CARDS settings."
+ ebeep
+ epause
+}