summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-04-29 17:52:30 +0000
committerMike Auty <ikelos@gentoo.org>2010-04-29 17:52:30 +0000
commitaef6013b26c664e2aaee23c1a86ddf6b7d423ed9 (patch)
treeeb66c10d93e9a504ed331e405d8597ed96ac9fd4 /x11-drivers/xf86-input-wacom
parentTry two at guessing what zlib wanted to do, assume a mistake between .4 and .... (diff)
downloadgentoo-2-aef6013b26c664e2aaee23c1a86ddf6b7d423ed9.tar.gz
gentoo-2-aef6013b26c664e2aaee23c1a86ddf6b7d423ed9.tar.bz2
gentoo-2-aef6013b26c664e2aaee23c1a86ddf6b7d423ed9.zip
Version bump xf86-input-wacom.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog8
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.6.ebuild54
2 files changed, 61 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 604bdd2d00db..5a3477a2c7e7 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.15 2010/04/18 16:25:34 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.16 2010/04/29 17:52:30 ikelos Exp $
+
+*xf86-input-wacom-0.10.6 (29 Apr 2010)
+
+ 29 Apr 2010; Mike Auty <ikelos@gentoo.org>
+ +xf86-input-wacom-0.10.6.ebuild:
+ Version bump xf86-input-wacom.
18 Apr 2010; <nixnut@gentoo.org> xf86-input-wacom-0.10.4.ebuild:
ppc stable #308521
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.6.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.6.ebuild
new file mode 100644
index 000000000000..e1986760b318
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.6.ebuild,v 1.1 2010/04/29 17:52:30 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+COMMON_DEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+RDEPEND="${COMMON_DEPEND}
+ !x11-drivers/linuxwacom"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ x-modular_src_install
+
+ use hal || rm -fr "${D}/usr/share/hal"
+
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}