summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Auty <ikelos@gentoo.org>2010-02-09 11:57:21 +0000
committerMike Auty <ikelos@gentoo.org>2010-02-09 11:57:21 +0000
commit8478770242914f000d149d24f87ee23c57ed80ed (patch)
tree6e614fc768998b28ae36d060e0b719a2a6dfd399 /x11-drivers/xf86-input-wacom
parentamd64 stable, bug 299560 (diff)
downloadgentoo-2-8478770242914f000d149d24f87ee23c57ed80ed.tar.gz
gentoo-2-8478770242914f000d149d24f87ee23c57ed80ed.tar.bz2
gentoo-2-8478770242914f000d149d24f87ee23c57ed80ed.zip
Version bump xf86-input-wacom to 0.10.4, closes bug 304081, thanks to Matthew Turnbull.
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'x11-drivers/xf86-input-wacom')
-rw-r--r--x11-drivers/xf86-input-wacom/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.4.ebuild57
2 files changed, 65 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-wacom/ChangeLog b/x11-drivers/xf86-input-wacom/ChangeLog
index 38166dd5794f..03d80d185f9c 100644
--- a/x11-drivers/xf86-input-wacom/ChangeLog
+++ b/x11-drivers/xf86-input-wacom/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-wacom
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.10 2010/01/18 15:46:56 rbu Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/ChangeLog,v 1.11 2010/02/09 11:57:21 ikelos Exp $
+
+*xf86-input-wacom-0.10.4 (09 Feb 2010)
+
+ 09 Feb 2010; Mike Auty <ikelos@gentoo.org>
+ +xf86-input-wacom-0.10.4.ebuild:
+ Version bump xf86-input-wacom to 0.10.4, closes bug 304081, thanks to
+ Matthew Turnbull.
18 Jan 2010; Robert Buchholz <rbu@gentoo.org> metadata.xml:
Dropping maintenance
diff --git a/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.4.ebuild b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.4.ebuild
new file mode 100644
index 000000000000..65ebcdd62902
--- /dev/null
+++ b/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-wacom/xf86-input-wacom-0.10.4.ebuild,v 1.1 2010/02/09 11:57:21 ikelos Exp $
+
+EAPI="2"
+
+inherit linux-info x-modular
+
+DESCRIPTION="Driver for Wacom tablets and drawing devices"
+LICENSE="GPL-2"
+EGIT_REPO_URI="git://linuxwacom.git.sourceforge.net/gitroot/linuxwacom/${PN}"
+[[ ${PV} != 9999* ]] && \
+ SRC_URI="mirror://sourceforge/linuxwacom/files/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="hal debug"
+
+COMMON_DEPEND=">=x11-base/xorg-server-1.6
+ hal? ( sys-apps/hal )"
+RDEPEND="${COMMON_DEPEND}
+ !x11-drivers/linuxwacom"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/inputproto
+ x11-proto/xproto"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ CONFIGURE_OPTIONS="$(use_enable debug)"
+}
+
+src_install() {
+ x-modular_src_install
+ rm -r "${D}/usr/share/hal"
+
+ if use hal; then
+ insinto /usr/share/hal/fdi/policy/10osvendor
+ newins "${S}"/fdi/wacom.fdi 11-x11-wacom.fdi
+ fi
+}
+
+pkg_postinst() {
+ x-modular_pkg_postinst
+
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present TABLET_USB_WACOM \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "If you use a USB Wacom tablet, you need to enable support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ ewarn " [*] Tablets --->"
+ ewarn " <*> Wacom Intuos/Graphire tablet support (USB)"
+ echo
+ fi
+}