summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-15 15:16:21 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2013-09-15 15:16:21 +0000
commitac39a6b6caed6e5b7fe32419da7894b01330dbbf (patch)
treecb0a1d2915f06ff7b9160336d9b778332a202219 /x11-drivers/xf86-input-tslib
parentmedia-plugins/vdr-tvtv masked for removal on ~15/Oct/2013, Bug #414255 #414177 (diff)
downloadgentoo-2-ac39a6b6caed6e5b7fe32419da7894b01330dbbf.tar.gz
gentoo-2-ac39a6b6caed6e5b7fe32419da7894b01330dbbf.tar.bz2
gentoo-2-ac39a6b6caed6e5b7fe32419da7894b01330dbbf.zip
Add patch for compatibility with more recent xorg-server versions, bug #446432.
(Portage version: 2.2.1/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-drivers/xf86-input-tslib')
-rw-r--r--x11-drivers/xf86-input-tslib/ChangeLog13
-rw-r--r--x11-drivers/xf86-input-tslib/files/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch23
-rw-r--r--x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6-r3.ebuild32
3 files changed, 65 insertions, 3 deletions
diff --git a/x11-drivers/xf86-input-tslib/ChangeLog b/x11-drivers/xf86-input-tslib/ChangeLog
index bc861d247b63..4f15f2f0b46e 100644
--- a/x11-drivers/xf86-input-tslib/ChangeLog
+++ b/x11-drivers/xf86-input-tslib/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-input-tslib
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.43 2012/06/08 13:58:00 pacho Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/ChangeLog,v 1.44 2013/09/15 15:16:21 chithanh Exp $
+
+*xf86-input-tslib-0.0.6-r3 (15 Sep 2013)
+
+ 15 Sep 2013; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch,
+ +xf86-input-tslib-0.0.6-r3.ebuild:
+ Add patch for compatibility with more recent xorg-server versions, bug
+ #446432.
08 Jun 2012; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop maintainer from metadata as talked with him.
@@ -179,4 +187,3 @@
+xf86-input-tslib-0.0.5.ebuild:
- initial import of x11-drivers/xf86-input-tslib for future xorg use to
replace kdrive only functionality
-
diff --git a/x11-drivers/xf86-input-tslib/files/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch b/x11-drivers/xf86-input-tslib/files/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch
new file mode 100644
index 000000000000..d3738bfecb96
--- /dev/null
+++ b/x11-drivers/xf86-input-tslib/files/xf86-input-tslib-0.0.6-xf86XInputSetScreen.patch
@@ -0,0 +1,23 @@
+diff -ur xf86-input-tslib-0.0.6.orig/src/tslib.c xf86-input-tslib-0.0.6/src/tslib.c
+--- xf86-input-tslib-0.0.6.orig/src/tslib.c 2012-12-05 01:12:16.286597071 +0100
++++ xf86-input-tslib-0.0.6/src/tslib.c 2012-12-05 01:11:02.686598595 +0100
+@@ -75,6 +75,19 @@
+ #define COLLECT_INPUT_OPTIONS(pInfo, options) xf86CollectInputOptions((pInfo), (options))
+ #endif
+
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) > 13
++static void
++xf86XInputSetScreen(InputInfoPtr pInfo,
++ int screen_number,
++ int x,
++ int y)
++{
++ if (miPointerGetScreen(pInfo->dev) !=
++ screenInfo.screens[screen_number]) {
++ miPointerSetScreen(pInfo->dev, screen_number, x, y);
++ }
++}
++#endif
+
+ enum { TSLIB_ROTATE_NONE=0, TSLIB_ROTATE_CW=270, TSLIB_ROTATE_UD=180, TSLIB_ROTATE_CCW=90 };
+
diff --git a/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6-r3.ebuild b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6-r3.ebuild
new file mode 100644
index 000000000000..2aaa9dfd7f8c
--- /dev/null
+++ b/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6-r3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-tslib/xf86-input-tslib-0.0.6-r3.ebuild,v 1.1 2013/09/15 15:16:21 chithanh Exp $
+
+EAPI=5
+
+inherit xorg-2
+
+PATCHLEVEL=3
+DEBSOURCES="${PN}_${PV}-${PATCHLEVEL}.tar.gz"
+
+DESCRIPTION="xorg input driver for use of tslib based touchscreen devices"
+HOMEPAGE="http://www.pengutronix.de/software/xf86-input-tslib/index_en.html"
+SRC_URI="ftp://cdn.debian.net/debian/pool/main/x/${PN}/${DEBSOURCES}"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/tslib"
+DEPEND="${RDEPEND}
+ x11-proto/randrproto"
+
+S=${WORKDIR}/${PN}-trunk
+
+DOCS=( COPYING ChangeLog )
+
+PATCHES=(
+ "${FILESDIR}"/fix-overlapped-variable.patch
+ "${FILESDIR}"/${PN}-port-ABI-12-r48.patch
+ "${FILESDIR}"/${P}-xf86XInputSetScreen.patch
+)