summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 22:27:42 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-03-18 22:27:42 +0000
commitccb8149d4ca1584ebebec6a1715dace22c37f157 (patch)
treef77591f9e632a19a6e8a8ccbc3c901807a629191 /x11-drivers/xf86-input-synaptics
parentAs pointed out by Michael "Mr. Bones" Sterret, it is no longer possible to de... (diff)
downloadgentoo-2-ccb8149d4ca1584ebebec6a1715dace22c37f157.tar.gz
gentoo-2-ccb8149d4ca1584ebebec6a1715dace22c37f157.tar.bz2
gentoo-2-ccb8149d4ca1584ebebec6a1715dace22c37f157.zip
Fix acceleration on xorg-server-1.12, thanks to anarchy for testing.
(Portage version: 2.2.0_alpha90/cvs/Linux x86_64)
Diffstat (limited to 'x11-drivers/xf86-input-synaptics')
-rw-r--r--x11-drivers/xf86-input-synaptics/ChangeLog9
-rw-r--r--x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.5.0-abi-14-acceleration.patch42
-rw-r--r--x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0-r1.ebuild43
3 files changed, 93 insertions, 1 deletions
diff --git a/x11-drivers/xf86-input-synaptics/ChangeLog b/x11-drivers/xf86-input-synaptics/ChangeLog
index 98ffab42f03b..95e988165508 100644
--- a/x11-drivers/xf86-input-synaptics/ChangeLog
+++ b/x11-drivers/xf86-input-synaptics/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-drivers/xf86-input-synaptics
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.67 2012/03/18 19:33:44 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/ChangeLog,v 1.68 2012/03/18 22:27:42 chithanh Exp $
+
+*xf86-input-synaptics-1.5.0-r1 (18 Mar 2012)
+
+ 18 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +files/xf86-input-synaptics-1.5.0-abi-14-acceleration.patch,
+ +xf86-input-synaptics-1.5.0-r1.ebuild:
+ Fix acceleration on xorg-server-1.12, thanks to anarchy for testing.
18 Mar 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+files/xf86-input-synaptics-1.5.0-abi-lt14.patch,
diff --git a/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.5.0-abi-14-acceleration.patch b/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.5.0-abi-14-acceleration.patch
new file mode 100644
index 000000000000..61a0680eec26
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/files/xf86-input-synaptics-1.5.0-abi-14-acceleration.patch
@@ -0,0 +1,42 @@
+From 7c0361d4ec6b1f1325cb6551d0ee2e7f5cfae15b Mon Sep 17 00:00:00 2001
+From: Daniel Stone <daniel@fooishbar.org>
+Date: Thu, 09 Jun 2011 19:03:05 +0000
+Subject: Adjust acceleration scheme for input ABI v14
+
+v14 wants doubles, rather than floats, from acceleration schemes.
+
+Signed-off-by: Daniel Stone <daniel@fooishbar.org>
+Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+diff --git a/src/synaptics.c b/src/synaptics.c
+index c44d1f7..e05147e 100644
+--- a/src/synaptics.c
++++ b/src/synaptics.c
+@@ -593,11 +593,22 @@ static void set_default_parameters(InputInfoPtr pInfo)
+ }
+ }
+
++#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) >= 14
++static double SynapticsAccelerationProfile(DeviceIntPtr dev,
++ DeviceVelocityPtr vel,
++ double velocity,
++ double thr,
++ double acc) {
++#else
+ static float SynapticsAccelerationProfile(DeviceIntPtr dev,
+ DeviceVelocityPtr vel,
+- float velocity,
+- float thr,
+- float acc) {
++ float velocity_f,
++ float thr_f,
++ float acc_f) {
++ double velocity = velocity_f;
++ double thr = thr_f;
++ double acc = acc_f;
++#endif
+ InputInfoPtr pInfo = dev->public.devicePrivate;
+ SynapticsPrivate *priv = (SynapticsPrivate *) (pInfo->private);
+ SynapticsParameters* para = &priv->synpara;
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0-r1.ebuild b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..e64d774f7961
--- /dev/null
+++ b/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-synaptics/xf86-input-synaptics-1.5.0-r1.ebuild,v 1.1 2012/03/18 22:27:42 chithanh Exp $
+
+EAPI=4
+
+inherit linux-info xorg-2
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://cgit.freedesktop.org/xorg/driver/xf86-input-synaptics/"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="
+ >=x11-base/xorg-server-1.8
+ >=x11-libs/libXi-1.2
+ >=x11-libs/libXtst-1.1.0"
+DEPEND="${RDEPEND}
+ >=x11-proto/recordproto-1.14"
+
+DOCS=( "README" )
+
+pkg_pretend() {
+ linux-info_pkg_setup
+ # Just a friendly warning
+ if ! linux_config_exists \
+ || ! linux_chkconfig_present INPUT_EVDEV; then
+ echo
+ ewarn "This driver requires event interface support in your kernel"
+ ewarn " Device Drivers --->"
+ ewarn " Input device support --->"
+ ewarn " <*> Event interface"
+ echo
+ fi
+}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5.0-xf86optionrec.patch
+ "${FILESDIR}"/${PN}-1.5.0-abi-14-acceleration.patch
+ "${FILESDIR}"/${PN}-1.5.0-xf86setstroption.patch
+ "${FILESDIR}"/${PN}-1.5.0-abi-lt14.patch
+)