summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-06-09 05:08:16 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-06-09 05:08:16 +0000
commitc213e9fe59f1a3a6162ee2ba4ef1c1a83efd3eb9 (patch)
tree21b4307b231e3b8c48c57ff2c08abff00a2f5205 /x11-drivers/xf86-input-evdev
parentwhitespace (diff)
downloadgentoo-2-c213e9fe59f1a3a6162ee2ba4ef1c1a83efd3eb9.tar.gz
gentoo-2-c213e9fe59f1a3a6162ee2ba4ef1c1a83efd3eb9.tar.bz2
gentoo-2-c213e9fe59f1a3a6162ee2ba4ef1c1a83efd3eb9.zip
(#225181) Bump with patch to fix moving pointers across multiple screens.
(Portage version: 2.1.5.4)
Diffstat (limited to 'x11-drivers/xf86-input-evdev')
-rw-r--r--x11-drivers/xf86-input-evdev/ChangeLog10
-rw-r--r--x11-drivers/xf86-input-evdev/files/1.99.2/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patch36
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r2.ebuild (renamed from x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r1.ebuild)3
-rw-r--r--x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild34
4 files changed, 47 insertions, 36 deletions
diff --git a/x11-drivers/xf86-input-evdev/ChangeLog b/x11-drivers/xf86-input-evdev/ChangeLog
index 5b660449ffe2..777c1a54f27e 100644
--- a/x11-drivers/xf86-input-evdev/ChangeLog
+++ b/x11-drivers/xf86-input-evdev/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-drivers/xf86-input-evdev
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.79 2008/06/07 19:36:47 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/ChangeLog,v 1.80 2008/06/09 05:08:16 dberkholz Exp $
+
+*xf86-input-evdev-1.99.2-r2 (09 Jun 2008)
+
+ 09 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.99.2/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patc
+ h, -xf86-input-evdev-1.99.2.ebuild, -xf86-input-evdev-1.99.2-r1.ebuild,
+ +xf86-input-evdev-1.99.2-r2.ebuild:
+ (#225181) Bump with patch to fix moving pointers across multiple screens.
07 Jun 2008; Donnie Berkholz <dberkholz@gentoo.org>;
xf86-input-evdev-1.1.5-r1.ebuild:
diff --git a/x11-drivers/xf86-input-evdev/files/1.99.2/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patch b/x11-drivers/xf86-input-evdev/files/1.99.2/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patch
new file mode 100644
index 000000000000..05f60a48edfa
--- /dev/null
+++ b/x11-drivers/xf86-input-evdev/files/1.99.2/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patch
@@ -0,0 +1,36 @@
+From fec73e1418a4da1b64496faca27b06fef0aa5206 Mon Sep 17 00:00:00 2001
+From: Sven Wegener <swegener@gentoo.org>
+Date: Sat, 7 Jun 2008 13:01:22 +0200
+Subject: [PATCH] evdev: Port b4a5a204 "Fix pointer crossing screen bug." to current master branch
+
+The commit b4a5a204 fixed an issue, where we can't move the pointer to
+other screens and this happens in current master branch again. This commit
+ports the old commit to the current master branch.
+
+Signed-off-by: Sven Wegener <swegener@gentoo.org>
+Signed-off-by: Peter Hutterer <peter@cs.unisa.edu.au>
+---
+ src/evdev.c | 4 ++--
+ 1 files changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/src/evdev.c b/src/evdev.c
+index b146d41..bd01316 100644
+--- a/src/evdev.c
++++ b/src/evdev.c
+@@ -767,11 +767,11 @@ EvdevAddRelClass(DeviceIntPtr device)
+ return !Success;
+
+ /* X valuator */
+- xf86InitValuatorAxisStruct(device, 0, 0, -1, 1, 0, 1);
++ xf86InitValuatorAxisStruct(device, 0, -1, -1, 1, 0, 1);
+ xf86InitValuatorDefaults(device, 0);
+
+ /* Y valuator */
+- xf86InitValuatorAxisStruct(device, 1, 0, -1, 1, 0, 1);
++ xf86InitValuatorAxisStruct(device, 1, -1, -1, 1, 0, 1);
+ xf86InitValuatorDefaults(device, 1);
+ xf86MotionHistoryAllocate(pInfo);
+
+--
+1.5.5.1
+
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r1.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r2.ebuild
index 63454937ed0f..1ad256925121 100644
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r1.ebuild
+++ b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r1.ebuild,v 1.1 2008/06/07 19:35:15 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2-r2.ebuild,v 1.1 2008/06/09 05:08:16 dberkholz Exp $
# Must be before x-modular eclass is inherited
#SNAPSHOT="yes"
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}/${PV}/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch"
"${FILESDIR}/${PV}/0003-Revert-Check-for-XINPUT-ABI-parameters-of-InitValu.patch"
"${FILESDIR}/${PV}/0004-Check-for-XINPUT-ABI-3-corrected-version.patch"
+ "${FILESDIR}/${PV}/0005-evdev-Port-b4a5a204-Fix-pointer-crossing-screen-bu.patch"
)
pkg_postinst() {
diff --git a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild b/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild
deleted file mode 100644
index 97b658abc23c..000000000000
--- a/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-drivers/xf86-input-evdev/xf86-input-evdev-1.99.2.ebuild,v 1.1 2008/06/06 22:07:08 dberkholz Exp $
-
-# Must be before x-modular eclass is inherited
-#SNAPSHOT="yes"
-#XDPVER=4
-
-inherit x-modular
-
-DESCRIPTION="Generic Linux input driver"
-
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~sparc ~x86"
-
-RDEPEND=">=x11-base/xorg-server-1.4.0.90
- >=sys-apps/hal-0.5.10"
-DEPEND="${RDEPEND}
- || ( >=sys-kernel/linux-headers-2.6 >=sys-kernel/mips-headers-2.6 )
- >=x11-proto/inputproto-1.4
- x11-proto/randrproto
- x11-proto/xproto"
-
-PATCHES=(
- "${FILESDIR}/${PV}/0001-Fail-if-the-device-cannot-be-grabbed-during-the-prob.patch"
- "${FILESDIR}/${PV}/0002-Check-for-XINPUT-ABI-parameters-of-InitValuatorClas.patch"
- )
-
-pkg_postinst() {
- elog "If your XKB (keyboard settings) stopped working,"
- elog "you may uninstall this driver or move your XKB configuration."
- elog "Download an example from http://dev.gentoo.org/~compnerd/temp/hal-config-examples/"
- elog "(these will be installed with sys-apps/hal soon),"
- elog "and drop it into /etc/hal/fdi/policy/"
-}