summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-11-03 00:00:12 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-11-03 00:00:12 +0000
commitfaef91da8b0901eb93faa759ce07bb8b680fd21d (patch)
tree706f651e6f1cbbb731de0f4ae3c8ca07b38011ed /x11-drivers/synaptics/synaptics-0.14.6.ebuild
parents:sys-apps/sandbox:>=sys-apps/sandbox-1.2.17:g for bug #153788 (diff)
downloadgentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.tar.gz
gentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.tar.bz2
gentoo-2-faef91da8b0901eb93faa759ce07bb8b680fd21d.zip
version bump, which renders the prior patches unnecessary, sinceupstream fixed the compile issues with xorg-7.1. Also, the manpage installation location is actually finally fixed (closing bug #14112 by KIMURA Masaru / hiyuh). Closes bug #144308 where Pietro Franchi provided the new version
(Portage version: 2.1.2_rc1-r2)
Diffstat (limited to 'x11-drivers/synaptics/synaptics-0.14.6.ebuild')
-rw-r--r--x11-drivers/synaptics/synaptics-0.14.6.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/x11-drivers/synaptics/synaptics-0.14.6.ebuild b/x11-drivers/synaptics/synaptics-0.14.6.ebuild
new file mode 100644
index 000000000000..9b6f2b47fb8d
--- /dev/null
+++ b/x11-drivers/synaptics/synaptics-0.14.6.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-drivers/synaptics/synaptics-0.14.6.ebuild,v 1.1 2006/11/03 00:00:12 seemant Exp $
+
+inherit toolchain-funcs eutils
+
+IUSE="dlloader"
+
+DESCRIPTION="Driver for Synaptics touchpads"
+HOMEPAGE="http://w1.894.telia.com/~u89404340/touchpad/"
+SRC_URI="http://w1.894.telia.com/~u89404340/touchpad/files/${P}.tar.bz2"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+RDEPEND="|| ( x11-libs/libXext virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( x11-base/xorg-server virtual/x11 )
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A} ; cd ${S}
+
+ # Switch up the CC and CFLAGS stuff.
+ sed -i \
+ -e "s:CC = gcc:CC = $(tc-getCC):g" \
+ -e "s:CDEBUGFLAGS = -O2:CDEBUGFLAGS = ${CFLAGS}:g" \
+ ${S}/Makefile
+}
+
+src_compile() {
+# if use dlloader
+# then
+# PICFLAG="-fPic"
+# fi
+
+ emake || die
+}
+
+src_install() {
+ make \
+ DESTDIR=${D} \
+ PREFIX=/usr \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodoc script/usbmouse script/usbhid alps.patch trouble-shooting.txt
+ dodoc COMPATIBILITY FILES INSTALL* LICENSE NEWS TODO README*
+
+ # Stupid new daemon, didn't work for me because of shm issues
+ newinitd ${FILESDIR}/rc.init syndaemon
+ newconfd ${FILESDIR}/rc.conf syndaemon
+}