summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-16 21:49:59 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2011-11-16 21:49:59 +0000
commitf6290385b877681a2f80740df059be90cc86dd0b (patch)
treef848c593d3519980e2399701c0601f6492d028bc /x11-base
parentBug 380259: avoid xtest automagic. (diff)
downloadgentoo-2-f6290385b877681a2f80740df059be90cc86dd0b.tar.gz
gentoo-2-f6290385b877681a2f80740df059be90cc86dd0b.tar.bz2
gentoo-2-f6290385b877681a2f80740df059be90cc86dd0b.zip
Add dependency on libXrender when building dmx, bug #390697. Prevent dbus from starting too late, bug #390609.
(Portage version: 2.2.0_alpha72/cvs/Linux x86_64)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog10
-rw-r--r--x11-base/xorg-server/files/xdm.initd-4220
-rw-r--r--x11-base/xorg-server/xorg-server-1.11.1-r1.ebuild241
-rw-r--r--x11-base/xorg-server/xorg-server-1.11.2-r1.ebuild (renamed from x11-base/xorg-server/xorg-server-1.11.2.ebuild)5
4 files changed, 232 insertions, 244 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index 12bc7a3057bc..05e5d9248605 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.626 2011/11/16 02:29:48 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.627 2011/11/16 21:49:59 chithanh Exp $
+
+*xorg-server-1.11.2-r1 (16 Nov 2011)
+
+ 16 Nov 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ -xorg-server-1.11.1-r1.ebuild, -xorg-server-1.11.2.ebuild,
+ +xorg-server-1.11.2-r1.ebuild, +files/xdm.initd-4:
+ Add dependency on libXrender when building dmx, bug #390697. Prevent dbus
+ from starting too late, bug #390609.
16 Nov 2011; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xorg-server-1.11.2.ebuild:
diff --git a/x11-base/xorg-server/files/xdm.initd-4 b/x11-base/xorg-server/files/xdm.initd-4
new file mode 100644
index 000000000000..d20265e2a5ac
--- /dev/null
+++ b/x11-base/xorg-server/files/xdm.initd-4
@@ -0,0 +1,220 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/files/xdm.initd-4,v 1.1 2011/11/16 21:49:59 chithanh Exp $
+
+# This is here to serve as a note to myself, and future developers.
+#
+# Any Display manager (gdm,kdm,xdm) has the following problem: if
+# it is started before any getty, and no vt is specified, it will
+# usually run on vt2. When the getty on vt2 then starts, and the
+# DM is already started, the getty will take control of the keyboard,
+# leaving us with a "dead" keyboard.
+#
+# Resolution: add the following line to /etc/inittab
+#
+# x:a:once:/etc/X11/startDM.sh
+#
+# and have /etc/X11/startDM.sh start the DM in daemon mode if
+# a lock is present (with the info of what DM should be started),
+# else just fall through.
+#
+# How this basically works, is the "a" runlevel is a additional
+# runlevel that you can use to fork processes with init, but the
+# runlevel never gets changed to this runlevel. Along with the "a"
+# runlevel, the "once" key word means that startDM.sh will only be
+# run when we specify it to run, thus eliminating respawning
+# startDM.sh when "xdm" is not added to the default runlevel, as was
+# done previously.
+#
+# This script then just calls "telinit a", and init will run
+# /etc/X11/startDM.sh after the current runlevel completes (this
+# script should only be added to the actual runlevel the user is
+# using).
+#
+# Martin Schlemmer
+# aka Azarah
+# 04 March 2002
+
+depend() {
+ need localmount xdm-setup
+
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ # (#139824) Start after ypbind and autofs for network authentication
+ # (#145219 #180163) Could use lirc mouse as input device
+ # (#70689 comment #92) Start after consolefont to avoid display corruption
+ # (#291269) Start after quota, since some dm need readable home
+ # (#390609) gdm-3 will fail when dbus is not running
+ after bootmisc consolefont modules netmount
+ after readahead-list ypbind autofs openvpn gpm lircmd
+ after quota
+ after dbus
+ before alsasound
+
+ # Start before X
+ use consolekit xfs
+}
+
+setup_dm() {
+ local MY_XDM
+
+ MY_XDM=$(echo "${DISPLAYMANAGER}" | tr '[:upper:]' '[:lower:]')
+
+ # Load our root path from profile.env
+ # Needed for kdm
+ PATH=${PATH}:$(. /etc/profile.env; echo "${ROOTPATH}")
+
+ NAME=
+ case "${MY_XDM}" in
+ kdm|kde)
+ EXE="$(which kdm)"
+ PIDFILE=/var/run/kdm.pid
+ ;;
+ kdm-*)
+ EXE="/usr/kde/${MY_XDM#kdm-}/bin/kdm"
+ PIDFILE=/var/run/kdm.pid
+ ;;
+ entrance*)
+ EXE=/usr/sbin/entranced
+ PIDFILE=/var/lib/entranced.pid
+ ;;
+ gdm|gnome)
+ EXE=/usr/bin/gdm
+ [ "${RC_UNAME}" != "Linux" ] && NAME=gdm-binary
+ PIDFILE=/var/run/gdm.pid
+ ;;
+ wdm)
+ EXE=/usr/bin/wdm
+ PIDFILE=
+ ;;
+ gpe)
+ EXE=/usr/bin/gpe-dm
+ PIDFILE=/var/run/gpe-dm.pid
+ ;;
+ lxdm)
+ EXE=/usr/sbin/lxdm-binary
+ PIDFILE=/var/run/lxdm.pid
+ START_STOP_ARGS="--background"
+ ;;
+ lightdm)
+ EXE=/usr/sbin/lightdm
+ PIDFILE=/var/run/lightdm.pid
+ START_STOP_ARGS="--background"
+ ;;
+ *)
+ # first find out if there is such executable
+ EXE="$(which ${MY_XDM} 2>/dev/null)"
+ PIDFILE="/var/run/${MY_XDM}.pid"
+
+ # warn user that he is doing sick things if the exe was not found
+ if [ -z "${EXE}" ]; then
+ echo "ERROR: Your XDM value is invalid."
+ echo " No ${MY_XDM} executable could be found on your system."
+ fi
+ ;;
+ esac
+
+ if ! [ -x "${EXE}" ]; then
+ EXE=/usr/bin/xdm
+ PIDFILE=/var/run/xdm.pid
+ if ! [ -x "/usr/bin/xdm" ]; then
+ echo "ERROR: Please set your DISPLAYMANAGER variable in /etc/conf.d/xdm,"
+ echo " or install x11-apps/xdm package"
+ eend 255
+ fi
+ fi
+}
+
+# Check to see if something is defined on our VT
+vtstatic() {
+ if [ -e /etc/inittab ] ; then
+ grep -Eq "^[^#]+.*\<tty$1\>" /etc/inittab
+ elif [ -e /etc/ttys ] ; then
+ grep -q "^ttyv$(($1 - 1))" /etc/ttys
+ else
+ return 1
+ fi
+}
+
+start() {
+ local EXE NAME PIDFILE
+ setup_dm
+
+ if [ -f /etc/.noxdm ]; then
+ einfo "Skipping ${EXE##*/}, /etc/.noxdm found or \"nox\" bootparam passed."
+ rm /etc/.noxdm
+ return 0
+ fi
+
+ ebegin "Setting up ${EXE##*/}"
+
+ # save the prefered DM
+ save_options "service" "${EXE}"
+ save_options "name" "${NAME}"
+ save_options "pidfile" "${PIDFILE}"
+ save_options "start_stop_args" "${START_STOP_ARGS}"
+
+ if [ -n "${CHECKVT-y}" ] ; then
+ if vtstatic "${CHECKVT:-7}" ; then
+ if [ -x /sbin/telinit ] && [ "${SOFTLEVEL}" != "BOOT" ] && [ "${RC_SOFTLEVEL}" != "BOOT" ]; then
+ ewarn "Something is already defined on VT ${CHECKVT:-7}, will start X later"
+ telinit a >/dev/null 2>&1
+ return 0
+ else
+ eerror "Something is already defined on VT ${CHECKVT:-7}, not starting"
+ return 1
+ fi
+ fi
+ fi
+
+ /etc/X11/startDM.sh
+ eend 0
+}
+
+stop() {
+ local curvt retval
+
+ retval=0
+ if [ -t 0 ]; then
+ if type fgconsole >/dev/null 2>&1; then
+ curvt=$(fgconsole 2>/dev/null)
+ else
+ curvt=$(tty)
+ case "${curvt}" in
+ /dev/ttyv[0-9]*) curvt=${curvt#/dev/ttyv} ;;
+ *) curvt= ;;
+ esac
+ fi
+ fi
+ local myexe myname mypidfile myservice
+ myexe=$(get_options "service")
+ myname=$(get_options "name")
+ mypidfile=$(get_options "pidfile")
+ myservice=${myexe##*/}
+
+ [ -z "${myexe}" ] && return 0
+
+ ebegin "Stopping ${myservice}"
+
+ if start-stop-daemon --quiet --test --stop --exec "${myexe}"; then
+ start-stop-daemon --stop --exec "${myexe}" --retry TERM/5/TERM/5 \
+ ${mypidfile:+--pidfile} ${mypidfile} \
+ ${myname:+--name} ${myname}
+ retval=${?}
+ fi
+
+ # switch back to original vt
+ if [ -n "${curvt}" ]; then
+ if type chvt >/dev/null 2>&1; then
+ chvt "${curvt}"
+ else
+ vidcontrol -s "$((curvt + 1))"
+ fi
+ fi
+
+ eend ${retval} "Error stopping ${myservice}"
+ return ${retval}
+}
+
+# vim: set ts=4 :
diff --git a/x11-base/xorg-server/xorg-server-1.11.1-r1.ebuild b/x11-base/xorg-server/xorg-server-1.11.1-r1.ebuild
deleted file mode 100644
index 762dd725934d..000000000000
--- a/x11-base/xorg-server/xorg-server-1.11.1-r1.ebuild
+++ /dev/null
@@ -1,241 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.11.1-r1.ebuild,v 1.2 2011/11/06 09:54:40 scarabeus Exp $
-
-EAPI=4
-
-XORG_DOC=doc
-inherit xorg-2 multilib versionator
-EGIT_REPO_URI="git://anongit.freedesktop.org/git/xorg/xserver"
-
-DESCRIPTION="X.Org X servers"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-
-IUSE_SERVERS="dmx kdrive xnest xorg xvfb"
-IUSE="${IUSE_SERVERS} ipv6 minimal nptl tslib +udev"
-
-RDEPEND=">=app-admin/eselect-opengl-1.0.8
- dev-libs/openssl
- media-libs/freetype
- >=x11-apps/iceauth-1.0.2
- >=x11-apps/rgb-1.0.3
- >=x11-apps/xauth-1.0.3
- x11-apps/xkbcomp
- >=x11-libs/libpciaccess-0.10.3
- >=x11-libs/libXau-1.0.4
- >=x11-libs/libXdmcp-1.0.2
- >=x11-libs/libXfont-1.4.2
- >=x11-libs/libxkbfile-1.0.4
- >=x11-libs/pixman-0.21.8
- >=x11-libs/xtrans-1.2.2
- >=x11-misc/xbitmaps-1.0.1
- >=x11-misc/xkeyboard-config-1.4
- dmx? (
- x11-libs/libXt
- >=x11-libs/libdmx-1.0.99.1
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXaw-1.0.4
- >=x11-libs/libXext-1.0.99.4
- >=x11-libs/libXfixes-5.0
- >=x11-libs/libXi-1.2.99.1
- >=x11-libs/libXmu-1.0.3
- >=x11-libs/libXres-1.0.3
- >=x11-libs/libXtst-1.0.99.2
- )
- kdrive? (
- >=x11-libs/libXext-1.0.5
- x11-libs/libXv
- )
- !minimal? (
- >=x11-libs/libX11-1.1.5
- >=x11-libs/libXext-1.0.5
- >=media-libs/mesa-7.8_rc[nptl=]
- )
- tslib? ( >=x11-libs/tslib-1.0 )
- udev? ( >=sys-fs/udev-150 )
- >=x11-apps/xinit-1.3"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- >=x11-proto/bigreqsproto-1.1.0
- >=x11-proto/compositeproto-0.4
- >=x11-proto/damageproto-1.1
- >=x11-proto/fixesproto-5.0
- >=x11-proto/fontsproto-2.0.2
- >=x11-proto/glproto-1.4.14
- >=x11-proto/inputproto-1.9.99.902
- >=x11-proto/kbproto-1.0.3
- >=x11-proto/randrproto-1.2.99.3
- >=x11-proto/recordproto-1.13.99.1
- >=x11-proto/renderproto-0.11
- >=x11-proto/resourceproto-1.0.2
- >=x11-proto/scrnsaverproto-1.1
- >=x11-proto/trapproto-3.4.3
- >=x11-proto/videoproto-2.2.2
- >=x11-proto/xcmiscproto-1.2.0
- >=x11-proto/xextproto-7.1.99
- >=x11-proto/xf86dgaproto-2.0.99.1
- >=x11-proto/xf86rushproto-1.1.2
- >=x11-proto/xf86vidmodeproto-2.2.99.1
- >=x11-proto/xineramaproto-1.1.3
- >=x11-proto/xproto-7.0.22
- dmx? (
- >=x11-proto/dmxproto-2.2.99.1
- doc? (
- || (
- www-client/links
- www-client/lynx
- www-client/w3m
- )
- )
- )
- !minimal? (
- >=x11-proto/xf86driproto-2.1.0
- >=x11-proto/dri2proto-2.6
- >=x11-libs/libdrm-2.4.20
- )"
-
-PDEPEND="
- xorg? ( >=x11-base/xorg-drivers-$(get_version_component_range 1-2) )"
-
-REQUIRED_USE="!minimal? (
- || ( ${IUSE_SERVERS} )
- )"
-
-#UPSTREAMED_PATCHES=(
-# "${WORKDIR}/patches/"
-#)
-
-PATCHES=(
- "${UPSTREAMED_PATCHES[@]}"
- "${FILESDIR}"/${PN}-disable-acpi.patch
- "${FILESDIR}"/${PN}-1.9-nouveau-default.patch
- "${FILESDIR}"/xorg-cve-2011-4028+4029.patch
-)
-
-pkg_pretend() {
- # older gcc is not supported
- [[ $(gcc-major-version) -lt 4 ]] && \
- die "Sorry, but gcc earlier than 4.0 wont work for xorg-server."
-}
-
-pkg_setup() {
- xorg-2_pkg_setup
-
- # localstatedir is used for the log location; we need to override the default
- # from ebuild.sh
- # sysconfdir is used for the xorg.conf location; same applies
- # --enable-install-setuid needed because sparcs default off
- # NOTE: fop is used for doc generating ; and i have no idea if gentoo
- # package it somewhere
- XORG_CONFIGURE_OPTIONS=(
- $(use_enable ipv6)
- $(use_enable dmx)
- $(use_enable kdrive)
- $(use_enable kdrive kdrive-kbd)
- $(use_enable kdrive kdrive-mouse)
- $(use_enable kdrive kdrive-evdev)
- $(use_enable tslib)
- $(use_enable !minimal record)
- $(use_enable !minimal xfree86-utils)
- $(use_enable !minimal install-libxf86config)
- $(use_enable !minimal dri)
- $(use_enable !minimal dri2)
- $(use_enable !minimal glx)
- $(use_enable xnest)
- $(use_enable xorg)
- $(use_enable xvfb)
- $(use_enable nptl glx-tls)
- $(use_enable udev config-udev)
- $(use_with doc doxygen)
- $(use_with doc xmlto)
- --sysconfdir=/etc/X11
- --localstatedir=/var
- --enable-install-setuid
- --with-fontrootdir=/usr/share/fonts
- --with-xkb-output=/var/lib/xkb
- --disable-config-hal
- --without-dtrace
- --without-fop
- --with-os-vendor=Gentoo
- )
-
- # Xorg-server requires includes from OS mesa which are not visible for
- # users of binary drivers.
- mkdir -p "${T}/mesa-symlinks/GL"
- for i in gl glx glxmd glxproto glxtokens; do
- ln -s "${EROOT}usr/$(get_libdir)/opengl/xorg-x11/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
- done
- for i in glext glxext; do
- ln -s "${EROOT}usr/$(get_libdir)/opengl/global/include/$i.h" "${T}/mesa-symlinks/GL/$i.h" || die
- done
- append-cppflags "-I${T}/mesa-symlinks"
-}
-
-src_install() {
- xorg-2_src_install
-
- dynamic_libgl_install
-
- server_based_install
-
- if ! use minimal && use xorg; then
- # Install xorg.conf.example into docs
- dodoc "${AUTOTOOLS_BUILD_DIR}"/hw/xfree86/xorg.conf.example
- fi
-
- newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-3 xdm
- newconfd "${FILESDIR}"/xdm.confd-4 xdm
-
- # install the @x11-module-rebuild set for Portage
- insinto /usr/share/portage/config/sets
- newins "${FILESDIR}"/xorg-sets.conf xorg.conf
-}
-
-pkg_postinst() {
- # sets up libGL and DRI2 symlinks if needed (ie, on a fresh install)
- eselect opengl set xorg-x11 --use-old
-
- if [[ ${PV} != 9999 && $(get_version_component_range 2 ${REPLACING_VERSIONS}) != $(get_version_component_range 2 ${PV}) ]]; then
- ewarn "You must rebuild all drivers if upgrading from <xorg-server-$(get_version_component_range 1-2)"
- ewarn "because the ABI changed. If you cannot start X because"
- ewarn "of module version mismatch errors, this is your problem."
-
- echo
- ewarn "You can generate a list of all installed packages in the x11-drivers"
- ewarn "category using this command:"
- ewarn " emerge portage-utils; qlist -I -C x11-drivers/"
- ewarn "or using sets from portage-2.2:"
- ewarn " emerge @x11-module-rebuild"
- fi
-}
-
-pkg_postrm() {
- # Get rid of module dir to ensure opengl-update works properly
- if [[ -z ${REPLACED_BY_VERSION} && -e ${ROOT}/usr/$(get_libdir)/xorg/modules ]]; then
- rm -rf "${ROOT}"/usr/$(get_libdir)/xorg/modules
- fi
-}
-
-dynamic_libgl_install() {
- # next section is to setup the dynamic libGL stuff
- ebegin "Moving GL files for dynamic switching"
- dodir /usr/$(get_libdir)/opengl/xorg-x11/extensions
- local x=""
- for x in "${D}"/usr/$(get_libdir)/xorg/modules/extensions/lib{glx,dri,dri2}*; do
- if [ -f ${x} -o -L ${x} ]; then
- mv -f ${x} "${D}"/usr/$(get_libdir)/opengl/xorg-x11/extensions
- fi
- done
- eend 0
-}
-
-server_based_install() {
- if ! use xorg; then
- rm "${D}"/usr/share/man/man1/Xserver.1x \
- "${D}"/usr/$(get_libdir)/xserver/SecurityPolicy \
- "${D}"/usr/$(get_libdir)/pkgconfig/xorg-server.pc \
- "${D}"/usr/share/man/man1/Xserver.1x
- fi
-}
diff --git a/x11-base/xorg-server/xorg-server-1.11.2.ebuild b/x11-base/xorg-server/xorg-server-1.11.2-r1.ebuild
index d4d98d9f9c75..1361c61dca97 100644
--- a/x11-base/xorg-server/xorg-server-1.11.2.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.11.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.11.2.ebuild,v 1.3 2011/11/16 02:29:48 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.11.2-r1.ebuild,v 1.1 2011/11/16 21:49:59 chithanh Exp $
EAPI=4
@@ -39,6 +39,7 @@ RDEPEND=">=app-admin/eselect-opengl-1.0.8
>=x11-libs/libXfixes-5.0
>=x11-libs/libXi-1.2.99.1
>=x11-libs/libXmu-1.0.3
+ x11-libs/libXrender
>=x11-libs/libXres-1.0.3
>=x11-libs/libXtst-1.0.99.2
)
@@ -184,7 +185,7 @@ src_install() {
fi
newinitd "${FILESDIR}"/xdm-setup.initd-1 xdm-setup
- newinitd "${FILESDIR}"/xdm.initd-3 xdm
+ newinitd "${FILESDIR}"/xdm.initd-4 xdm
newconfd "${FILESDIR}"/xdm.confd-4 xdm
# install the @x11-module-rebuild set for Portage