summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Baergen <joshuabaergen@gentoo.org>2006-10-13 22:54:58 +0000
committerJoshua Baergen <joshuabaergen@gentoo.org>2006-10-13 22:54:58 +0000
commitdf83a0f74364f5c365a6c841999168f36a4d7d98 (patch)
treef6c59b13fa0ed23e59e1d05a69c7460d8dac64c8 /x11-base
parentFixes bug #151229. Thanks t Wiktor Wandachowicz for reporting it. (diff)
downloadgentoo-2-df83a0f74364f5c365a6c841999168f36a4d7d98.tar.gz
gentoo-2-df83a0f74364f5c365a6c841999168f36a4d7d98.tar.bz2
gentoo-2-df83a0f74364f5c365a6c841999168f36a4d7d98.zip
Hide AIGLX patches behind the "aiglx" USE flag, since the patches seem to
cause some EXA slowdowns (bug #147841, reported by Giacomo Perale). (Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-server/ChangeLog7
-rw-r--r--x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild36
2 files changed, 28 insertions, 15 deletions
diff --git a/x11-base/xorg-server/ChangeLog b/x11-base/xorg-server/ChangeLog
index bde6a677e743..419cf447d040 100644
--- a/x11-base/xorg-server/ChangeLog
+++ b/x11-base/xorg-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/xorg-server
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.175 2006/10/12 15:31:34 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/ChangeLog,v 1.176 2006/10/13 22:54:58 joshuabaergen Exp $
+
+ 13 Oct 2006; Joshua Baergen <joshuabaergen@gentoo.org>
+ xorg-server-1.1.1-r1.ebuild:
+ Hide AIGLX patches behind the "aiglx" USE flag, since the patches seem to
+ cause some EXA slowdowns (bug #147841, reported by Giacomo Perale).
12 Oct 2006; Joshua Baergen <joshuabaergen@gentoo.org>
xorg-server-1.1.1-r1.ebuild:
diff --git a/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild b/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild
index 9922b416e561..9b6f7c6bd23f 100644
--- a/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild
+++ b/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild,v 1.10 2006/10/12 15:31:34 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-server/xorg-server-1.1.1-r1.ebuild,v 1.11 2006/10/13 22:54:58 joshuabaergen Exp $
# Must be before x-modular eclass is inherited
SNAPSHOT="yes"
@@ -14,19 +14,6 @@ MESA_PV="6.5.1"
MESA_P="${MESA_PN}-${MESA_PV}"
MESA_SRC_P="${MESA_PN}Lib-${MESA_PV}"
-PATCHES="${FILESDIR}/01-no-move-damage.patch
- ${FILESDIR}/02-dont-backfill-bg-none.patch
- ${FILESDIR}/03-tfp-damage.patch
- ${FILESDIR}/04-mesa-copy-sub-buffer.patch
- ${FILESDIR}/05-offscreen-pixmaps.patch
- ${FILESDIR}/06-aiglx-happy-vt-switch.patch
- ${FILESDIR}/xorg-x11-server-1.1.1-mesa-6.5.1.patch
- ${FILESDIR}/${P}-install-libxf86config-headers.patch
- ${FILESDIR}/${PV}-fix-xrandr-zoom-keys.patch
- ${FILESDIR}/${PV}-sparc64-ati-lockups.patch
- ${FILESDIR}/xorg-conf-example.patch"
-
-
SRC_URI="${SRC_URI}
mirror://sourceforge/mesa3d/${MESA_SRC_P}.tar.bz2
http://xorg.freedesktop.org/releases/individual/xserver/${P}.tar.bz2"
@@ -120,6 +107,7 @@ IUSE="${IUSE_VIDEO_CARDS}
${IUSE_INPUT_DEVICES}
${IUSE_SERVERS}
3dfx
+ aiglx
dri ipv6 minimal nptl sdl xprint"
RDEPEND="x11-libs/libXfont
x11-libs/xtrans
@@ -285,6 +273,26 @@ LICENSE="${LICENSE} MIT"
pkg_setup() {
use minimal || ensure_a_server_is_building
+ PATCHES="${FILESDIR}/xorg-x11-server-1.1.1-mesa-6.5.1.patch
+ ${FILESDIR}/${P}-install-libxf86config-headers.patch
+ ${FILESDIR}/${PV}-fix-xrandr-zoom-keys.patch
+ ${FILESDIR}/${PV}-sparc64-ati-lockups.patch
+ ${FILESDIR}/xorg-conf-example.patch"
+
+ # Patches required for compiz to work with AIGLX,
+ # but they slow EXA down (bug #147841).
+ if use aiglx; then
+ einfo "AIGLX patches will be applied."
+ ewarn "These patches are known to cause problems with EXA enabled."
+ PATCHES="${FILESDIR}/01-no-move-damage.patch
+ ${FILESDIR}/02-dont-backfill-bg-none.patch
+ ${FILESDIR}/03-tfp-damage.patch
+ ${FILESDIR}/04-mesa-copy-sub-buffer.patch
+ ${FILESDIR}/05-offscreen-pixmaps.patch
+ ${FILESDIR}/06-aiglx-happy-vt-switch.patch
+ ${PATCHES}"
+ fi
+
# SDL only available in kdrive build
if use kdrive && use sdl; then
conf_opts="${conf_opts} --enable-xsdl"