summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2003-09-16 05:56:14 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2003-09-16 05:56:14 +0000
commitc42938bd9476cca584dc6a0036df01b002e07295 (patch)
tree420e00cf0caa6816dc8e076f375f79ae7601b178 /x11-base
parentUpdated digest (diff)
downloadgentoo-2-c42938bd9476cca584dc6a0036df01b002e07295.tar.gz
gentoo-2-c42938bd9476cca584dc6a0036df01b002e07295.tar.bz2
gentoo-2-c42938bd9476cca584dc6a0036df01b002e07295.zip
Ebuild cleanup, disable type1 and truetype for now because they're useless in the current setup.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/kdrive/ChangeLog6
-rw-r--r--x11-base/kdrive/Manifest4
-rw-r--r--x11-base/kdrive/kdrive-4.3.0.ebuild42
3 files changed, 28 insertions, 24 deletions
diff --git a/x11-base/kdrive/ChangeLog b/x11-base/kdrive/ChangeLog
index f6de221eb2f1..dd9408d49799 100644
--- a/x11-base/kdrive/ChangeLog
+++ b/x11-base/kdrive/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-base/kdrive
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/kdrive/ChangeLog,v 1.3 2003/07/18 22:57:06 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/kdrive/ChangeLog,v 1.4 2003/09/16 05:56:11 spyderous Exp $
+
+ 16 Sep 2003; Donnie Berkholz <spyderous@gentoo.org>; kdrive-4.3.0.ebuild:
+ Ebuild cleanup, disable type1 and truetype for now because they're useless in
+ the current setup.
18 Jul 2003; Donnie Berkholz <spyderous@gentoo.org>; kdrive-4.3.0.ebuild:
Marked stable for x86.
diff --git a/x11-base/kdrive/Manifest b/x11-base/kdrive/Manifest
index 0ea99d7cb280..45ba2a7623ae 100644
--- a/x11-base/kdrive/Manifest
+++ b/x11-base/kdrive/Manifest
@@ -1,4 +1,4 @@
-MD5 c88abb21bc1e65da8dcabe3ed1535849 ChangeLog 501
-MD5 311dccc5209ba55661c847eaa98eae7f kdrive-4.3.0.ebuild 10315
+MD5 5b1f43f8818cfde2ba146de63946eea4 ChangeLog 679
+MD5 dfb36dc591c29412ab1e1c8716c8d837 kdrive-4.3.0.ebuild 10183
MD5 a1c3090581323032b75d0416d74ced9e metadata.xml 251
MD5 c1fefd05eb62aac375b37a764c0be440 files/digest-kdrive-4.3.0 253
diff --git a/x11-base/kdrive/kdrive-4.3.0.ebuild b/x11-base/kdrive/kdrive-4.3.0.ebuild
index b69492d28bfa..475dae6ea127 100644
--- a/x11-base/kdrive/kdrive-4.3.0.ebuild
+++ b/x11-base/kdrive/kdrive-4.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/kdrive/kdrive-4.3.0.ebuild,v 1.4 2003/09/06 22:07:08 msterret Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/kdrive/kdrive-4.3.0.ebuild,v 1.5 2003/09/16 05:56:11 spyderous Exp $
# If you don't want to build the Xvesa server, do this.
# VESA="no" emerge kdrive
@@ -9,7 +9,7 @@
# that only we only strip stuff that are safe to strip ...
RESTRICT="nostrip"
-IUSE="sse mmx 3dnow ipv6 xinerama type1 truetype fbdev"
+IUSE="sse mmx 3dnow ipv6 xinerama fbdev"
# VIDEO_CARDS="savage trident sis trio ts300 mach64 i810 igs"
@@ -157,19 +157,19 @@ src_unpack() {
if [ "${ARCH}" = "x86" ]
then
# optimize for architecture
- if use mmx &>/dev/null
+ if use mmx
then
echo "#define HasMMXSupport YES" >> config/cf/host.def
else
echo "#define HasMMXSupport NO" >> config/cf/host.def
fi
- if use 3dnow &>/dev/null
+ if use mmx && use 3dnow
then
echo "#define Has3DNowSupport YES" >> config/cf/host.def
else
echo "#define Has3DNowSupport NO" >> config/cf/host.def
fi
- if use sse &>/dev/null
+ if use mmx && use sse
then
echo "#define HasKatmaiSupport YES" >> config/cf/host.def
else
@@ -193,19 +193,19 @@ src_unpack() {
fi
fi
- if use fbdev &> /dev/null
+ if use fbdev
then
echo "#define XfbdevServer YES" >> config/cf/host.def
else
echo "#define XfbdevServer NO" >> config/cf/host.def
fi
- if use ipv6 &>/dev/null
+ if use ipv6
then
echo "#define HasIPv6 YES" >> config/cf/host.def
fi
- if use xinerama &>/dev/null
+ if use xinerama
then
echo "#define BuildXinerama YES" >> config/cf/host.def
# Don't know if this is necessary. Probably.
@@ -216,15 +216,15 @@ src_unpack() {
# fonts (but support for built-in ``fixed'' and ``cursor'' fonts, and
# normal support for bitmap fonts and font-server provided fonts).
- if use type1 &>/dev/null
- then
- echo "#define BuildType1 YES" >> config/cf/host.def
- fi
-
- if use truetype &>/dev/null
- then
- echo "#define BuildFreeType YES" >> config/cf/host.def
- fi
+# if use type1
+# then
+# echo "#define BuildType1 YES" >> config/cf/host.def
+# fi
+#
+# if use truetype
+# then
+# echo "#define BuildFreeType YES" >> config/cf/host.def
+# fi
if vcards savage &>/dev/null
then
@@ -303,7 +303,7 @@ src_install() {
fperms 4755 /usr/X11R6/bin/Xvesa
fi
- if use fbdev &> /dev/null
+ if use fbdev
then
doexe programs/Xserver/Xfbdev
fperms 4755 /usr/X11R6/bin/Xfbdev
@@ -365,7 +365,7 @@ src_install() {
local M=${WORKDIR}/man
- if use fbdev &> /dev/null
+ if use fbdev
then
doman -x11 ${M}/usr/X11R6/man/man1/Xfbdev.1x
fi
@@ -383,12 +383,12 @@ pkg_postinst() {
# einfo "make a copy of /usr/X11R6/bin/startxvesa and set defaultserver"
# einfo "to your Kdrive server."
#
-# if use vesa &> /dev/null
+# if use vesa
# then
# einfo "Use startxvesa to start the Xvesa Kdrive server."
# fi
#
-# if use fbdev &> /dev/null
+# if use fbdev
# then
# einfo "Use startxfbdev to start the Xfbdev Kdrive server."
# fi