summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-11-03 09:13:26 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-11-03 09:13:26 +0000
commit6f619df0e110a5a6c33ae4b56444e523aa376605 (patch)
treed7feb766ec6689d2177fafbe38a4c1493b305987 /x11-base
parentStable amd64 for security fix. Removing insecure versions. (diff)
downloadgentoo-2-6f619df0e110a5a6c33ae4b56444e523aa376605.tar.gz
gentoo-2-6f619df0e110a5a6c33ae4b56444e523aa376605.tar.bz2
gentoo-2-6f619df0e110a5a6c33ae4b56444e523aa376605.zip
Combine the dri USE flag into the opengl USE flag, since there's no way to control just the build of the 3D drivers at present.
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xorg-x11/ChangeLog7
-rw-r--r--x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild27
2 files changed, 17 insertions, 17 deletions
diff --git a/x11-base/xorg-x11/ChangeLog b/x11-base/xorg-x11/ChangeLog
index aae62dd0e3e9..1d3a2cab93c1 100644
--- a/x11-base/xorg-x11/ChangeLog
+++ b/x11-base/xorg-x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/xorg-x11
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.187 2004/11/03 08:33:38 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/ChangeLog,v 1.188 2004/11/03 09:13:26 spyderous Exp $
+
+ 03 Nov 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ xorg-x11-6.8.0-r2.ebuild:
+ Combine the dri USE flag into the opengl USE flag, since there's no way to
+ control just the build of the 3D drivers at present.
03 Nov 2004; Donnie Berkholz <spyderous@gentoo.org>;
xorg-x11-6.8.0-r2.ebuild:
diff --git a/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild b/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
index c320c602a24b..d43255e1ee43 100644
--- a/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
+++ b/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild,v 1.42 2004/11/03 08:33:38 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xorg-x11/xorg-x11-6.8.0-r2.ebuild,v 1.43 2004/11/03 09:13:26 spyderous Exp $
# Set TDFX_RISKY to "yes" to get 16-bit, 1024x768 or higher on low-memory
# voodoo3 cards.
@@ -34,9 +34,9 @@ inherit eutils flag-o-matic toolchain-funcs x11
RESTRICT="nostrip"
# IUSE="gatos" disabled because gatos is broken on ~4.4 now (31 Jan 2004)
-IUSE="3dfx 3dnow bitmap-fonts cjk debug dlloader dmx doc dri font-server
- hardened insecure-drivers ipv6 mmx nls opengl pam sdk sse static
- truetype-fonts type1-fonts uclibc xprint xv"
+IUSE="3dfx 3dnow bitmap-fonts cjk debug dlloader dmx doc font-server hardened
+ insecure-drivers ipv6 mmx nls opengl pam sdk sse static truetype-fonts
+ type1-fonts uclibc xprint xv"
# IUSE_INPUT_DEVICES="synaptics wacom"
FILES_VER="0.6"
@@ -227,10 +227,6 @@ pkg_setup() {
die "The dmx and doc USE flags are temporarily incompatible and result in a dead build."
fi
- if use dri && ! use opengl; then
- die "The dri USE flag requires the opengl flag."
- fi
-
if use xv && ! use opengl; then
eerror "See http://bugs.gentoo.org/show_bug.cgi?id=67996"
eerror "The xv USE flag currently requires the opengl flag."
@@ -416,21 +412,20 @@ host_def_setup() {
# echo "#define XF86ExtraCardDrivers via" >> ${HOSTCONF}
fi
+ # Do we want the glx extension? This will turn off XF86DRI if it's off.
+ # DRI can't build if glx isn't built, so keep this below DRI define.
+ # Do this before hppa so they can turn DRI off
+ use_build opengl BuildGlxExt
+ use_build opengl BuildGLXLibrary
+ use_build opengl BuildXF86DRI
+
if use hppa; then
echo "#define DoLoadableServer NO" >> ${HOSTCONF}
echo "#define BuildXF86DRI NO" >> config/cf/host.def
echo "#undef DriDrivers" >> config/cf/host.def
echo "#define XF86CardDrivers fbdev" >> config/cf/host.def
- else
- # Do we want direct rendering support in drivers?
- use_build dri BuildXF86DRI
fi
- # Do we want the glx extension? This will turn off XF86DRI if it's off.
- # DRI can't build if glx isn't built, so keep this below DRI define.
- use_build opengl BuildGlxExt
- use_build opengl BuildGLXLibrary
-
# Make xv optional for more minimal builds
use_build xv BuildXvLibrary
use_build xv BuildXvExt