summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2001-11-11 11:02:54 +0000
committerMartin Schlemmer <azarah@gentoo.org>2001-11-11 11:02:54 +0000
commit4336775b963d692af4774006e33122161f21eacf (patch)
tree2c161cdd112ad76518d06e9d8f45d8688b9615f5 /x11-base
parentcleanup (diff)
downloadgentoo-2-4336775b963d692af4774006e33122161f21eacf.tar.gz
gentoo-2-4336775b963d692af4774006e33122161f21eacf.tar.bz2
gentoo-2-4336775b963d692af4774006e33122161f21eacf.zip
fix dumb mistake i made when fixing the xdm rc-script problem, sorry guys
Diffstat (limited to 'x11-base')
-rw-r--r--x11-base/xfree/files/digest-xfree-4.1.0-r44
-rw-r--r--x11-base/xfree/xfree-4.1.0-r4.ebuild88
2 files changed, 92 insertions, 0 deletions
diff --git a/x11-base/xfree/files/digest-xfree-4.1.0-r4 b/x11-base/xfree/files/digest-xfree-4.1.0-r4
new file mode 100644
index 000000000000..142d8b1c9d6b
--- /dev/null
+++ b/x11-base/xfree/files/digest-xfree-4.1.0-r4
@@ -0,0 +1,4 @@
+MD5 2d4709f7106a1d65c175be445a3d3c32 X410src-1.tgz 25022464
+MD5 beaffed1cbdb700e5fed6a5490a7f222 X410src-2.tgz 22528000
+MD5 f94e42cd5c5e31a702ec64bfdc017a7d X410src-3.tgz 9322496
+MD5 a70e4d28c241374868a099127c668949 truetype.tar.gz 1531904
diff --git a/x11-base/xfree/xfree-4.1.0-r4.ebuild b/x11-base/xfree/xfree-4.1.0-r4.ebuild
new file mode 100644
index 000000000000..76ce2a457216
--- /dev/null
+++ b/x11-base/xfree/xfree-4.1.0-r4.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Desktop Team <desktop@gentoo.org>
+# Author: Achim Gottinger <achim@gentoo.org>, Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-base/xfree/xfree-4.1.0-r4.ebuild,v 1.1 2001/11/11 11:02:54 azarah Exp $
+
+MY_V="`echo ${PV} |sed -e 's:\.::g'`"
+S=${WORKDIR}/xc
+DESCRIPTION="Xfree86: famouse and free X server"
+SRC_PATH0="ftp://ftp.xfree.org/pub/XFree86/4.1.0/source"
+SRC_PATH1="ftp://ftp1.sourceforge.net/pub/mirrors/XFree86/4.1.0/source"
+
+SRC_URI="$SRC_PATH0/X${MY_V}src-1.tgz
+ $SRC_PATH0/X${MY_V}src-2.tgz
+ $SRC_PATH0/X${MY_V}src-3.tgz
+ $SRC_PATH1/X${MY_V}src-1.tgz
+ $SRC_PATH1/X${MY_V}src-2.tgz
+ $SRC_PATH1/X${MY_V}src-3.tgz
+ http://www.ibiblio.org/gentoo/gentoo-sources/truetype.tar.gz"
+
+HOMEPAGE="http://www.xfree.org"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ >=sys-libs/zlib-1.1.3-r2
+ sys-devel/flex
+ sys-devel/perl"
+
+RDEPEND=">=sys-libs/ncurses-5.1"
+
+PROVIDE="virtual/x11 virtual/opengl"
+# virtual/glu"
+# This has been removed. Anyone know why exactly ??
+
+
+src_unpack () {
+
+ unpack X${MY_V}src-{1,2,3}.tgz
+
+ cd ${S}
+ cp ${FILESDIR}/${PVR}/site.def config/cf/host.def
+ echo "#define DefaultGcc2i386Opt ${CFLAGS}" >> config/cf/host.def
+ echo "#define GccWarningOptions -Wno" >> config/cf/host.def
+ echo "#define DefaultCCOptions -ansi" >> config/cf/host.def
+}
+
+src_compile() {
+
+ make World || die
+}
+
+src_install() {
+
+ make install DESTDIR=${D} || die
+ make install.man DESTDIR=${D} || die
+
+ #we zap the host.def file which gets hard-coded with our CFLAGS, messing up other things that use xmkmf
+ echo > ${D}/usr/X11R6/lib/X11/config/host.def
+ #theoretically, /usr/X11R6/lib/X11/config is a possible candidate for config file management.
+ #If we find that people really worry about imake stuff, we may add it. But for now, we leave
+ #the dir unprotected.
+
+ insinto /usr/X11R6/lib/X11
+ doins ${FILESDIR}/${PVR}/XftConfig
+ cd ${D}/usr/X11R6/lib/X11/fonts
+ tar -xz --no-same-owner -f ${DISTDIR}/truetype.tar.gz
+ dosym /usr/X11R6/lib/libGL.so.1.2 /usr/X11R6/lib/libMesaGL.so
+ dosym /usr/X11R6/bin /usr/bin/X11
+
+ #X installs some /usr/lib/libGL symlinks, pointing to the libGL's in /usr/X11R6/lib.
+ #I don't see the point in this. Yes, according to LSB, the correct location for libGL is
+ #in /usr/lib, but this is so closely integrated with X itself that /usr/X11R6/lib seems
+ #like the right place.
+ rm -rf ${D}/usr/lib
+
+ #dosym /usr/X11R6/lib/libGLU.so.1.3 /usr/lib/libMesaGLU.so
+ #We're no longer including libGLU from here. Packaged separately, from separate sources.
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/${PVR}/10xfree
+ insinto /etc/X11/xinit
+ doins ${FILESDIR}/${PVR}/xinitrc
+ insinto /etc/X11/xdm
+ doins ${FILESDIR}/${PVR}/Xsession
+ insinto /etc/pam.d
+ doins ${FILESDIR}/${PVR}/xdm
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/${PVR}/xdm.start xdm
+}