summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBryan Stine <battousai@gentoo.org>2007-03-14 18:18:53 +0000
committerBryan Stine <battousai@gentoo.org>2007-03-14 18:18:53 +0000
commit29eb99358e110949e9d15706f794e6417d5670af (patch)
tree778d71389446f5707b189245fbb9fba4cdf1c4ba /x11-base/x11-drm
parentRemoved opengl-update for bug #170889. (diff)
downloadgentoo-2-29eb99358e110949e9d15706f794e6417d5670af.tar.gz
gentoo-2-29eb99358e110949e9d15706f794e6417d5670af.tar.bz2
gentoo-2-29eb99358e110949e9d15706f794e6417d5670af.zip
Various ebuild fixes. Resolves bug #150957 and bug #170842.
(Portage version: 2.1.2.2)
Diffstat (limited to 'x11-base/x11-drm')
-rw-r--r--x11-base/x11-drm/ChangeLog8
-rw-r--r--x11-base/x11-drm/x11-drm-20060608-r1.ebuild45
-rw-r--r--x11-base/x11-drm/x11-drm-20060608.ebuild49
-rw-r--r--x11-base/x11-drm/x11-drm-20070314.ebuild36
4 files changed, 59 insertions, 79 deletions
diff --git a/x11-base/x11-drm/ChangeLog b/x11-base/x11-drm/ChangeLog
index 7181aec98c74..a4b6b6b0350e 100644
--- a/x11-base/x11-drm/ChangeLog
+++ b/x11-base/x11-drm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-base/x11-drm
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.51 2007/03/14 17:08:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/ChangeLog,v 1.52 2007/03/14 18:18:53 battousai Exp $
+
+ 14 Mar 2007; Bryan Stine <battousai@gentoo.org> x11-drm-20060608.ebuild,
+ x11-drm-20060608-r1.ebuild, x11-drm-20070314.ebuild:
+ Ebuild fixes across the board since 20060608 for proper linux-mod and
+ autotools usage, as well as KBUILD_OUTPUT support. Thanks jakub(bug #150957)
+ and Zhang Le(bug #170842).
*x11-drm-20070314 (14 Mar 2007)
diff --git a/x11-base/x11-drm/x11-drm-20060608-r1.ebuild b/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
index d2912bd9612b..f224e9b57131 100644
--- a/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
+++ b/x11-base/x11-drm/x11-drm-20060608-r1.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608-r1.ebuild,v 1.5 2007/01/04 07:31:03 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608-r1.ebuild,v 1.6 2007/03/14 18:18:53 battousai Exp $
-inherit eutils x11 linux-mod
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7"
+
+inherit eutils x11 linux-mod autotools
IUSE_VIDEO_CARDS="
video_cards_i810
@@ -20,7 +23,7 @@ IUSE="${IUSE_VIDEO_CARDS} kernel_FreeBSD kernel_linux"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
-RESTRICT="nostrip"
+RESTRICT="strip"
S="${WORKDIR}/drm"
PATCHVER="0.3"
@@ -36,14 +39,10 @@ SLOT="0"
LICENSE="X11"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
-DEPEND=">=sys-devel/automake-1.7
- >=sys-devel/autoconf-2.59
- >=sys-devel/libtool-1.5.14
- >=sys-devel/m4-1.4
- kernel_linux? ( virtual/linux-sources )
+DEPEND="kernel_linux? ( virtual/linux-sources )
kernel_FreeBSD? ( sys-freebsd/freebsd-sources
- sys-freebsd/freebsd-mk-defs )
- >=sys-apps/portage-2.0.49-r13"
+ sys-freebsd/freebsd-mk-defs )"
+RDEPEND=""
pkg_setup() {
# Setup the kernel's stuff.
@@ -79,7 +78,7 @@ src_unpack() {
src_unpack_os
cd ${S}
- WANT_AUTOCONF="2.5" WANT_AUTOMAKE="1.7" autoreconf -v --install
+ eautoreconf -v --install
}
src_compile() {
@@ -133,28 +132,19 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- get_version
+ linux-mod_pkg_setup
if kernel_is 2 6
then
- if linux_chkconfig_builtin "DRM"
- then
+ linux_chkconfig_builtin "DRM" && \
die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
- fi
-
- if ! linux_chkconfig_present "AGP"
- then
- einfo "AGP support is not enabled in your kernel config. This may be needed for DRM to"
- einfo "work, so you might want to double-check that setting. (CONFIG_AGP)"
- echo
- fi
+
+ CONFIG_CHECK="AGP"
+ ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
elif kernel_is 2 4
then
- if ! linux_chkconfig_present "DRM"
- then
- die "Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
- echo
- fi
+ CONFIG_CHECK="DRM"
+ ERROR_DRM="Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
fi
fi
}
@@ -323,6 +313,7 @@ src_install_linux() {
DESTDIR="${D}" \
RUNNING_REL="${KV_FULL}" \
MODULE_LIST="${VIDCARDS} ${DRM_KMOD}" \
+ O="${KBUILD_OUTPUT}" \
install || die "Install failed."
# Strip binaries, leaving /lib/modules untouched (bug #24415)
diff --git a/x11-base/x11-drm/x11-drm-20060608.ebuild b/x11-base/x11-drm/x11-drm-20060608.ebuild
index 86148c06f884..4b4c99fe7dd6 100644
--- a/x11-base/x11-drm/x11-drm-20060608.ebuild
+++ b/x11-base/x11-drm/x11-drm-20060608.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608.ebuild,v 1.11 2007/01/04 07:31:04 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20060608.ebuild,v 1.12 2007/03/14 18:18:53 battousai Exp $
-inherit eutils x11 linux-mod
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7"
+
+inherit eutils x11 linux-mod autotools
IUSE_VIDEO_CARDS="
video_cards_i810
@@ -20,7 +23,7 @@ IUSE="${IUSE_VIDEO_CARDS}"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
-RESTRICT="nostrip"
+RESTRICT="strip"
S="${WORKDIR}/drm"
PATCHVER="0.3"
@@ -36,36 +39,21 @@ SLOT="0"
LICENSE="X11"
KEYWORDS="alpha amd64 ia64 ppc x86"
-DEPEND=">=sys-devel/automake-1.7
- >=sys-devel/autoconf-2.59
- >=sys-devel/libtool-1.5.14
- >=sys-devel/m4-1.4
- virtual/linux-sources
- >=sys-apps/portage-2.0.49-r13"
+DEPEND="virtual/linux-sources"
+RDEPEND=""
pkg_setup() {
- get_version
+ linux-mod_pkg_setup
- if kernel_is 2 6
- then
- if linux_chkconfig_builtin "DRM"
- then
+ if kernel_is 2 6 ; then
+ linux_chkconfig_builtin "DRM" && \
die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
- fi
-
- if ! linux_chkconfig_present "AGP"
- then
- einfo "AGP support is not enabled in your kernel config. This may be needed for DRM to"
- einfo "work, so you might want to double-check that setting. (CONFIG_AGP)"
- echo
- fi
- elif kernel_is 2 4
- then
- if ! linux_chkconfig_present "DRM"
- then
- die "Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
- echo
- fi
+ CONFIG_CHECK="AGP"
+ ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
+
+ elif kernel_is 2 4 ; then
+ CONFIG_CHECK="DRM"
+ ERROR_DRM="Please enable DRM support in your kernel configuration. (CONFIG_DRM = y or m)."
fi
# Set video cards to build for.
@@ -96,7 +84,7 @@ src_unpack() {
cp ${S}/tests/*.c ${SRC_BUILD}
cd ${S}
- WANT_AUTOCONF="2.5" WANT_AUTOMAKE="1.7" autoreconf -v --install
+ eautoreconf -v --install
}
src_compile() {
@@ -139,6 +127,7 @@ src_install() {
DESTDIR="${D}" \
RUNNING_REL="${KV_FULL}" \
MODULE_LIST="${VIDCARDS} ${DRM_KMOD}" \
+ O="${KBUILD_OUTPUT}" \
install || die "Install failed."
dodoc README.drm
diff --git a/x11-base/x11-drm/x11-drm-20070314.ebuild b/x11-base/x11-drm/x11-drm-20070314.ebuild
index 9857d53f7191..54785838ce5a 100644
--- a/x11-base/x11-drm/x11-drm-20070314.ebuild
+++ b/x11-base/x11-drm/x11-drm-20070314.ebuild
@@ -1,8 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.1 2007/03/14 17:08:12 battousai Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/x11-drm/x11-drm-20070314.ebuild,v 1.2 2007/03/14 18:18:53 battousai Exp $
-inherit eutils x11 linux-mod
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="1.7"
+
+inherit eutils x11 linux-mod autotools
IUSE_VIDEO_CARDS="
video_cards_i810
@@ -20,7 +23,7 @@ IUSE="${IUSE_VIDEO_CARDS} kernel_FreeBSD kernel_linux"
# Make sure Portage does _NOT_ strip symbols. We will do it later and make sure
# that only we only strip stuff that are safe to strip ...
-RESTRICT="nostrip"
+RESTRICT="strip"
S="${WORKDIR}/drm"
PATCHVER="0.1"
@@ -36,14 +39,10 @@ SLOT="0"
LICENSE="X11"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
-DEPEND=">=sys-devel/automake-1.7
- >=sys-devel/autoconf-2.59
- >=sys-devel/libtool-1.5.14
- >=sys-devel/m4-1.4
- kernel_linux? ( virtual/linux-sources )
+DEPEND="kernel_linux? ( virtual/linux-sources )
kernel_FreeBSD? ( sys-freebsd/freebsd-sources
- sys-freebsd/freebsd-mk-defs )
- >=sys-apps/portage-2.0.49-r13"
+ sys-freebsd/freebsd-mk-defs )"
+RDEPEND=""
pkg_setup() {
# Setup the kernel's stuff.
@@ -78,7 +77,7 @@ src_unpack() {
src_unpack_os
cd ${S}
- WANT_AUTOCONF="2.5" WANT_AUTOMAKE="1.7" autoreconf -v --install
+ eautoreconf -v --install
}
src_compile() {
@@ -132,7 +131,7 @@ kernel_setup() {
K_RV=${CHOST/*-freebsd/}
elif use kernel_linux
then
- get_version
+ linux-mod_pkg_setup
if kernel_is 2 4
then
@@ -141,17 +140,11 @@ kernel_setup() {
die "Please use in-kernel DRM or switch to a 2.6 kernel."
fi
- if linux_chkconfig_builtin "DRM"
- then
+ linux_chkconfig_builtin "DRM" && \
die "Please disable or modularize DRM in the kernel config. (CONFIG_DRM = n or m)"
- fi
- if ! linux_chkconfig_present "AGP"
- then
- einfo "AGP support is not enabled in your kernel config. This may be needed for DRM to"
- einfo "work, so you might want to double-check that setting. (CONFIG_AGP)"
- echo
- fi
+ CONFIG_CHECK="AGP"
+ ERROR_AGP="AGP support is not enabled in your kernel config (CONFIG_AGP)"
fi
}
@@ -314,6 +307,7 @@ src_install_linux() {
DESTDIR="${D}" \
RUNNING_REL="${KV_FULL}" \
MODULE_LIST="${VIDCARDS} ${DRM_KMOD}" \
+ O="${KBUILD_OUTPUT}" \
install || die "Install failed."
# Strip binaries, leaving /lib/modules untouched (bug #24415)