summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-06-11 02:23:52 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-06-11 02:23:52 +0000
commit938f10b7766850389f922c725d2fa4e867a1488c (patch)
treebb4905e1bc13b23022d3551a48716617bea46a77 /x11-base/opengl-update
parentppc sparc arm amd64. (Manifest recommit) (diff)
downloadgentoo-2-938f10b7766850389f922c725d2fa4e867a1488c.tar.gz
gentoo-2-938f10b7766850389f922c725d2fa4e867a1488c.tar.bz2
gentoo-2-938f10b7766850389f922c725d2fa4e867a1488c.zip
Pull stale versions.
Diffstat (limited to 'x11-base/opengl-update')
-rw-r--r--x11-base/opengl-update/ChangeLog8
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-1.30
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-1.40
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-1.60
-rw-r--r--x11-base/opengl-update/files/opengl-update-1.3127
-rw-r--r--x11-base/opengl-update/files/opengl-update-1.4153
-rw-r--r--x11-base/opengl-update/files/opengl-update-1.6164
-rw-r--r--x11-base/opengl-update/opengl-update-1.3.ebuild19
-rw-r--r--x11-base/opengl-update/opengl-update-1.4.ebuild20
-rw-r--r--x11-base/opengl-update/opengl-update-1.6.ebuild18
10 files changed, 7 insertions, 502 deletions
diff --git a/x11-base/opengl-update/ChangeLog b/x11-base/opengl-update/ChangeLog
index a501875a9494..9f8176e5eb89 100644
--- a/x11-base/opengl-update/ChangeLog
+++ b/x11-base/opengl-update/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-base/opengl-update
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.23 2004/06/11 02:21:38 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.24 2004/06/11 02:23:52 spyderous Exp $
+
+ 10 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
+ -files/opengl-update-1.3, -files/opengl-update-1.4,
+ -files/opengl-update-1.6, -opengl-update-1.3.ebuild,
+ -opengl-update-1.4.ebuild, -opengl-update-1.6.ebuild:
+ Pull stale versions.
10 Jun 2004; Donnie Berkholz <spyderous@gentoo.org>;
opengl-update-1.7.1.ebuild:
diff --git a/x11-base/opengl-update/files/digest-opengl-update-1.3 b/x11-base/opengl-update/files/digest-opengl-update-1.3
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/x11-base/opengl-update/files/digest-opengl-update-1.3
+++ /dev/null
diff --git a/x11-base/opengl-update/files/digest-opengl-update-1.4 b/x11-base/opengl-update/files/digest-opengl-update-1.4
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/x11-base/opengl-update/files/digest-opengl-update-1.4
+++ /dev/null
diff --git a/x11-base/opengl-update/files/digest-opengl-update-1.6 b/x11-base/opengl-update/files/digest-opengl-update-1.6
deleted file mode 100644
index e69de29bb2d1..000000000000
--- a/x11-base/opengl-update/files/digest-opengl-update-1.6
+++ /dev/null
diff --git a/x11-base/opengl-update/files/opengl-update-1.3 b/x11-base/opengl-update/files/opengl-update-1.3
deleted file mode 100644
index 2eaa7a66fe35..000000000000
--- a/x11-base/opengl-update/files/opengl-update-1.3
+++ /dev/null
@@ -1,127 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-1.3,v 1.2 2004/03/06 04:20:10 vapier Exp $
-# Author: Martin Schlemmer <azarah@gentoo.org>
-
-source /etc/init.d/functions.sh
-
-if [ `id -u` -ne 0 ]
-then
- eerror "${0}: must be root."
- exit 1
-fi
-
-usage() {
-cat << FOO
-usage: opengl-update <GL implementation>
-
-note:
- This utility switch between OpenGL implementations. Currently there
- are two supported implementations, namely "xfree" and "nvidia", the
- implementations for XFree86 and the NVidia drivers respectively.
-
-examples:
- opengl-update xfree
- This will setup things to use libGL.so from XFree86
-
- opengl-update nvidia
- This will setup things to use libGL.so from the NVidia drivers.
-
-FOO
- exit 1
-}
-
-if [ "$#" -ne 1 ]
-then
- usage
-fi
-if [ ! -d /usr/lib/opengl/${1} ]
-then
- usage
-else
- ebegin "Switching to ${1} OpenGL interface"
-
- #setup the $LDPATH
- echo "LDPATH=/usr/lib/opengl/${1}/lib" >/etc/env.d/09opengl
- /usr/sbin/env-update &>/dev/null
-
- #setup the /usr/lib/libGL.so symlink
- if [ -e /usr/lib/libGL.so ]
- then
- rm -f /usr/lib/libGL.so
- fi
- if [ -e /usr/lib/libGL.so.1 ]
- then
- rm -f /usr/lib/libGL.so.1
- fi
- realname="$(readlink /usr/lib/opengl/${1}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${1}/lib/${realname} \
- /usr/lib/libGL.so
- ln -sf /usr/lib/opengl/${1}/lib/${realname} \
- /usr/lib/libGL.so.1
-
- #setup the /usr/X11R6/lib/libMesaGL.so symlink
- if [ -e /usr/X11R6/lib/libMesaGL.so ]
- then
- rm -f /usr/X11R6/lib/libMesaGL.so
- fi
- realname="$(readlink /usr/lib/opengl/${1}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${1}/lib/${realname} \
- /usr/X11R6/lib/libMesaGL.so
-
- #setup the /usr/lib/libGLcore.so symlink
- if [ -e /usr/lib/libGLcore.so ]
- then
- rm -f /usr/lib/libGLcore.so
- fi
- if [ -e /usr/lib/libGLcore.so.1 ]
- then
- rm -f /usr/lib/libGLcore.so.1
- fi
- if [ -e /usr/lib/opengl/${1}/lib/libGLcore.so ]
- then
- realname="$(readlink /usr/lib/opengl/${1}/lib/libGLcore.so)"
- ln -sf /usr/lib/opengl/${1}/lib/${realname} \
- /usr/lib/libGLcore.so
- ln -sf /usr/lib/opengl/${1}/lib/${realname} \
- /usr/lib/libGLcore.so.1
- fi
-
- #setup the /usr/X11R6/lib/modules/extensions/libglx.so symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.so ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- if [ -e /usr/lib/opengl/${1}/extensions/libglx.so ]
- then
- ln -sf /usr/lib/opengl/${1}/extensions/libglx.so \
- /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- #setup the /usr/X11R6/lib/modules/extensions/libglx.a symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.a ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.a
- fi
- if [ -e /usr/lib/opengl/${1}/extensions/libglx.a ]
- then
- ln -sf /usr/lib/opengl/${1}/extensions/libglx.a \
- /usr/X11R6/lib/modules/extensions/libglx.a
- fi
-
- #setup the includes
- for x in gl.h glx.h glxtokens.h
- do
- if [ -e /usr/X11R6/include/GL/${x} ]
- then
- rm -f /usr/X11R6/include/GL/${x}
- fi
- ln -sf /usr/lib/opengl/${1}/include/${x} \
- /usr/X11R6/include/GL/${x}
- done
-
- eend 0
-fi
-
-
-# vim:ts=4
diff --git a/x11-base/opengl-update/files/opengl-update-1.4 b/x11-base/opengl-update/files/opengl-update-1.4
deleted file mode 100644
index c27ccde2eb54..000000000000
--- a/x11-base/opengl-update/files/opengl-update-1.4
+++ /dev/null
@@ -1,153 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-1.4,v 1.2 2004/03/06 04:20:10 vapier Exp $
-# Author: Martin Schlemmer <azarah@gentoo.org>
-
-source /etc/init.d/functions.sh
-
-if [ `id -u` -ne 0 ]
-then
- eerror "${0}: must be root."
- exit 1
-fi
-
-usage() {
-cat << FOO
-usage: opengl-update <GL implementation>
-
-note:
- This utility switch between OpenGL implementations. Currently there
- are two supported implementations, namely "xfree" and "nvidia", the
- implementations for XFree86 and the NVidia drivers respectively.
-
-examples:
- opengl-update xfree
- This will setup things to use libGL.so from XFree86
-
- opengl-update nvidia
- This will setup things to use libGL.so from the NVidia drivers.
-
-FOO
- exit 1
-}
-
-if [ "$#" -ne 1 ] && [ "$#" -eq 2 -a "$1" != "--use-old" ]
-then
- usage
-fi
-
-GL_IMPLEM=""
-
-# Only use specified implementation if it is not already selected.
-if [ "$1" = "--use-old" ]
-then
- shift
-
- if [ -f /etc/env.d/09opengl ]
- then
- source /etc/env.d/09opengl
- if [ -n "${LDPATH}" ]
- then
- GL_IMPLEM="${LDPATH/\/usr\/lib\/opengl\/}"
- GL_IMPLEM="${GL_IMPLEM/\/lib}"
- unset LDPATH
- fi
- fi
-
- if [ -z "${GL_IMPLEM}" ]
- then
- GL_IMPLEM="$1"
- fi
-else
- GL_IMPLEM="$1"
-fi
-if [ ! -d /usr/lib/opengl/${GL_IMPLEM} ]
-then
- usage
-else
- ebegin "Switching to ${GL_IMPLEM} OpenGL interface"
-
- #setup the $LDPATH
- echo "LDPATH=/usr/lib/opengl/${GL_IMPLEM}/lib" >/etc/env.d/09opengl
- /usr/sbin/env-update &>/dev/null
-
- #setup the /usr/lib/libGL.so symlink
- if [ -e /usr/lib/libGL.so ]
- then
- rm -f /usr/lib/libGL.so
- fi
- if [ -e /usr/lib/libGL.so.1 ]
- then
- rm -f /usr/lib/libGL.so.1
- fi
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGL.so
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGL.so.1
-
- #setup the /usr/X11R6/lib/libMesaGL.so symlink
- if [ -e /usr/X11R6/lib/libMesaGL.so ]
- then
- rm -f /usr/X11R6/lib/libMesaGL.so
- fi
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/X11R6/lib/libMesaGL.so
-
- #setup the /usr/lib/libGLcore.so symlink
- if [ -e /usr/lib/libGLcore.so ]
- then
- rm -f /usr/lib/libGLcore.so
- fi
- if [ -e /usr/lib/libGLcore.so.1 ]
- then
- rm -f /usr/lib/libGLcore.so.1
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so ]
- then
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGLcore.so
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGLcore.so.1
- fi
-
- #setup the /usr/X11R6/lib/modules/extensions/libglx.so symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.so ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so \
- /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- #setup the /usr/X11R6/lib/modules/extensions/libglx.a symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.a ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.a
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a \
- /usr/X11R6/lib/modules/extensions/libglx.a
- fi
-
- #setup the includes
- for x in gl.h glx.h glxtokens.h
- do
- if [ -e /usr/X11R6/include/GL/${x} ]
- then
- rm -f /usr/X11R6/include/GL/${x}
- fi
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/include/${x} \
- /usr/X11R6/include/GL/${x}
- done
-
- eend 0
-fi
-
-
-# vim:ts=4
diff --git a/x11-base/opengl-update/files/opengl-update-1.6 b/x11-base/opengl-update/files/opengl-update-1.6
deleted file mode 100644
index 054cd77c55bf..000000000000
--- a/x11-base/opengl-update/files/opengl-update-1.6
+++ /dev/null
@@ -1,164 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-1.6,v 1.3 2004/03/06 04:20:10 vapier Exp $
-# Author: Martin Schlemmer <azarah@gentoo.org>
-
-source /etc/init.d/functions.sh
-
-if [ `id -u` -ne 0 ]
-then
- eerror "${0}: must be root."
- exit 1
-fi
-
-usage() {
-cat << FOO
-usage: `basename $0` <GL implementation>
-
-note:
- This utility switches between OpenGL implementations. Currently there
- are four supported implementations, "xfree" "nvidia" "ati" and "mtx", the
- implementations for XFree86, NVidia, ATI and Matrox drivers respectively.
-
-examples:
- `basename $0` xfree
- This will setup things to use libGL.so from XFree86.
-
- `basename $0` nvidia
- This will setup things to use libGL.so from the NVidia drivers.
-
-FOO
- exit 1
-}
-
-if [ "$#" -ne 1 -a "$#" -ne 2 ] || [ "$#" -eq 2 -a "$1" != "--use-old" ]
-then
- usage
-fi
-
-GL_IMPLEM=""
-
-# Only use specified implementation if it is not already selected.
-if [ "$1" = "--use-old" ]
-then
- shift
-
- if [ -f /etc/env.d/09opengl ]
- then
- source /etc/env.d/09opengl
- if [ -n "${LDPATH}" ]
- then
- GL_IMPLEM="${LDPATH/\/usr\/lib\/opengl\/}"
- GL_IMPLEM="${GL_IMPLEM/\/lib}"
- unset LDPATH
- fi
- fi
-
- if [ -z "${GL_IMPLEM}" ]
- then
- GL_IMPLEM="$1"
- fi
-else
- GL_IMPLEM="$1"
-fi
-if [ ! -d /usr/lib/opengl/${GL_IMPLEM} ]
-then
- usage
-else
- ebegin "Switching to ${GL_IMPLEM} OpenGL interface"
-
- #setup the $LDPATH
- echo "LDPATH=/usr/lib/opengl/${GL_IMPLEM}/lib" >/etc/env.d/09opengl
- /usr/sbin/env-update &>/dev/null
-
- #setup the /usr/lib/libGL.so symlink
- if [ -e /usr/lib/libGL.so ]
- then
- rm -f /usr/lib/libGL.so
- fi
- if [ -e /usr/lib/libGL.so.1 ]
- then
- rm -f /usr/lib/libGL.so.1
- fi
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGL.so
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGL.so.1
-
- #setup the /usr/X11R6/lib/libMesaGL.so symlink
- if [ -e /usr/X11R6/lib/libMesaGL.so ]
- then
- rm -f /usr/X11R6/lib/libMesaGL.so
- fi
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/X11R6/lib/libMesaGL.so
-
- #setup the /usr/lib/libGLcore.so symlink
- if [ -e /usr/lib/libGLcore.so ]
- then
- rm -f /usr/lib/libGLcore.so
- fi
- if [ -e /usr/lib/libGLcore.so.1 ]
- then
- rm -f /usr/lib/libGLcore.so.1
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so ]
- then
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGLcore.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGLcore.so
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libGLcore.so.1
- fi
-
- #setup the /usr/lib/libGL.la symlink
- if [ -e /usr/lib/libGL.la ]
- then
- rm -f /usr/lib/libGL.la
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la \
- /usr/lib/libGL.la
- fi
-
- #setup the /usr/X11R6/lib/modules/extensions/libglx.so symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.so ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so \
- /usr/X11R6/lib/modules/extensions/libglx.so
- fi
- #setup the /usr/X11R6/lib/modules/extensions/libglx.a symlink
- if [ -e /usr/X11R6/lib/modules/extensions/libglx.a ]
- then
- rm -f /usr/X11R6/lib/modules/extensions/libglx.a
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a \
- /usr/X11R6/lib/modules/extensions/libglx.a
- fi
-
- #setup the includes
- for x in gl.h glx.h glxtokens.h
- do
- if [ -e /usr/X11R6/include/GL/${x} ]
- then
- rm -f /usr/X11R6/include/GL/${x}
- fi
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/include/${x} \
- /usr/X11R6/include/GL/${x}
- done
-
- eend 0
-fi
-
-
-# vim:ts=4
diff --git a/x11-base/opengl-update/opengl-update-1.3.ebuild b/x11-base/opengl-update/opengl-update-1.3.ebuild
deleted file mode 100644
index 34fecb4131d1..000000000000
--- a/x11-base/opengl-update/opengl-update-1.3.ebuild
+++ /dev/null
@@ -1,19 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-1.3.ebuild,v 1.11 2004/02/22 12:29:26 mr_bones_ Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Utility to change the OpenGL interface being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-SLOT="0"
-KEYWORDS="x86 ppc sparc "
-LICENSE="GPL-2"
-DEPEND="virtual/glibc"
-RDEPEND=$DEPEND
-
-src_install() {
- newsbin ${FILESDIR}/opengl-update-${PV} opengl-update
-}
-
diff --git a/x11-base/opengl-update/opengl-update-1.4.ebuild b/x11-base/opengl-update/opengl-update-1.4.ebuild
deleted file mode 100644
index 391792a44048..000000000000
--- a/x11-base/opengl-update/opengl-update-1.4.ebuild
+++ /dev/null
@@ -1,20 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-1.4.ebuild,v 1.10 2004/02/22 12:29:26 mr_bones_ Exp $
-
-S=${WORKDIR}/${P}
-DESCRIPTION="Utility to change the OpenGL interface being used."
-SRC_URI=""
-HOMEPAGE="http://www.gentoo.org/"
-
-KEYWORDS="x86 ppc sparc alpha hppa amd64 mips"
-SLOT="0"
-LICENSE="GPL-2"
-
-DEPEND="virtual/glibc"
-
-
-src_install() {
- newsbin ${FILESDIR}/opengl-update-${PV} opengl-update
-}
-
diff --git a/x11-base/opengl-update/opengl-update-1.6.ebuild b/x11-base/opengl-update/opengl-update-1.6.ebuild
deleted file mode 100644
index 5e20dee7369c..000000000000
--- a/x11-base/opengl-update/opengl-update-1.6.ebuild
+++ /dev/null
@@ -1,18 +0,0 @@
-# Copyright 1999-2004 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-1.6.ebuild,v 1.2 2004/04/28 22:18:25 vapier Exp $
-
-DESCRIPTION="Utility to change the OpenGL interface being used"
-HOMEPAGE="http://www.gentoo.org/"
-SRC_URI=""
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~mips ~alpha arm ~hppa ~amd64 ~ia64"
-IUSE=""
-
-DEPEND="virtual/glibc"
-
-src_install() {
- newsbin ${FILESDIR}/opengl-update-${PV} opengl-update || die
-}