summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-04-03 19:32:00 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-04-03 19:32:00 +0000
commit75e93398d84b324036a1651e5a869cc974a4099c (patch)
treecf63d268c75505c7b65b35c5aa6e3fdb8aed6c95 /x11-base/opengl-update
parentCosmetic. (diff)
downloadgentoo-2-75e93398d84b324036a1651e5a869cc974a4099c.tar.gz
gentoo-2-75e93398d84b324036a1651e5a869cc974a4099c.tar.bz2
gentoo-2-75e93398d84b324036a1651e5a869cc974a4099c.zip
Removing old versions.
(Portage version: 2.0.51.19)
Diffstat (limited to 'x11-base/opengl-update')
-rw-r--r--x11-base/opengl-update/ChangeLog7
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-2.0_pre4-r11
-rw-r--r--x11-base/opengl-update/files/digest-opengl-update-2.1.12
-rwxr-xr-xx11-base/opengl-update/files/opengl-update-2.0_pre4379
-rw-r--r--x11-base/opengl-update/opengl-update-2.0_pre4-r1.ebuild61
-rw-r--r--x11-base/opengl-update/opengl-update-2.1.1.ebuild82
6 files changed, 6 insertions, 526 deletions
diff --git a/x11-base/opengl-update/ChangeLog b/x11-base/opengl-update/ChangeLog
index 0195233d7647..4fc074eaa147 100644
--- a/x11-base/opengl-update/ChangeLog
+++ b/x11-base/opengl-update/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-base/opengl-update
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.83 2005/03/11 02:31:57 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/ChangeLog,v 1.84 2005/04/03 19:32:00 eradicator Exp $
+
+ 03 Apr 2005; Jeremy Huddleston <eradicator@gentoo.org>
+ -files/opengl-update-2.0_pre4, -opengl-update-2.0_pre4-r1.ebuild,
+ -opengl-update-2.1.1.ebuild:
+ Removing old versions.
10 Mar 2005; Donnie Berkholz <spyderous@gentoo.org>;
opengl-update-2.1.1-r1.ebuild:
diff --git a/x11-base/opengl-update/files/digest-opengl-update-2.0_pre4-r1 b/x11-base/opengl-update/files/digest-opengl-update-2.0_pre4-r1
deleted file mode 100644
index 23c2e8979086..000000000000
--- a/x11-base/opengl-update/files/digest-opengl-update-2.0_pre4-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e16a3144742d1a5409fe18477a88f8b6 glext.h-20040830.bz2 30982
diff --git a/x11-base/opengl-update/files/digest-opengl-update-2.1.1 b/x11-base/opengl-update/files/digest-opengl-update-2.1.1
deleted file mode 100644
index 6a175f487f3b..000000000000
--- a/x11-base/opengl-update/files/digest-opengl-update-2.1.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 ad3eba2841c01c0a94b6477d11d5ac31 glext.h-26.bz2 32485
-MD5 3260a509b23a3519b8df335a4e8f5e1d glxext.h-10.bz2 5895
diff --git a/x11-base/opengl-update/files/opengl-update-2.0_pre4 b/x11-base/opengl-update/files/opengl-update-2.0_pre4
deleted file mode 100755
index b53612769083..000000000000
--- a/x11-base/opengl-update/files/opengl-update-2.0_pre4
+++ /dev/null
@@ -1,379 +0,0 @@
-#!/bin/bash
-# Copyright 1999-2004 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-2.0_pre4,v 1.3 2004/12/27 00:06:04 cyfred Exp $
-# Author: Martin Schlemmer <azarah@gentoo.org>
-# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
-# Further modifications based off submissions to bug #54984 <cyfred@gentoo.org>
-
-. /etc/init.d/functions.sh
-
-need_version() {
- local X11 X11_VER X11_MAJOR_VER X11_MINOR_VER X11_MICRO_VER ERROR_MSG
- ERROR_MSG="This version requires >=x11-base/xorg-x11-6.8.0-r4"
- X11="$(portageq match / virtual/x11)"
- # Got the egrep from ferringb, who got it from portage code
- X11_VER="$(echo ${X11} | egrep -o '(cvs\.)?([[:digit:]]+)((\.[[:digit:]]+)*)([a-z]?)((_(pre|p|beta|alpha|rc)[[:digit:]]*)*)(-r([[:digit:]]+))?$')"
- X11_MAJOR_VER="${X11_VER%%.*}"
- # Hack around a little to get the minor version
- X11_MINOR_VER="${X11_VER#*.}"
- X11_MINOR_VER="${X11_MINOR_VER%%.*}"
- X11_REVISION_VER="${X11_VER##*-r}"
-
- # If version <6.*, die
- if [ ${X11_MAJOR_VER} -lt 6 ]
- then
- einfo "Detected X ${X11_MAJOR_VER}.${X11_MINOR_VER} series, revision ${X11_REVISION_VER}"
- eerror "${ERROR_MSG}"
- exit 1
- # If version =6.* and <6.8.*, die
- elif [ ${X11_MAJOR_VER} -eq 6 -a ${X11_MINOR_VER} -lt 8 ]
- then
- einfo "Detected X ${X11_MAJOR_VER}.${X11_MINOR_VER} series, revision ${X11_REVISION_VER}"
- eerror "${ERROR_MSG}"
- exit 1
- # If version =6.8.0 and <r4, die
- elif [ "${X11_VER}" = "6.8.0" ]
- then
- if [ ! ${X11_REVISION_VER} -lt 4 ]
- then
- einfo "Detected X ${X11_MAJOR_VER}.${X11_MINOR_VER} series, revision ${X11_REVISION_VER}"
- eerror "${ERROR_MSG}"
- exit 1
- fi
- fi
-}
-
-count_implementations() {
- local DIR
- COUNT="0"
- for DIR in $(ls /usr/lib/opengl)
- do
- if [ "${DIR}" != "global" ]
- then
- DIRS="${DIRS} ${DIR}"
- COUNT="$((COUNT + 1))"
- fi
- done
-}
-
-usage() {
-# In addition to the below function, there are two extra uses for this.
-#
-# They aren't in the printed help message because they're intended
-# for developer use.
-# 1) --use-old $NEW_IMPLEM will switch to the new implementation only if
-# no old setup existed (i.e., X has never been installed)
-# 2) --get-implementation will return the implementation
-
-count_implementations
-
-# Get grammar right in message
-local IS_ARE IMPLEM_PLURAL
-if [ ${COUNT} -eq 1 ]
-then
- IS_ARE="is"
- IMPLEM_PLURAL=""
-else
- IS_ARE="are"
- IMPLEM_PLURAL="s"
-fi
-
-cat << FOO
-usage: ${0##*/} <GL implementation>
-
-note:
- This utility switches between OpenGL implementations. There ${IS_ARE}
- ${COUNT} available implementation${IMPLEM_PLURAL}: ${DIRS}.
-
-examples:
- ${0##*/} xorg-x11
- This will setup things to use libGL.so from X.org.
-
- ${0##*/} nvidia
- This will setup things to use libGL.so from the nVidia drivers.
-
-FOO
- exit 1
-}
-
-need_version
-
-if [ "$#" -ne 1 -a "$#" -ne 2 ] || \
- [ "$#" -eq 2 -a "$1" != "--use-old" ]
-then
- usage
-fi
-
-GL_IMPLEM=""
-
-# Discover GL implementation if it exists
-get_implem() {
- if [ -f /etc/env.d/09opengl ]
- then
- source /etc/env.d/09opengl
- if [ -n "${LDPATH}" ]
- then
- GL_IMPLEM="${LDPATH/:\*/}"
- GL_IMPLEM="${GL_IMPLEM/\/usr\/lib\/opengl\/}"
- GL_IMPLEM="${GL_IMPLEM/\/lib}"
- unset LDPATH
- fi
- fi
-}
-
-# Return current GL implementation
-if [ "$1" = "--get-implementation" ]
-then
- get_implem
-
- if [ -n "${GL_IMPLEM}" ]
- then
- echo "${GL_IMPLEM}"
- fi
-
- if [ -z "${GL_IMPLEM}" ]
- then
- exit 2
- fi
-
- exit 0
-fi
-
-if [ $(id -u) -ne 0 ]
-then
- eerror "${0}: must be root."
- exit 1
-fi
-
-# Only use specified implementation if it is not already selected.
-if [ "$1" = "--use-old" ]
-then
- shift
-
- get_implem
-
- if [ -z "${GL_IMPLEM}" ]
- then
- GL_IMPLEM="$1"
- fi
-else
- GL_IMPLEM="$1"
-fi
-
-if [ ! -d /usr/lib/opengl/${GL_IMPLEM} ]
-then
- usage
-fi
-
-ebegin "Switching to ${GL_IMPLEM} OpenGL interface"
-
- # Provide the right libnvidia-tls depending on ntpl or not
- if [ "${GL_IMPLEM}" = "nvidia" ]
- then
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/tls ]
- then
- rm -f /usr/lib/opengl/${GL_IMPLEM}/lib/tls
- fi
-
-# This was the nvidia approach but it seems to not work, new method
-# as suggested on various bug reports, #64927, #70545
-# /usr/lib/misc/tls_test /usr/lib/misc/tls_test_dso.so 2>/dev/null
- getconf GNU_LIBPTHREAD_VERSION | grep -i nptl > /dev/null
- if [ ${?} = 0 ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/tls /usr/lib/opengl/${GL_IMPLEM}/lib/tls
- if [ -d /usr/lib32/opengl/${GL_IMPLEM} ]
- then
- ln -sf /usr/lib32/opengl/${GL_IMPLEM}/tls /usr/lib32/opengl/${GL_IMPLEM}/lib/tls
- fi
- fi
- fi
-
- # Setup the $LDPATH
- echo "LDPATH=/usr/lib/opengl/${GL_IMPLEM}/lib" > /etc/env.d/09opengl
- # Check if we need 32 bit compatibility
- if [ -d /usr/lib32/opengl/${GL_IMPLEM} ]
- then
- source /etc/env.d/09opengl
- echo "LDPATH=${LDPATH}:/usr/lib32/opengl/${GL_IMPLEM}/lib" > /etc/env.d/09opengl
- unset LDPATH
-
- # We also need to make TLS directories now aswell, make 32bit one here
- lib32="$(readlink /usr/lib32)"
- if [ -h ${lib32}/tls ]
- then
- rm -f ${lib32}/tls
- fi
- if [ ! -d ${lib32}/tls ]
- then
- mkdir -p ${lib32}/tls
- fi
-
- fi
-
- # System wide tls stuff
- if [ -h /usr/lib/tls ]
- then
- rm -f /usr/lib/tls
- fi
- if [ ! -d /usr/lib/tls ]
- then
- mkdir -p /usr/lib/tls
- fi
-
- /usr/sbin/env-update &>/dev/null
-
- LIBDIRS="lib lib32"
- for LIBDIR in ${LIBDIRS}
- do
- # If there is a 32 bit compatibility implementation we shall use it
- # Otherwise we want to have some compatibility GL, use xorg-x11.
- if [ "${LIBDIR}" = "lib32" ] && [ ! -d /usr/lib32/opengl/"${GL_IMPLEM}" ]
- then
- GL_LOCAL="xorg-x11"
- else
- GL_LOCAL="${GL_IMPLEM}"
- fi
-
- #setup the /usr/lib/libGL.so symlink
- if [ -e /usr/${LIBDIR}/libGL.so ]
- then
- rm -f /usr/${LIBDIR}/libGL.so
- fi
- if [ -e /usr/${LIBDIR}/libGL.so.1 ]
- then
- rm -f /usr/${LIBDIR}/libGL.so.1
- fi
- if [ -e /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/libGL.so ]
- then
- realname="$(readlink /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/libGL.so)"
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libGL.so
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libGL.so.1
- fi
-
- # Setup the /usr/lib/libGLcore.so symlink
- if [ -e /usr/${LIBDIR}/libGLcore.so ]
- then
- rm -f /usr/${LIBDIR}/libGLcore.so
- fi
- if [ -e /usr/${LIBDIR}/libGLcore.so.1 ]
- then
- rm -f /usr/${LIBDIR}/libGLcore.so.1
- fi
- if [ -e /usr/${LIBDIR}/opengl/${GL_IMPLEM}/lib/libGLcore.so ]
- then
- realname="$(readlink /usr/${LIBDIR}/opengl/${GL_IMPLEM}/lib/libGLcore.so)"
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libGLcore.so
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libGLcore.so.1
- fi
-
- # Now setup the TLS library links
- if [ -e /usr/${LIBDIR}/libnvidia-tls.so ]
- then
- rm -f /usr/${LIBDIR}/libnvidia-tls.so
- fi
- if [ -e /usr/${LIBDIR}/libnvidia-tls.so.1 ]
- then
- rm -f /usr/${LIBDIR}/libnvidia-tls.so.1
- fi
- if [ -e /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/tls/libnvidia-tls.so.1 ]
- then
- realtls="$(readlink /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/tls/libnvidia-tls.so.1)"
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/tls/${realtls} \
- /usr/${LIBDIR}/tls/libnvidia-tls.so
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/tls/${realtls} \
- /usr/${LIBDIR}/tls/libnvidia-tls.so.1
- fi
- if [ -e /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/libnvidia-tls.so.1 ]
- then
- realname="$(readlink /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/libnvidia-tls.so.1)"
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libnvidia-tls.so
- ln -sf /usr/${LIBDIR}/opengl/${GL_LOCAL}/lib/${realname} \
- /usr/${LIBDIR}/libnvidia-tls.so.1
- fi
- done
-
- # Setup the /usr/lib/libMesaGL.so symlink
- if [ -e /usr/lib/libMesaGL.so ]
- then
- rm -f /usr/lib/libMesaGL.so
- fi
- realname="$(readlink /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.so)"
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/${realname} \
- /usr/lib/libMesaGL.so
-
- # Setup the /usr/lib/libGL.la symlink
- if [ -e /usr/lib/libGL.la ]
- then
- rm -f /usr/lib/libGL.la
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/lib/libGL.la \
- /usr/lib/libGL.la
- fi
-
- # Fix libtool archives (#48297)
- CURDIR="$(pwd)"
- cd /usr/lib
- if [ "`grep -l /usr/lib/opengl *.la`" ]
- then
- sed -i 's:/usr/lib/opengl/[^/]*/lib/libGL.la:/usr/lib/libGL.la:' \
- `grep -l /usr/lib/opengl *.la`
- fi
- cd ${CURDIR}
-
- # Setup the /usr/lib/modules/extensions/libglx.so symlink
- if [ -e /usr/lib/modules/extensions/libglx.so ]
- then
- rm -f /usr/lib/modules/extensions/libglx.so
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.so \
- /usr/lib/modules/extensions/libglx.so
- fi
-
- #setup the /usr/lib/modules/extensions/libglx.a symlink
- if [ -e /usr/lib/modules/extensions/libglx.a ]
- then
- rm -f /usr/lib/modules/extensions/libglx.a
- fi
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/extensions/libglx.a \
- /usr/lib/modules/extensions/libglx.a
- fi
-
- #setup the includes
- for x in gl.h glx.h glxtokens.h glext.h
- do
- if [ -e /usr/X11R6/include/GL/${x} ]
- then
- rm -f /usr/X11R6/include/GL/${x}
- fi
-
- # IMPORTANT
- # It is preferable currently to use the standard glext.h file
- # however if an OpenGL provider must use a self produced glext.h
- # then it should be installed to ${GL_IMPLEM}/include
-
- if [ -e /usr/lib/opengl/${GL_IMPLEM}/include/${x} ]
- then
- ln -sf /usr/lib/opengl/${GL_IMPLEM}/include/${x} \
- /usr/X11R6/include/GL/${x}
- else
- ln -sf /usr/lib/opengl/global/include/${x} \
- /usr/X11R6/include/GL/${x}
- fi
- done
-
-eend 0
-
-# vim:ts=4
diff --git a/x11-base/opengl-update/opengl-update-2.0_pre4-r1.ebuild b/x11-base/opengl-update/opengl-update-2.0_pre4-r1.ebuild
deleted file mode 100644
index b06755ea0345..000000000000
--- a/x11-base/opengl-update/opengl-update-2.0_pre4-r1.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-2.0_pre4-r1.ebuild,v 1.6 2005/02/05 17:41:32 cryos Exp $
-
-DESCRIPTION="Utility to change the OpenGL interface being used"
-HOMEPAGE="http://www.gentoo.org/"
-GLEXT="20040830"
-SRC_URI="http://dev.gentoo.org/~cyfred/distfiles/glext.h-${GLEXT}.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 mips ~ppc ~ppc64 ~s390 sparc x86"
-IUSE=""
-
-DEPEND="virtual/libc
- app-arch/bzip2"
-
-pkg_setup() {
- # xfree has glext.h somewhere out of place so lets make the user move it
- if ( [ ! -h /usr/X11R6/include/GL/glext.h ] && [ -a /usr/X11R6/include/GL/glext.h ] )
- then
- # Just make it simpler on the user by giving verbose instructions
- if [ -d /usr/lib/opengl/xfree ]
- then
- GL_IM="xfree"
- else
- GL_IM="xorg-x11"
- fi
-
- echo
- ewarn "Due to inconsistencies in xorg-x11 vs xfree handling of glext.h a userspace"
- ewarn "is necessary for you to use opengl-update-1.8; Please do the following"
- echo
- ewarn "mv /usr/X11R6/include/GL/glext.h /usr/lib/opengl/${GL_IM}/include"
- echo
- ewarn "You may then remerge opengl-update-1.8.1 successfully"
- echo
-
- die "Userspace problem needs fixing"
- fi
-}
-
-src_unpack() {
- bzcat ${DISTDIR}/glext.h-${GLEXT}.bz2 > ${WORKDIR}/glext.h || die
-}
-
-src_install() {
- newsbin ${FILESDIR}/opengl-update-${PV} opengl-update || die
-
- # Install default glext.h
- dodir /usr/lib/opengl/global/include
- insinto /usr/lib/opengl/global/include
- doins ${WORKDIR}/glext.h || die
-}
-
-pkg_postinst() {
- echo
- ewarn "This version will only work with >=x11-base/xorg-x11-6.8.0-r4."
- ewarn "Upgrade before running ${PN}."
- echo
-}
diff --git a/x11-base/opengl-update/opengl-update-2.1.1.ebuild b/x11-base/opengl-update/opengl-update-2.1.1.ebuild
deleted file mode 100644
index d428beb0805f..000000000000
--- a/x11-base/opengl-update/opengl-update-2.1.1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-2.1.1.ebuild,v 1.1 2005/02/10 06:45:38 eradicator Exp $
-
-inherit multilib toolchain-funcs
-
-DESCRIPTION="Utility to change the OpenGL interface being used"
-HOMEPAGE="http://www.gentoo.org/"
-
-# Source:
-# http://oss.sgi.com/projects/ogl-sample/ABI/glext.h
-# http://oss.sgi.com/projects/ogl-sample/ABI/glxext.h
-
-GLEXT="26"
-GLXEXT="10"
-
-SRC_URI="http://dev.gentoo.org/~eradicator/opengl/glext.h-${GLEXT}.bz2
- http://dev.gentoo.org/~eradicator/opengl/glxext.h-${GLXEXT}.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE=""
-RESTRICT="multilib-pkg-force"
-
-DEPEND="virtual/libc
- app-arch/bzip2"
-
-RDEPEND="!x11-base/xfree86
- !<x11-base/xorg-x11-6.8.0-r4
- !<media-video/ati-drivers-8.8.25-r3"
-
-S="${WORKDIR}"
-
-src_unpack() {
- unpack ${A}
-
- # Bug #81199
- sed -i 's/^#warn /#warning /' glxext.h-${GLXEXT}
-}
-
-pkg_preinst() {
- # It needs to be before 04multilib
- [ -f "${ROOT}/etc/env.d/09opengl" ] && mv ${ROOT}/etc/env.d/09opengl ${ROOT}/etc/env.d/03opengl
-
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- if [ -e "${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so" ]; then
- einfo "Removing libMesaGL.so from xorg-x11 profile. See bug #47598."
- rm -f ${ROOT}/usr/$(get_libdir)/opengl/xorg-x11/lib/libMesaGL.so
- fi
- if [ -e "${ROOT}/usr/$(get_libdir)/libMesaGL.so" ]; then
- einfo "Removing libMesaGL.so from /usr/$(get_libdir). See bug #47598."
- rm -f ${ROOT}/usr/$(get_libdir)/libMesaGL.so
- fi
- done
- ABI="${OABI}"
- unset OABI
-}
-
-src_install() {
- newsbin ${FILESDIR}/opengl-update-${PV} opengl-update || die
-
- # MULTILIB-CLEANUP: Fix this when FEATURES=multilib-pkg is in portage
- local MLTEST=$(type dyn_unpack)
- if has_multilib_profile && [ "${MLTEST/set_abi}" = "${MLTEST}" ]; then
- OABI="${ABI}"
- for ABI in $(get_install_abis); do
- # Install default glext.h
- insinto /usr/$(get_libdir)/opengl/global/include
- newins ${WORKDIR}/glext.h-${GLEXT} glext.h || die
- newins ${WORKDIR}/glxext.h-${GLXEXT} glxext.h || die
- done
- ABI="${OABI}"
- unset OABI
- else
- # Install default glext.h
- insinto /usr/$(get_libdir)/opengl/global/include
- newins ${WORKDIR}/glext.h-${GLEXT} glext.h || die
- newins ${WORKDIR}/glxext.h-${GLXEXT} glxext.h || die
- fi
-}