summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Huddleston <eradicator@gentoo.org>2005-08-17 21:51:02 +0000
committerJeremy Huddleston <eradicator@gentoo.org>2005-08-17 21:51:02 +0000
commit42263aaf66fb41c0a2aa3f1006261456d7ed1b37 (patch)
tree07c1e864451cb773febd23dc558e62da56cb028e /x11-base/opengl-update
parentMark -alpha since varargs stuff is broken (diff)
downloadgentoo-2-42263aaf66fb41c0a2aa3f1006261456d7ed1b37.tar.gz
gentoo-2-42263aaf66fb41c0a2aa3f1006261456d7ed1b37.tar.bz2
gentoo-2-42263aaf66fb41c0a2aa3f1006261456d7ed1b37.zip
Added a deprecation notice to opengl-update-3.0.0
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-base/opengl-update')
-rwxr-xr-xx11-base/opengl-update/files/opengl-update-3.0.014
-rw-r--r--x11-base/opengl-update/opengl-update-3.0.0.ebuild7
2 files changed, 17 insertions, 4 deletions
diff --git a/x11-base/opengl-update/files/opengl-update-3.0.0 b/x11-base/opengl-update/files/opengl-update-3.0.0
index a542e1266cbf..436a6434e174 100755
--- a/x11-base/opengl-update/files/opengl-update-3.0.0
+++ b/x11-base/opengl-update/files/opengl-update-3.0.0
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0,v 1.3 2005/08/13 07:54:39 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/files/opengl-update-3.0.0,v 1.4 2005/08/17 21:51:02 eradicator Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
# Further modifications by Donnie Berkholz <spyderous@gentoo.org>
# Further modifications based off submissions to bug #54984 <cyfred@gentoo.org>
@@ -48,8 +48,8 @@ Examples:
This will setup things to use libGL.so from the nVidia drivers.
WARNING: opengl-update is deprecated and is just a frontend to the opengl
- eselect module. A future version will drop support for the
- opengl-update command. Please see 'eselect opengl help'
+ eselect module. In the future, opengl-update will be removed
+ from portage. Please see 'eselect opengl help'
FOO
}
@@ -138,10 +138,18 @@ case ${ACTION} in
eselect opengl show
;;
old-implementation)
+ ewarn "opengl-update is deprecated and is just a frontend to the opengl"
+ ewarn "eselect module. In the future, opengl-update will be removed"
+ ewarn "from portage. Please see 'eselect opengl help'"
+
eselect opengl set --use-old
exit $?
;;
set-implementation)
+ ewarn "opengl-update is deprecated and is just a frontend to the opengl"
+ ewarn "eselect module. In the future, opengl-update will be removed"
+ ewarn "from portage. Please see 'eselect opengl help'"
+
if [[ ${USE_PROFILE_HEADERS} == "yes" ]] ; then
eselect opengl set ${NEW_GL_IMPLEM} --prefix="${PREFIX}" --dst-prefix="${DST_PREFIX}" --impl-headers
else
diff --git a/x11-base/opengl-update/opengl-update-3.0.0.ebuild b/x11-base/opengl-update/opengl-update-3.0.0.ebuild
index eedf3b2df366..bb38c56c4768 100644
--- a/x11-base/opengl-update/opengl-update-3.0.0.ebuild
+++ b/x11-base/opengl-update/opengl-update-3.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-3.0.0.ebuild,v 1.2 2005/08/17 21:43:19 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-base/opengl-update/opengl-update-3.0.0.ebuild,v 1.3 2005/08/17 21:51:02 eradicator Exp $
DESCRIPTION="Utility to change the OpenGL interface being used"
HOMEPAGE="http://www.gentoo.org/"
@@ -17,3 +17,8 @@ RDEPEND="app-admin/eselect-opengl"
src_install() {
newsbin ${FILESDIR}/opengl-update-${PV} opengl-update || die
}
+
+pkg_postinst() {
+ einfo "opengl-update is deprecated and will eventually be removed from portage."
+ einfo "The opengl-update executable just calls the opengl eselect module."
+}