summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-04-26 18:58:14 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-04-26 18:58:14 +0000
commitf0dc6e28305596caea264191087317cf8d47ae1a (patch)
treecc491d5f3f78563c045f10a2f146fb800cc0c527 /x11-apps
parentversion bump (diff)
downloadgentoo-2-f0dc6e28305596caea264191087317cf8d47ae1a.tar.gz
gentoo-2-f0dc6e28305596caea264191087317cf8d47ae1a.tar.bz2
gentoo-2-f0dc6e28305596caea264191087317cf8d47ae1a.zip
Revision bump to fix building with new xcb-util. Per bug #364967.
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'x11-apps')
-rw-r--r--x11-apps/xlsclients/ChangeLog8
-rw-r--r--x11-apps/xlsclients/files/1.1.1-xcb_util.patch59
-rw-r--r--x11-apps/xlsclients/xlsclients-1.1.1-r1.ebuild21
3 files changed, 87 insertions, 1 deletions
diff --git a/x11-apps/xlsclients/ChangeLog b/x11-apps/xlsclients/ChangeLog
index 37b76f546b1a..08af94197248 100644
--- a/x11-apps/xlsclients/ChangeLog
+++ b/x11-apps/xlsclients/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-apps/xlsclients
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-apps/xlsclients/ChangeLog,v 1.53 2011/02/14 18:43:22 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xlsclients/ChangeLog,v 1.54 2011/04/26 18:58:14 scarabeus Exp $
+
+*xlsclients-1.1.1-r1 (26 Apr 2011)
+
+ 26 Apr 2011; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/1.1.1-xcb_util.patch, +xlsclients-1.1.1-r1.ebuild:
+ Revision bump to fix building with new xcb-util. Per bug #364967.
14 Feb 2011; Kacper Kowalik <xarthisius@gentoo.org>
xlsclients-1.1.1.ebuild:
diff --git a/x11-apps/xlsclients/files/1.1.1-xcb_util.patch b/x11-apps/xlsclients/files/1.1.1-xcb_util.patch
new file mode 100644
index 000000000000..3752b7036288
--- /dev/null
+++ b/x11-apps/xlsclients/files/1.1.1-xcb_util.patch
@@ -0,0 +1,59 @@
+From 223851b68fedad730747652bc6560e40ca695ea7 Mon Sep 17 00:00:00 2001
+From: Jon TURNEY <jon.turney@dronecode.org.uk>
+Date: Mon, 07 Mar 2011 13:54:53 +0000
+Subject: Use XCB_ATOM_* atom names rather than deprecated atom names
+
+Those deprecated atom names were removed from xcb/util in commit
+2f0334b3eb49fa3a0d6daf6b9dde10e480a5c59f
+
+Found by tinderbox, see:
+
+http://tinderbox.freedesktop.org/builds/2011-03-06-0008/logs/xlsclients/#build
+http://tinderbox.freedesktop.org/builds/2011-03-07-0001/logs/xlsclients/#build
+
+Signed-off-by: Jon TURNEY <jon.turney@dronecode.org.uk>
+Tested-by: Dan Nicholson <dbn.lists@gmail.com>
+Signed-off-by: Peter Harris <pharris@opentext.com>
+---
+diff --git a/xlsclients.c b/xlsclients.c
+index 3a34865..15d3f1a 100644
+--- a/xlsclients.c
++++ b/xlsclients.c
+@@ -539,21 +539,21 @@ print_client_properties(xcb_connection_t *dpy, xcb_window_t w, int verbose, int
+ * get the WM_CLIENT_MACHINE and WM_COMMAND list of strings
+ */
+ cs->client_machine = xcb_get_property(dpy, 0, w,
+- WM_CLIENT_MACHINE, XCB_GET_PROPERTY_TYPE_ANY,
++ XCB_ATOM_WM_CLIENT_MACHINE, XCB_GET_PROPERTY_TYPE_ANY,
+ 0, 1000000L);
+ cs->command = xcb_get_property(dpy, 0, w,
+- WM_COMMAND, XCB_GET_PROPERTY_TYPE_ANY,
++ XCB_ATOM_WM_COMMAND, XCB_GET_PROPERTY_TYPE_ANY,
+ 0, 1000000L);
+
+ if (verbose) {
+ cs->name = xcb_get_property(dpy, 0, w,
+- WM_NAME, XCB_GET_PROPERTY_TYPE_ANY,
++ XCB_ATOM_WM_NAME, XCB_GET_PROPERTY_TYPE_ANY,
+ 0, 1000000L);
+ cs->icon_name = xcb_get_property(dpy, 0, w,
+- WM_ICON_NAME, XCB_GET_PROPERTY_TYPE_ANY,
++ XCB_ATOM_WM_ICON_NAME, XCB_GET_PROPERTY_TYPE_ANY,
+ 0, 1000000L);
+ cs->wm_class = xcb_get_property(dpy, 0, w,
+- WM_CLASS, STRING,
++ XCB_ATOM_WM_CLASS, XCB_ATOM_STRING,
+ 0, 1000000L);
+ }
+
+@@ -569,7 +569,7 @@ print_text_field(xcb_connection_t *dpy, char *s, xcb_get_property_reply_t *tp)
+ }
+
+ if (s) printf ("%s", s);
+- if (tp->type == STRING && tp->format == 8) {
++ if (tp->type == XCB_ATOM_STRING && tp->format == 8) {
+ printf ("%.*s", (int)tp->value_len, (char *)xcb_get_property_value(tp));
+ } else {
+ unknown (dpy, tp->type, tp->format);
+--
+cgit v0.8.3-6-g21f6
diff --git a/x11-apps/xlsclients/xlsclients-1.1.1-r1.ebuild b/x11-apps/xlsclients/xlsclients-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..b1fec39ec6db
--- /dev/null
+++ b/x11-apps/xlsclients/xlsclients-1.1.1-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-apps/xlsclients/xlsclients-1.1.1-r1.ebuild,v 1.1 2011/04/26 18:58:14 scarabeus Exp $
+
+EAPI=3
+
+inherit xorg-2
+
+DESCRIPTION="X.Org xlsclients application"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util
+"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PV}-xcb_util.patch"
+)